GUI.PythonApi Namespace

CollapseAll image | DropDown image
C#

Visual Basic

Visual C++

Iron Python

PLANTA API to IronPython
GUI.PythonApi Namespace
Root namespace of Python API. Contains three subnamespaces: Data, Customizing and Layout Class Diagram of Python API to GUI elements

Types

All Types | Interfaces | Enumerations
Name | Description
Environment | Defines Python contract on Environment
Logger | Defines Python contract on Logger
PpmsPanel | Defines Python contract on PpmsPanel
ShadingWindow | Defines Python contract on ShadingWindow
WindowState | Panel window state Data Type

PLANTA GmbH


Environment Interface

Iron Python

| Members | See Also
PLANTA API to IronPython
Environment Interface
Defines Python contract on Environment

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
public interface Environment
Public Interface Environment
public interface class Environment
public abstract class Environment

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ChangeSetID | ChangeSetID - the latest TFS changeset ID of the current build
GeneratePdfFile(List<(Of <<'(PdfExportDocument>)>>), String, String) | Generate PDF file from pdf export documents list.
Logger | Class for output messages
MinimizePanels()()()() | Minimize panels
PdfExportDocumentsList | Get PdfExportDocument list needed for PDF file generation.
RestorePanels()()()() | Restore panels
TotalBusyModeOff()()()() | Disables total busy mode
TotalBusyModeOn()()()() | Enables total busy mode

See Also

GUI.PythonApi Namespace


Environment Methods

Iron Python

| See Also
PLANTA API to IronPython
Environment Methods

The Environment type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
GeneratePdfFile(List<(Of <<'(PdfExportDocument>)>>), String, String) | Generate PDF file from pdf export documents list.
MinimizePanels()()()() | Minimize panels
RestorePanels()()()() | Restore panels
TotalBusyModeOff()()()() | Disables total busy mode
TotalBusyModeOn()()()() | Enables total busy mode

See Also

Environment Interface
GUI.PythonApi Namespace


GeneratePdfFile Method

Iron Python

Environment..::GeneratePdfFile Method
Generate PDF file from pdf export documents list.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
string GeneratePdfFile(
    List<PdfExportDocument> documentsList,
    string path,
    string name
)
Function GeneratePdfFile ( _
    documentsList As List(Of PdfExportDocument), _
    path As String, _
    name As String _
) As String
String^ GeneratePdfFile(
    List<PdfExportDocument^>^ documentsList,
    String^ path,
    String^ name
)
def GeneratePdfFile(
    documentsList : List[PdfExportDocument],
    path : str,
    name : str
) : str

Parameters

documentsList
List <(Of <(<' PdfExportDocument >)>)>
pdf export documents list
path
String
path to file
name
String
Name of the output file

Return Value

PDF file full name if generation is successfull, empty string otherwise

See Also

Environment Interface
GUI.PythonApi Namespace


MinimizePanels Method

Iron Python

Environment..::MinimizePanels Method
Minimize panels

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
void MinimizePanels()
Sub MinimizePanels
void MinimizePanels()
def MinimizePanels()

See Also

Environment Interface
GUI.PythonApi Namespace


RestorePanels Method

Iron Python

Environment..::RestorePanels Method
Restore panels

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
void RestorePanels()
Sub RestorePanels
void RestorePanels()
def RestorePanels()

See Also

Environment Interface
GUI.PythonApi Namespace


TotalBusyModeOff Method

Iron Python

Environment..::TotalBusyModeOff Method
Disables total busy mode

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
void TotalBusyModeOff()
Sub TotalBusyModeOff
void TotalBusyModeOff()
def TotalBusyModeOff()

See Also

Environment Interface
GUI.PythonApi Namespace


TotalBusyModeOn Method

Iron Python

Environment..::TotalBusyModeOn Method
Enables total busy mode

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
void TotalBusyModeOn()
Sub TotalBusyModeOn
void TotalBusyModeOn()
def TotalBusyModeOn()

See Also

Environment Interface
GUI.PythonApi Namespace


Environment Properties

Iron Python

Environment Properties

The Environment type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ChangeSetID | ChangeSetID - the latest TFS changeset ID of the current build
Logger | Class for output messages
PdfExportDocumentsList | Get PdfExportDocument list needed for PDF file generation.

See Also

Environment Interface
GUI.PythonApi Namespace


ChangeSetID Property

Iron Python

Environment..::ChangeSetID Property
ChangeSetID - the latest TFS changeset ID of the current build

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
string ChangeSetID { get; }
ReadOnly Property ChangeSetID As String
    Get
property String^ ChangeSetID {
    String^ get ();
}
property ChangeSetID : str
 get

See Also

Environment Interface
GUI.PythonApi Namespace


Logger Property

Iron Python

Environment..::Logger Property
Class for output messages

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
Logger Logger { get; }
ReadOnly Property Logger As Logger
    Get
property Logger^ Logger {
    Logger^ get ();
}
property Logger : Logger
 get

See Also

Environment Interface
GUI.PythonApi Namespace


PdfExportDocumentsList Property

Iron Python

Environment..::PdfExportDocumentsList Property
Get PdfExportDocument list needed for PDF file generation.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
List<PdfExportDocument> PdfExportDocumentsList { get; }
ReadOnly Property PdfExportDocumentsList As List(Of PdfExportDocument)
    Get
property List<PdfExportDocument^>^ PdfExportDocumentsList {
    List<PdfExportDocument^>^ get ();
}
property PdfExportDocumentsList : List[PdfExportDocument]
 get

See Also

Environment Interface
GUI.PythonApi Namespace


Logger Interface

Iron Python

| Members | See Also
PLANTA API to IronPython
Logger Interface
Defines Python contract on Logger

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
public interface Logger
Public Interface Logger
public interface class Logger
public abstract class Logger

Members

All Members | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Close()()()() | Close log file.
Debug(String) | Write DEBUG msg into log file.
Error(String) | Write ERROR msg into log file.
Fatal(String) | Write FATAL msg into log file.
GetLogDirectory()()()() | Returns directory containing logs.
GetSupportLogFileName()()()() | Returns support log file name.
Info(String) | Write INFO msg into log file.
Warning(String) | Write WARNING msg into log file.

See Also

GUI.PythonApi Namespace


Logger Methods

Iron Python

Logger Methods

The Logger type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Close()()()() | Close log file.
Debug(String) | Write DEBUG msg into log file.
Error(String) | Write ERROR msg into log file.
Fatal(String) | Write FATAL msg into log file.
GetLogDirectory()()()() | Returns directory containing logs.
GetSupportLogFileName()()()() | Returns support log file name.
Info(String) | Write INFO msg into log file.
Warning(String) | Write WARNING msg into log file.

See Also

Logger Interface
GUI.PythonApi Namespace


Close Method

Iron Python

Logger..::Close Method
Close log file.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
void Close()
Sub Close
void Close()
def Close()

See Also

Logger Interface
GUI.PythonApi Namespace


Debug Method

Iron Python

Logger..::Debug Method
Write DEBUG msg into log file.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
void Debug(
    string msg
)
Sub Debug ( _
    msg As String _
)
void Debug(
    String^ msg
)
def Debug(
    msg : str
)

Parameters

msg
String
log string

See Also

Logger Interface
GUI.PythonApi Namespace


Error Method

Iron Python

Logger..::Error Method
Write ERROR msg into log file.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
void Error(
    string msg
)
Sub Error ( _
    msg As String _
)
void Error(
    String^ msg
)
def Error(
    msg : str
)

Parameters

msg
String
log string

See Also

Logger Interface
GUI.PythonApi Namespace


Fatal Method

Iron Python

Logger..::Fatal Method
Write FATAL msg into log file.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
void Fatal(
    string msg
)
Sub Fatal ( _
    msg As String _
)
void Fatal(
    String^ msg
)
def Fatal(
    msg : str
)

Parameters

msg
String
log string

See Also

Logger Interface
GUI.PythonApi Namespace


GetLogDirectory Method

Iron Python

Logger..::GetLogDirectory Method
Returns directory containing logs.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
string GetLogDirectory()
Function GetLogDirectory As String
String^ GetLogDirectory()
def GetLogDirectory() : str

Return Value

Log directory name

See Also

Logger Interface
GUI.PythonApi Namespace


GetSupportLogFileName Method

Iron Python

Logger..::GetSupportLogFileName Method
Returns support log file name.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
string GetSupportLogFileName()
Function GetSupportLogFileName As String
String^ GetSupportLogFileName()
def GetSupportLogFileName() : str

Return Value

Support log file name

See Also

Logger Interface
GUI.PythonApi Namespace


Info Method

Iron Python

Logger..::Info Method
Write INFO msg into log file.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
void Info(
    string msg
)
Sub Info ( _
    msg As String _
)
void Info(
    String^ msg
)
def Info(
    msg : str
)

Parameters

msg
String
log string

See Also

Logger Interface
GUI.PythonApi Namespace


Warning Method

Iron Python

Logger..::Warning Method
Write WARNING msg into log file.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
void Warning(
    string msg
)
Sub Warning ( _
    msg As String _
)
void Warning(
    String^ msg
)
def Warning(
    msg : str
)

Parameters

msg
String
log string

See Also

Logger Interface
GUI.PythonApi Namespace


PpmsPanel Interface

Iron Python

| Members | See Also
PLANTA API to IronPython
PpmsPanel Interface
Defines Python contract on PpmsPanel

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
public interface PpmsPanel
Public Interface PpmsPanel
public interface class PpmsPanel
public abstract class PpmsPanel

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
GetShadingWindow(String, Byte, Byte, Byte, Byte, Boolean) | Get object of Shading window with specified parameters
MainModule | Return any Main module of the Panel.
Modules | All modules currently present on the Panel
Uid | Uid
WindowState | Return window state of PPMS Panel.

See Also

GUI.PythonApi Namespace


PpmsPanel Methods

Iron Python

PpmsPanel Methods

The PpmsPanel type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
GetShadingWindow(String, Byte, Byte, Byte, Byte, Boolean) | Get object of Shading window with specified parameters

See Also

PpmsPanel Interface
GUI.PythonApi Namespace


GetShadingWindow Method

Iron Python

PpmsPanel..::GetShadingWindow Method
Get object of Shading window with specified parameters

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
ShadingWindow GetShadingWindow(
    string text,
    byte r,
    byte g,
    byte b,
    byte opacity,
    bool spinnerIsVisible
)
Function GetShadingWindow ( _
    text As String, _
    r As Byte, _
    g As Byte, _
    b As Byte, _
    opacity As Byte, _
    spinnerIsVisible As Boolean _
) As ShadingWindow
ShadingWindow^ GetShadingWindow(
    String^ text,
    unsigned char r,
    unsigned char g,
    unsigned char b,
    unsigned char opacity,
    bool spinnerIsVisible
)
def GetShadingWindow(
    text : str,
    r : Byte,
    g : Byte,
    b : Byte,
    opacity : Byte,
    spinnerIsVisible : bool
) : ShadingWindow

Parameters

text
String
Text which will be displayed on Shading window
r
Byte
The red component of window background color. Valid values are 0 through 255.
g
Byte
The green component of window background color. Valid values are 0 through 255.
b
Byte
The blue component of window background color. Valid values are 0 through 255.
opacity
Byte
The level of opacity for the Shading window.
spinnerIsVisible
Boolean
Parameter which specifies visibility of spinner. If True - spinner is visible.

Return Value

ShadingWindow object

See Also

PpmsPanel Interface
GUI.PythonApi Namespace


PpmsPanel Properties

Iron Python

PpmsPanel Properties

The PpmsPanel type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
MainModule | Return any Main module of the Panel.
Modules | All modules currently present on the Panel
Uid | Uid
WindowState | Return window state of PPMS Panel.

See Also

PpmsPanel Interface
GUI.PythonApi Namespace


MainModule Property

Iron Python

PpmsPanel..::MainModule Property
Return any Main module of the Panel.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
Module MainModule { get; }
ReadOnly Property MainModule As Module
    Get
property Module^ MainModule {
    Module^ get ();
}
property MainModule : Module
 get

Field Value

Remarks

Ussually there should be a single Main module in a Panel

See Also

PpmsPanel Interface
GUI.PythonApi Namespace


Modules Property

Iron Python

PpmsPanel..::Modules Property
All modules currently present on the Panel

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
IEnumerable<Module> Modules { get; }
ReadOnly Property Modules As IEnumerable(Of Module)
    Get
property IEnumerable<Module^>^ Modules {
    IEnumerable<Module^>^ get ();
}
property Modules : IEnumerable[Module]
 get

See Also

PpmsPanel Interface
GUI.PythonApi Namespace


Uid Property

Iron Python

PpmsPanel..::Uid Property
Uid

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
string Uid { get; }
ReadOnly Property Uid As String
    Get
property String^ Uid {
    String^ get ();
}
property Uid : str
 get

See Also

PpmsPanel Interface
GUI.PythonApi Namespace


WindowState Property

Iron Python

PpmsPanel..::WindowState Property
Return window state of PPMS Panel.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
WindowState WindowState { get; }
ReadOnly Property WindowState As WindowState
    Get
property WindowState WindowState {
    WindowState get ();
}
property WindowState : WindowState
 get

See Also

PpmsPanel Interface
GUI.PythonApi Namespace


ShadingWindow Interface

Iron Python

| Members | See Also
PLANTA API to IronPython
ShadingWindow Interface
Defines Python contract on ShadingWindow

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
public interface ShadingWindow
Public Interface ShadingWindow
public interface class ShadingWindow
public abstract class ShadingWindow

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
activate()()()() | Show shading window
disable()()()() | Hide shading window
text | Get or set text which will be displayed on Shading window.

See Also

GUI.PythonApi Namespace


ShadingWindow Methods

Iron Python

ShadingWindow Methods

The ShadingWindow type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
activate()()()() | Show shading window
disable()()()() | Hide shading window

See Also

ShadingWindow Interface
GUI.PythonApi Namespace


activate Method

Iron Python

ShadingWindow..::activate Method
Show shading window

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
void activate()
Sub activate
void activate()
def activate()

See Also

ShadingWindow Interface
GUI.PythonApi Namespace


disable Method

Iron Python

ShadingWindow..::disable Method
Hide shading window

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
void disable()
Sub disable
void disable()
def disable()

See Also

ShadingWindow Interface
GUI.PythonApi Namespace


ShadingWindow Properties

Iron Python

ShadingWindow Properties

The ShadingWindow type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
text | Get or set text which will be displayed on Shading window.

See Also

ShadingWindow Interface
GUI.PythonApi Namespace


text Property

Iron Python

ShadingWindow..::text Property
Get or set text which will be displayed on Shading window.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
string text { get; set; }
Property text As String
    Get
    Set
property String^ text {
    String^ get ();
    void set (String^ value);
}
property text : str
 get
 set

See Also

ShadingWindow Interface
GUI.PythonApi Namespace


WindowState Enumeration

Iron Python

WindowState Enumeration
Panel window state Data Type

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
public enum WindowState
Public Enumeration WindowState
public enum class WindowState
public enum WindowState

Members

Member | Description
Normal | Normal
Maximized | Maximized
Minimized | Minimized
Unknown | Unknown

See Also

GUI.PythonApi Namespace


GUI.PythonApi.Customizing Namespace

Iron Python

GUI.PythonApi.Customizing Namespace
Contains interfaces exposed to Python by Customizing objects

Types

All Types | Interfaces | Enumerations
Name | Description
DataAreaCustomizing | Defines Python contract on DataAreaCustomizing
DataFieldCustomizing | Defines Python contract on DataFieldCustomizing
ModuleCustomizing | Defines Python contract on Customizing
RawDataType | Raw DataField Data Type
RawTextFormatInfo | Raw Text Format Info
RootCustomizing | Defines Python contract on Customizing


DataAreaCustomizing Interface

Iron Python

| Members | See Also
PLANTA API to IronPython
DataAreaCustomizing Interface
Defines Python contract on DataAreaCustomizing

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
public interface DataAreaCustomizing
Public Interface DataAreaCustomizing
public interface class DataAreaCustomizing
public abstract class DataAreaCustomizing

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ChildrenDFC | List of DFCs the DAC has
get_customizing_name()()()() | Get DataAreaCustomizing name
get_df_by_name(String) | Get DataFieldCustomizing by its name(NOT USED ANYMORE. USE get_dfc_by_name(string name))
get_dfc_by_name(String) | Get DataFieldCustomizing by its name
Name | DAC name
TryGetDFC(String, DataFieldCustomizing%) | Tries to locate a DFC by uid
Uid | Uid

See Also

GUI.PythonApi.Customizing Namespace


DataAreaCustomizing Methods

Iron Python

DataAreaCustomizing Methods

The DataAreaCustomizing type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
get_customizing_name()()()() | Get DataAreaCustomizing name
get_df_by_name(String) | Get DataFieldCustomizing by its name(NOT USED ANYMORE. USE get_dfc_by_name(string name))
get_dfc_by_name(String) | Get DataFieldCustomizing by its name
TryGetDFC(String, DataFieldCustomizing%) | Tries to locate a DFC by uid

See Also

DataAreaCustomizing Interface
GUI.PythonApi.Customizing Namespace


get_customizing_name Method

Iron Python

DataAreaCustomizing..::get_customizing_name Method
Get DataAreaCustomizing name

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
string get_customizing_name()
Function get_customizing_name As String
String^ get_customizing_name()
def get_customizing_name() : str

Return Value

DataAreaCustomizing Name

See Also

DataAreaCustomizing Interface
GUI.PythonApi.Customizing Namespace


get_df_by_name Method

Iron Python

DataAreaCustomizing..::get_df_by_name Method
Get DataFieldCustomizing by its name(NOT USED ANYMORE. USE get_dfc_by_name(string name))

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
DataFieldCustomizing get_df_by_name(
    string name
)
Function get_df_by_name ( _
    name As String _
) As DataFieldCustomizing
DataFieldCustomizing^ get_df_by_name(
    String^ name
)
def get_df_by_name(
    name : str
) : DataFieldCustomizing

Parameters

name
String
Name of DataFieldCustomizing to look for

Return Value

Found DataFieldCustomizing or null if name is not found

See Also

DataAreaCustomizing Interface
GUI.PythonApi.Customizing Namespace


get_dfc_by_name Method

Iron Python

DataAreaCustomizing..::get_dfc_by_name Method
Get DataFieldCustomizing by its name

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
DataFieldCustomizing get_dfc_by_name(
    string name
)
Function get_dfc_by_name ( _
    name As String _
) As DataFieldCustomizing
DataFieldCustomizing^ get_dfc_by_name(
    String^ name
)
def get_dfc_by_name(
    name : str
) : DataFieldCustomizing

Parameters

name
String
Name of DataFieldCustomizing to look for

Return Value

Found DataFieldCustomizing or null if name is not found

See Also

DataAreaCustomizing Interface
GUI.PythonApi.Customizing Namespace


TryGetDFC Method

Iron Python

DataAreaCustomizing..::TryGetDFC Method
Tries to locate a DFC by uid

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
bool TryGetDFC(
    string uid,
    out DataFieldCustomizing dfc
)
Function TryGetDFC ( _
    uid As String, _
    <OutAttribute> ByRef dfc As DataFieldCustomizing _
) As Boolean
bool TryGetDFC(
    String^ uid,
    [OutAttribute] DataFieldCustomizing^% dfc
)
def TryGetDFC(
    uid : str,
    dfc : DataFieldCustomizing
) : bool

Parameters

uid
String
UID of DFC to get
dfc
DataFieldCustomizing %
Recievies found DFC or Null if not found

Return Value

True if found, False otherwise

Remarks

If DAC has a DFC with given uid true is retrurned and will point to it, othewise returns false and dfc will be set to Null

See Also

DataAreaCustomizing Interface
GUI.PythonApi.Customizing Namespace


DataAreaCustomizing Properties

Iron Python

DataAreaCustomizing Properties

The DataAreaCustomizing type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ChildrenDFC | List of DFCs the DAC has
Name | DAC name
Uid | Uid

See Also

DataAreaCustomizing Interface
GUI.PythonApi.Customizing Namespace


ChildrenDFC Property

Iron Python

DataAreaCustomizing..::ChildrenDFC Property
List of DFCs the DAC has

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
IEnumerable<DataFieldCustomizing> ChildrenDFC { get; }
ReadOnly Property ChildrenDFC As IEnumerable(Of DataFieldCustomizing)
    Get
property IEnumerable<DataFieldCustomizing^>^ ChildrenDFC {
    IEnumerable<DataFieldCustomizing^>^ get ();
}
property ChildrenDFC : IEnumerable[DataFieldCustomizing]
 get

See Also

DataAreaCustomizing Interface
GUI.PythonApi.Customizing Namespace


Name Property

Iron Python

DataAreaCustomizing..::Name Property
DAC name

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
string Name { get; }
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
property Name : str
 get

See Also

DataAreaCustomizing Interface
GUI.PythonApi.Customizing Namespace


Uid Property

Iron Python

DataAreaCustomizing..::Uid Property
Uid

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
string Uid { get; }
ReadOnly Property Uid As String
    Get
property String^ Uid {
    String^ get ();
}
property Uid : str
 get

See Also

DataAreaCustomizing Interface
GUI.PythonApi.Customizing Namespace


DataFieldCustomizing Interface

Iron Python

| Members | See Also
PLANTA API to IronPython
DataFieldCustomizing Interface
Defines Python contract on DataFieldCustomizing

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
public interface DataFieldCustomizing
Public Interface DataFieldCustomizing
public interface class DataFieldCustomizing
public abstract class DataFieldCustomizing

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
get_customizing_name()()()() | Get DataFieldCustomizing name
PythonScriptSettings | Python script settings. Customized script parameters.
RawTextFormat | Gets Raw Text format of DFC
Title | DFC title
Uid | Uid

Remarks

Class Diagram of DFC elements

See Also

GUI.PythonApi.Customizing Namespace


DataFieldCustomizing Methods

Iron Python

DataFieldCustomizing Methods

The DataFieldCustomizing type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
get_customizing_name()()()() | Get DataFieldCustomizing name

See Also

DataFieldCustomizing Interface
GUI.PythonApi.Customizing Namespace


get_customizing_name Method

Iron Python

DataFieldCustomizing..::get_customizing_name Method
Get DataFieldCustomizing name

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
string get_customizing_name()
Function get_customizing_name As String
String^ get_customizing_name()
def get_customizing_name() : str

Return Value

DataFieldCustomizing name

See Also

DataFieldCustomizing Interface
GUI.PythonApi.Customizing Namespace


DataFieldCustomizing Properties

Iron Python

DataFieldCustomizing Properties

The DataFieldCustomizing type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
PythonScriptSettings | Python script settings. Customized script parameters.
RawTextFormat | Gets Raw Text format of DFC
Title | DFC title
Uid | Uid

See Also

DataFieldCustomizing Interface
GUI.PythonApi.Customizing Namespace


PythonScriptSettings Property

Iron Python

DataFieldCustomizing..::PythonScriptSettings Property
Python script settings. Customized script parameters.

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
string PythonScriptSettings { get; }
ReadOnly Property PythonScriptSettings As String
    Get
property String^ PythonScriptSettings {
    String^ get ();
}
property PythonScriptSettings : str
 get

See Also

DataFieldCustomizing Interface
GUI.PythonApi.Customizing Namespace


RawTextFormat Property

Iron Python

DataFieldCustomizing..::RawTextFormat Property
Gets Raw Text format of DFC

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
RawTextFormatInfo RawTextFormat { get; }
ReadOnly Property RawTextFormat As RawTextFormatInfo
    Get
property RawTextFormatInfo^ RawTextFormat {
    RawTextFormatInfo^ get ();
}
property RawTextFormat : RawTextFormatInfo
 get

See Also

DataFieldCustomizing Interface
GUI.PythonApi.Customizing Namespace


Title Property

Iron Python

DataFieldCustomizing..::Title Property
DFC title

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
string Title { get; }
ReadOnly Property Title As String
    Get
property String^ Title {
    String^ get ();
}
property Title : str
 get

See Also

DataFieldCustomizing Interface
GUI.PythonApi.Customizing Namespace


Uid Property

Iron Python

DataFieldCustomizing..::Uid Property
Uid

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
string Uid { get; }
ReadOnly Property Uid As String
    Get
property String^ Uid {
    String^ get ();
}
property Uid : str
 get

See Also

DataFieldCustomizing Interface
GUI.PythonApi.Customizing Namespace


ModuleCustomizing Interface

Iron Python

| Members | See Also
PLANTA API to IronPython
ModuleCustomizing Interface
Defines Python contract on Customizing

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
public interface ModuleCustomizing
Public Interface ModuleCustomizing
public interface class ModuleCustomizing
public abstract class ModuleCustomizing

Members

All Members | Properties
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Roots | All RootCustomizings of the Customizing
Uid | Uid

See Also

GUI.PythonApi.Customizing Namespace


ModuleCustomizing Properties

Iron Python

ModuleCustomizing Properties

The ModuleCustomizing type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Roots | All RootCustomizings of the Customizing
Uid | Uid

See Also

ModuleCustomizing Interface
GUI.PythonApi.Customizing Namespace


Roots Property

Iron Python

ModuleCustomizing..::Roots Property
All RootCustomizings of the Customizing

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
IEnumerable<RootCustomizing> Roots { get; }
ReadOnly Property Roots As IEnumerable(Of RootCustomizing)
    Get
property IEnumerable<RootCustomizing^>^ Roots {
    IEnumerable<RootCustomizing^>^ get ();
}
property Roots : IEnumerable[RootCustomizing]
 get

See Also

ModuleCustomizing Interface
GUI.PythonApi.Customizing Namespace


Uid Property

Iron Python

ModuleCustomizing..::Uid Property
Uid

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
string Uid { get; }
ReadOnly Property Uid As String
    Get
property String^ Uid {
    String^ get ();
}
property Uid : str
 get

See Also

ModuleCustomizing Interface
GUI.PythonApi.Customizing Namespace


RawDataType Enumeration

Iron Python

RawDataType Enumeration
Raw DataField Data Type

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
public enum RawDataType
Public Enumeration RawDataType
public enum class RawDataType
public enum RawDataType

Members

Member | Description
String | String
Integral | Integral
Decimal | Decimal
Date | Date
Time | Time
Currency | Currency

See Also

GUI.PythonApi.Customizing Namespace


RawTextFormatInfo Interface

Iron Python

| Members | See Also
PLANTA API to IronPython
RawTextFormatInfo Interface
Raw Text Format Info

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
public interface RawTextFormatInfo
Public Interface RawTextFormatInfo
public interface class RawTextFormatInfo
public abstract class RawTextFormatInfo

Members

All Members | Properties
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
PDataType | Data type
SuffixSymbol | Suffix symbol
ZeroPadWidth | Zero pad width

See Also

GUI.PythonApi.Customizing Namespace


RawTextFormatInfo Properties

Iron Python

RawTextFormatInfo Properties

The RawTextFormatInfo type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
PDataType | Data type
SuffixSymbol | Suffix symbol
ZeroPadWidth | Zero pad width

See Also

RawTextFormatInfo Interface
GUI.PythonApi.Customizing Namespace


PDataType Property

Iron Python

RawTextFormatInfo..::PDataType Property
Data type

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
RawDataType PDataType { get; }
ReadOnly Property PDataType As RawDataType
    Get
property RawDataType PDataType {
    RawDataType get ();
}
property PDataType : RawDataType
 get

See Also

RawTextFormatInfo Interface
GUI.PythonApi.Customizing Namespace


SuffixSymbol Property

Iron Python

RawTextFormatInfo..::SuffixSymbol Property
Suffix symbol

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
string SuffixSymbol { get; }
ReadOnly Property SuffixSymbol As String
    Get
property String^ SuffixSymbol {
    String^ get ();
}
property SuffixSymbol : str
 get

See Also

RawTextFormatInfo Interface
GUI.PythonApi.Customizing Namespace


ZeroPadWidth Property

Iron Python

RawTextFormatInfo..::ZeroPadWidth Property
Zero pad width

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
int ZeroPadWidth { get; }
ReadOnly Property ZeroPadWidth As Integer
    Get
property int ZeroPadWidth {
    int get ();
}
property ZeroPadWidth : int
 get

See Also

RawTextFormatInfo Interface
GUI.PythonApi.Customizing Namespace


RootCustomizing Interface

Iron Python

| Members | See Also
PLANTA API to IronPython
RootCustomizing Interface
Defines Python contract on Customizing

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
public interface RootCustomizing
Public Interface RootCustomizing
public interface class RootCustomizing
public abstract class RootCustomizing

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
GetDAC(String) | Looks for DataAreaCustomizing with given uid
Uid | Uid
VirtualRootDAC | Virtual root DAC that groups all top level DACs.

See Also

GUI.PythonApi.Customizing Namespace


RootCustomizing Methods

Iron Python

RootCustomizing Methods

The RootCustomizing type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
GetDAC(String) | Looks for DataAreaCustomizing with given uid

See Also

RootCustomizing Interface
GUI.PythonApi.Customizing Namespace


GetDAC Method

Iron Python

RootCustomizing..::GetDAC Method
Looks for DataAreaCustomizing with given uid

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
DataAreaCustomizing GetDAC(
    string uid
)
Function GetDAC ( _
    uid As String _
) As DataAreaCustomizing
DataAreaCustomizing^ GetDAC(
    String^ uid
)
def GetDAC(
    uid : str
) : DataAreaCustomizing

Parameters

uid
String
DataAreaCustomizing uid to search for

Return Value

DataAreaCustomizing with given UID or Null if not found

See Also

RootCustomizing Interface
GUI.PythonApi.Customizing Namespace


RootCustomizing Properties

Iron Python

RootCustomizing Properties

The RootCustomizing type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Uid | Uid
VirtualRootDAC | Virtual root DAC that groups all top level DACs.

See Also

RootCustomizing Interface
GUI.PythonApi.Customizing Namespace


Uid Property

Iron Python

RootCustomizing..::Uid Property
Uid

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
string Uid { get; }
ReadOnly Property Uid As String
    Get
property String^ Uid {
    String^ get ();
}
property Uid : str
 get

See Also

RootCustomizing Interface
GUI.PythonApi.Customizing Namespace


VirtualRootDAC Property

Iron Python

RootCustomizing..::VirtualRootDAC Property
Virtual root DAC that groups all top level DACs.

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
DataAreaCustomizing VirtualRootDAC { get; }
ReadOnly Property VirtualRootDAC As DataAreaCustomizing
    Get
property DataAreaCustomizing^ VirtualRootDAC {
    DataAreaCustomizing^ get ();
}
property VirtualRootDAC : DataAreaCustomizing
 get

See Also

RootCustomizing Interface
GUI.PythonApi.Customizing Namespace


GUI.PythonApi.Data Namespace

Iron Python

GUI.PythonApi.Data Namespace
Contains interfaces exposed to Python by Data objects

Types

All Types | Interfaces
Name | Description
DataArea | Defines Python contract on DataArea
DataField | Defines Python contract on DataField
Module | Defines Python contract on Module
Root | Defines Python contract on Root
Sheet | Defines Python contract on Sheet
SheetManager | Defines Python contract on SheetManager


DataArea Interface

Iron Python

| Members | See Also
PLANTA API to IronPython
DataArea Interface
Defines Python contract on DataArea

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
public interface DataArea
Public Interface DataArea
public interface class DataArea
public abstract class DataArea

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ChildrenDF | DFs of DA
Customizing | DA customizing
DASheets | SheetManager of DA sheets
get_children(String) | Get list of child DataAreas which belong to the DataAreaCustomizing with current custName
get_customizing_name()()()() | Get name of DataAreaCustomizing
get_dfc(String) | Get DataFieldCustomizing with specified customizing name
get_id()()()() | Get ID of data area customizing
get_records()()()() | Get list of all DataAreas which belong to the customizing of current dataarea
Uid | Uid

See Also

GUI.PythonApi.Data Namespace


DataArea Methods

Iron Python

DataArea Methods

The DataArea type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
get_children(String) | Get list of child DataAreas which belong to the DataAreaCustomizing with current custName
get_customizing_name()()()() | Get name of DataAreaCustomizing
get_dfc(String) | Get DataFieldCustomizing with specified customizing name
get_id()()()() | Get ID of data area customizing
get_records()()()() | Get list of all DataAreas which belong to the customizing of current dataarea

See Also

DataArea Interface
GUI.PythonApi.Data Namespace


get_children Method

Iron Python

DataArea..::get_children Method
Get list of child DataAreas which belong to the DataAreaCustomizing with current custName

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
List<DataArea> get_children(
    string custName
)
Function get_children ( _
    custName As String _
) As List(Of DataArea)
List<DataArea^>^ get_children(
    String^ custName
)
def get_children(
    custName : str
) : List[DataArea]

Parameters

custName
String
name of DataAreaCustomizing

Return Value

List of child DataAreas which belong to the DataAreaCustomizing with current custName

See Also

DataArea Interface
GUI.PythonApi.Data Namespace


get_customizing_name Method

Iron Python

DataArea..::get_customizing_name Method
Get name of DataAreaCustomizing

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
string get_customizing_name()
Function get_customizing_name As String
String^ get_customizing_name()
def get_customizing_name() : str

Return Value

Name of DataAreaCustomizing

See Also

DataArea Interface
GUI.PythonApi.Data Namespace


get_dfc Method

Iron Python

DataArea..::get_dfc Method
Get DataFieldCustomizing with specified customizing name

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
DataFieldCustomizing get_dfc(
    string custName
)
Function get_dfc ( _
    custName As String _
) As DataFieldCustomizing
DataFieldCustomizing^ get_dfc(
    String^ custName
)
def get_dfc(
    custName : str
) : DataFieldCustomizing

Parameters

custName
String
name of DataFieldCustomizing

Return Value

DataFieldCustomizing instance with specified customizing name

See Also

DataArea Interface
GUI.PythonApi.Data Namespace


get_id Method

Iron Python

DataArea..::get_id Method
Get ID of data area customizing

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
string get_id()
Function get_id As String
String^ get_id()
def get_id() : str

Return Value

Data area customizing ID

See Also

DataArea Interface
GUI.PythonApi.Data Namespace


get_records Method

Iron Python

DataArea..::get_records Method
Get list of all DataAreas which belong to the customizing of current dataarea

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
List<DataArea> get_records()
Function get_records As List(Of DataArea)
List<DataArea^>^ get_records()
def get_records() : List[DataArea]

Return Value

List of all DataAreas which belong to the customizing of current dataarea

See Also

DataArea Interface
GUI.PythonApi.Data Namespace


DataArea Properties

Iron Python

DataArea Properties

The DataArea type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ChildrenDF | DFs of DA
Customizing | DA customizing
DASheets | SheetManager of DA sheets
Uid | Uid

See Also

DataArea Interface
GUI.PythonApi.Data Namespace


ChildrenDF Property

Iron Python

DataArea..::ChildrenDF Property
DFs of DA

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
IEnumerable<DataField> ChildrenDF { get; }
ReadOnly Property ChildrenDF As IEnumerable(Of DataField)
    Get
property IEnumerable<DataField^>^ ChildrenDF {
    IEnumerable<DataField^>^ get ();
}
property ChildrenDF : IEnumerable[DataField]
 get

See Also

DataArea Interface
GUI.PythonApi.Data Namespace


Customizing Property

Iron Python

DataArea..::Customizing Property
DA customizing

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
DataAreaCustomizing Customizing { get; }
ReadOnly Property Customizing As DataAreaCustomizing
    Get
property DataAreaCustomizing^ Customizing {
    DataAreaCustomizing^ get ();
}
property Customizing : DataAreaCustomizing
 get

See Also

DataArea Interface
GUI.PythonApi.Data Namespace


DASheets Property

Iron Python

DataArea..::DASheets Property
SheetManager of DA sheets

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
SheetManager DASheets { get; }
ReadOnly Property DASheets As SheetManager
    Get
property SheetManager^ DASheets {
    SheetManager^ get ();
}
property DASheets : SheetManager
 get

See Also

DataArea Interface
GUI.PythonApi.Data Namespace


Uid Property

Iron Python

DataArea..::Uid Property
Uid

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
string Uid { get; }
ReadOnly Property Uid As String
    Get
property String^ Uid {
    String^ get ();
}
property Uid : str
 get

See Also

DataArea Interface
GUI.PythonApi.Data Namespace


DataField Interface

Iron Python

| Members | See Also
PLANTA API to IronPython
DataField Interface
Defines Python contract on DataField

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
public interface DataField
Public Interface DataField
public interface class DataField
public abstract class DataField

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Customizing | DF CU
get_customizing_name()()()() | Get customizing name of data field
GetValue<(Of <<'(T>)>>)()()()() | Gets DF value.
HasRawText | Gets a value indicating whether the DataField has a raw value assigned.
RawText | Gets or sets a raw text (an unformatted value). This method should only be used when the parameter "Raw Format" is activated on DT406 for the data source DA.
SetServerValue(ModuleLayout, Object) | Sets DF value, like if the user have changed it

See Also

GUI.PythonApi.Data Namespace


DataField Methods

Iron Python

DataField Methods

The DataField type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
get_customizing_name()()()() | Get customizing name of data field
GetValue<(Of <<'(T>)>>)()()()() | Gets DF value.
SetServerValue(ModuleLayout, Object) | Sets DF value, like if the user have changed it

See Also

DataField Interface
GUI.PythonApi.Data Namespace


get_customizing_name Method

Iron Python

DataField..::get_customizing_name Method
Get customizing name of data field

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
string get_customizing_name()
Function get_customizing_name As String
String^ get_customizing_name()
def get_customizing_name() : str

Return Value

Customizing name of data field

See Also

DataField Interface
GUI.PythonApi.Data Namespace


GetValue Generic Method

Iron Python

DataField..::GetValue<(Of <(<'T>)>)> Method
Gets DF value.

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
T GetValue<T>()

Function GetValue(Of T) As T
generic<typename T>
T GetValue()
def GetValue<T>() : T

Type Parameters

T
The type of Value to retrieve from DF. Consider reading remarks

Return Value

DF value of type T

Remarks

The type of DF value is determined by its behaviour. To make code typesafe this function is generic. So calling code must pass valid T when requesting DF value Depending on DF behaviour a valid object type must be specified

DF behaviour | T type
i2 and o2 | Boolean
c1-c4 | DataFieldButtonValue
h | DataFieldHlinkValue
a | BinaryImage
all other | String

See Also

DataField Interface
GUI.PythonApi.Data Namespace


SetServerValue Method

Iron Python

DataField..::SetServerValue Method
Sets DF value, like if the user have changed it

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
void SetServerValue(
    ModuleLayout ml,
    Object value
)
Sub SetServerValue ( _
    ml As ModuleLayout, _
    value As Object _
)
void SetServerValue(
    ModuleLayout^ ml,
    Object^ value
)
def SetServerValue(
    ml : ModuleLayout,
    value : Object
)

Parameters

ml
ModuleLayout
Module layout that caused the value to be set
value
Object
Depending on DF behaviour a valid object type must be specified. Read remarks to GetValue<(Of <<'(T>)>>)()()()()

See Also

DataField Interface
GUI.PythonApi.Data Namespace


DataField Properties

Iron Python

DataField Properties

The DataField type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Customizing | DF CU
HasRawText | Gets a value indicating whether the DataField has a raw value assigned.
RawText | Gets or sets a raw text (an unformatted value). This method should only be used when the parameter "Raw Format" is activated on DT406 for the data source DA.

See Also

DataField Interface
GUI.PythonApi.Data Namespace


Customizing Property

Iron Python

DataField..::Customizing Property
DF CU

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
DataFieldCustomizing Customizing { get; }
ReadOnly Property Customizing As DataFieldCustomizing
    Get
property DataFieldCustomizing^ Customizing {
    DataFieldCustomizing^ get ();
}
property Customizing : DataFieldCustomizing
 get

See Also

DataField Interface
GUI.PythonApi.Data Namespace


HasRawText Property

Iron Python

DataField..::HasRawText Property
Gets a value indicating whether the DataField has a raw value assigned.

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
bool HasRawText { get; set; }
Property HasRawText As Boolean
    Get
    Set
property bool HasRawText {
    bool get ();
    void set (bool value);
}
property HasRawText : bool
 get
 set

See Also

DataField Interface
GUI.PythonApi.Data Namespace


RawText Property

Iron Python

DataField..::RawText Property
Gets or sets a raw text (an unformatted value). This method should only be used when the parameter "Raw Format" is activated on DT406 for the data source DA.

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
Object RawText { get; set; }
Property RawText As Object
    Get
    Set
property Object^ RawText {
    Object^ get ();
    void set (Object^ value);
}
property RawText : Object
 get
 set

See Also

DataField Interface
GUI.PythonApi.Data Namespace


Module Interface

Iron Python

| Members | See Also
PLANTA API to IronPython
Module Interface
Defines Python contract on Module

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
public interface Module
Public Interface Module
public interface class Module
public abstract class Module

Members

All Members | Properties | Methods | Events
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CreateExcelExportDocument()()()() | Create Excel export document which is used for exporting module content to Excel file.
CreatePdfExportDocument(String, String, Nullable<(Of <<'(Boolean>)>>), Nullable<(Of <<'(Boolean>)>>), Nullable<(Of <<'(Single>)>>), Nullable<(Of <<'(Int32>)>>), Nullable<(Of <<'(Int32>)>>), Nullable<(Of <<'(Int32>)>>), Nullable<(Of <<'(Int32>)>>)) | Create PDF export document, which is used for exporting module content to PDF file.
CreatePrintExportDocument(String, String, Nullable<(Of <<'(Boolean>)>>), Nullable<(Of <<'(Boolean>)>>), Nullable<(Of <<'(Single>)>>), Nullable<(Of <<'(Int32>)>>), Nullable<(Of <<'(Int32>)>>), Nullable<(Of <<'(Int32>)>>), Nullable<(Of <<'(Int32>)>>)) | Create print export document, which is used for printing module.
Customizing | Module customizing
DAChanged | Event
ExportToPdfWithDialog(String, String) | Exports module to pdf file using dialog window.
get_dac(String) | Get DataAreaCustomizing with specified customizing name
get_id()()()() | Get ID of module customizing
Roots | All roots of the module
Uid | Uid

See Also

GUI.PythonApi.Data Namespace


Module Methods

Iron Python

Module Methods

The Module type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CreateExcelExportDocument()()()() | Create Excel export document which is used for exporting module content to Excel file.
CreatePdfExportDocument(String, String, Nullable<(Of <<'(Boolean>)>>), Nullable<(Of <<'(Boolean>)>>), Nullable<(Of <<'(Single>)>>), Nullable<(Of <<'(Int32>)>>), Nullable<(Of <<'(Int32>)>>), Nullable<(Of <<'(Int32>)>>), Nullable<(Of <<'(Int32>)>>)) | Create PDF export document, which is used for exporting module content to PDF file.
CreatePrintExportDocument(String, String, Nullable<(Of <<'(Boolean>)>>), Nullable<(Of <<'(Boolean>)>>), Nullable<(Of <<'(Single>)>>), Nullable<(Of <<'(Int32>)>>), Nullable<(Of <<'(Int32>)>>), Nullable<(Of <<'(Int32>)>>), Nullable<(Of <<'(Int32>)>>)) | Create print export document, which is used for printing module.
ExportToPdfWithDialog(String, String) | Exports module to pdf file using dialog window.
get_dac(String) | Get DataAreaCustomizing with specified customizing name
get_id()()()() | Get ID of module customizing

See Also

Module Interface
GUI.PythonApi.Data Namespace


CreateExcelExportDocument Method

Iron Python

Module..::CreateExcelExportDocument Method
Create Excel export document which is used for exporting module content to Excel file.

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
ExcelExportDocument CreateExcelExportDocument()
Function CreateExcelExportDocument As ExcelExportDocument
ExcelExportDocument^ CreateExcelExportDocument()
def CreateExcelExportDocument() : ExcelExportDocument

Return Value

ExcelExportDocument

See Also

Module Interface
GUI.PythonApi.Data Namespace


CreatePdfExportDocument Method

Iron Python

Module..::CreatePdfExportDocument Method
Create PDF export document, which is used for exporting module content to PDF file.

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
PdfExportDocument CreatePdfExportDocument(
    string name,
    string pageSize,
    Nullable<bool> landscape,
    Nullable<bool> fitToPage,
    Nullable<float> zoom,
    Nullable<int> marginLeft,
    Nullable<int> marginRight,
    Nullable<int> marginTop,
    Nullable<int> marginBottom
)
Function CreatePdfExportDocument ( _
    name As String, _
    pageSize As String, _
    landscape As Nullable(Of Boolean), _
    fitToPage As Nullable(Of Boolean), _
    zoom As Nullable(Of Single), _
    marginLeft As Nullable(Of Integer), _
    marginRight As Nullable(Of Integer), _
    marginTop As Nullable(Of Integer), _
    marginBottom As Nullable(Of Integer) _
) As PdfExportDocument
PdfExportDocument^ CreatePdfExportDocument(
    String^ name,
    String^ pageSize,
    Nullable<bool> landscape,
    Nullable<bool> fitToPage,
    Nullable<float> zoom,
    Nullable<int> marginLeft,
    Nullable<int> marginRight,
    Nullable<int> marginTop,
    Nullable<int> marginBottom
)
def CreatePdfExportDocument(
    name : str,
    pageSize : str,
    landscape : Nullable[bool],
    fitToPage : Nullable[bool],
    zoom : Nullable[float],
    marginLeft : Nullable[int],
    marginRight : Nullable[int],
    marginTop : Nullable[int],
    marginBottom : Nullable[int]
) : PdfExportDocument

Parameters

name
String
Document name, if it is not set or empty, it is taken from module name
pageSize
String
Page size: A4, A3, A2, if it is not set or empty, it is taken from module printing settings
landscape
Nullable <(Of <(<' Boolean >)>)>
Landscape orientation, if it is not set, it is taken from module printing settings
fitToPage
Nullable <(Of <(<' Boolean >)>)>
Fit content to page, if it is not set, it is taken from module printing settings. If it equals True, causes ignoring of the zoom
zoom
Nullable <(Of <(<' Single >)>)>
Content zoom factor in percents, if it is not set, it is taken from module printing settings. It is not accounted if the fitToPage = True
marginLeft
Nullable <(Of <(<' Int32 >)>)>
Margin left in dmm, if it is not set, it is taken from module printing settings
marginRight
Nullable <(Of <(<' Int32 >)>)>
Margin right in dmm, if it is not set, it is taken from module printing settings
marginTop
Nullable <(Of <(<' Int32 >)>)>
Margin top in dmm, if it is not set, it is taken from module printing settings
marginBottom
Nullable <(Of <(<' Int32 >)>)>
Margin bottom in dmm, if it is not set, it is taken from module printing settings

Return Value

PdfExportDocument

See Also

Module Interface
GUI.PythonApi.Data Namespace


CreatePrintExportDocument Method

Iron Python

Module..::CreatePrintExportDocument Method
Create print export document, which is used for printing module.

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
PrintExportDocument CreatePrintExportDocument(
    string name,
    string pageSize,
    Nullable<bool> landscape,
    Nullable<bool> fitToPage,
    Nullable<float> zoom,
    Nullable<int> marginLeft,
    Nullable<int> marginRight,
    Nullable<int> marginTop,
    Nullable<int> marginBottom
)
Function CreatePrintExportDocument ( _
    name As String, _
    pageSize As String, _
    landscape As Nullable(Of Boolean), _
    fitToPage As Nullable(Of Boolean), _
    zoom As Nullable(Of Single), _
    marginLeft As Nullable(Of Integer), _
    marginRight As Nullable(Of Integer), _
    marginTop As Nullable(Of Integer), _
    marginBottom As Nullable(Of Integer) _
) As PrintExportDocument
PrintExportDocument^ CreatePrintExportDocument(
    String^ name,
    String^ pageSize,
    Nullable<bool> landscape,
    Nullable<bool> fitToPage,
    Nullable<float> zoom,
    Nullable<int> marginLeft,
    Nullable<int> marginRight,
    Nullable<int> marginTop,
    Nullable<int> marginBottom
)
def CreatePrintExportDocument(
    name : str,
    pageSize : str,
    landscape : Nullable[bool],
    fitToPage : Nullable[bool],
    zoom : Nullable[float],
    marginLeft : Nullable[int],
    marginRight : Nullable[int],
    marginTop : Nullable[int],
    marginBottom : Nullable[int]
) : PrintExportDocument

Parameters

name
String
Document name, if it is not set or empty, it is taken from module name
pageSize
String
Page size: A4, A3, A2, if it is not set or empty, it is taken from module printing settings
landscape
Nullable <(Of <(<' Boolean >)>)>
Landscape orientation, if it is not set, it is taken from module printing settings
fitToPage
Nullable <(Of <(<' Boolean >)>)>
Fit content to page, if it is not set, it is taken from module printing settings. If it equals True, causes ignoring of the zoom
zoom
Nullable <(Of <(<' Single >)>)>
Content zoom factor in percents, if it is not set, it is taken from module printing settings. It is not accounted if the fitToPage = True
marginLeft
Nullable <(Of <(<' Int32 >)>)>
Margin left in dmm, if it is not set, it is taken from module printing settings
marginRight
Nullable <(Of <(<' Int32 >)>)>
Margin right in dmm, if it is not set, it is taken from module printing settings
marginTop
Nullable <(Of <(<' Int32 >)>)>
Margin top in dmm, if it is not set, it is taken from module printing settings
marginBottom
Nullable <(Of <(<' Int32 >)>)>
Margin bottom in dmm, if it is not set, it is taken from module printing settings

Return Value

PrintExportDocument

See Also

Module Interface
GUI.PythonApi.Data Namespace


ExportToPdfWithDialog Method

Iron Python

Module..::ExportToPdfWithDialog Method
Exports module to pdf file using dialog window.

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
bool ExportToPdfWithDialog(
    string directory,
    string name
)
Function ExportToPdfWithDialog ( _
    directory As String, _
    name As String _
) As Boolean
bool ExportToPdfWithDialog(
    String^ directory,
    String^ name
)
def ExportToPdfWithDialog(
    directory : str,
    name : str
) : bool

Parameters

directory
String
Output directory. If value is null, the execution path of the client will be used. Default value is null.
name
String
Module name. If value is null, the Name property of the customizing will be used. Default value is null.

Return Value

True if export is successfull, false otherwise

See Also

Module Interface
GUI.PythonApi.Data Namespace


get_dac Method

Iron Python

Module..::get_dac Method
Get DataAreaCustomizing with specified customizing name

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
DataAreaCustomizing get_dac(
    string custName
)
Function get_dac ( _
    custName As String _
) As DataAreaCustomizing
DataAreaCustomizing^ get_dac(
    String^ custName
)
def get_dac(
    custName : str
) : DataAreaCustomizing

Parameters

custName
String
CU_name of the DataAreaCustomizing

Return Value

DataAreaCustomizing with specified customizing name or null if not found

See Also

Module Interface
GUI.PythonApi.Data Namespace


get_id Method

Iron Python

Module..::get_id Method
Get ID of module customizing

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
string get_id()
Function get_id As String
String^ get_id()
def get_id() : str

Return Value

ID of module customizing

See Also

Module Interface
GUI.PythonApi.Data Namespace


Module Properties

Iron Python

Module Properties

The Module type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Customizing | Module customizing
Roots | All roots of the module
Uid | Uid

See Also

Module Interface
GUI.PythonApi.Data Namespace


Customizing Property

Iron Python

Module..::Customizing Property
Module customizing

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
ModuleCustomizing Customizing { get; }
ReadOnly Property Customizing As ModuleCustomizing
    Get
property ModuleCustomizing^ Customizing {
    ModuleCustomizing^ get ();
}
property Customizing : ModuleCustomizing
 get

See Also

Module Interface
GUI.PythonApi.Data Namespace


Roots Property

Iron Python

Module..::Roots Property
All roots of the module

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
IEnumerable<Root> Roots { get; }
ReadOnly Property Roots As IEnumerable(Of Root)
    Get
property IEnumerable<Root^>^ Roots {
    IEnumerable<Root^>^ get ();
}
property Roots : IEnumerable[Root]
 get

See Also

Module Interface
GUI.PythonApi.Data Namespace


Uid Property

Iron Python

Module..::Uid Property
Uid

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
string Uid { get; }
ReadOnly Property Uid As String
    Get
property String^ Uid {
    String^ get ();
}
property Uid : str
 get

See Also

Module Interface
GUI.PythonApi.Data Namespace


Module Events

Iron Python

Module Events

The Module type exposes the following events.

Events

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
DAChanged | Event

See Also

Module Interface
GUI.PythonApi.Data Namespace


DAChanged Event

Iron Python

Module..::DAChanged Event
Event

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
event EventHandler DAChanged
Event DAChanged As EventHandler
 event EventHandler^ DAChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
event DAChanged : EventHandler

See Also

Module Interface
GUI.PythonApi.Data Namespace


Root Interface

Iron Python

| Members | See Also
PLANTA API to IronPython
Root Interface
Defines Python contract on Root

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
public interface Root
Public Interface Root
public interface class Root
public abstract class Root

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Customizing | Root Customizing
get_dac(String) | Get DataAreaCustomizing with specified customizing name
get_records(String) | Get list of all DataAreas which belong to the DataAreaCustomizing with current CU_name
GetDA(String) | Looks for DA with given uid
Uid | Uid
VirtualRootDA | Virtual root DA that groups all top level DAs.

See Also

GUI.PythonApi.Data Namespace


Root Methods

Iron Python

Root Methods

The Root type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
get_dac(String) | Get DataAreaCustomizing with specified customizing name
get_records(String) | Get list of all DataAreas which belong to the DataAreaCustomizing with current CU_name
GetDA(String) | Looks for DA with given uid

See Also

Root Interface
GUI.PythonApi.Data Namespace


get_dac Method

Iron Python

Root..::get_dac Method
Get DataAreaCustomizing with specified customizing name

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
DataAreaCustomizing get_dac(
    string custName
)
Function get_dac ( _
    custName As String _
) As DataAreaCustomizing
DataAreaCustomizing^ get_dac(
    String^ custName
)
def get_dac(
    custName : str
) : DataAreaCustomizing

Parameters

custName
String
CU_name of the DataAreaCustomizing

Return Value

DataAreaCustomizing with specified customizing name

See Also

Root Interface
GUI.PythonApi.Data Namespace


get_records Method

Iron Python

Root..::get_records Method
Get list of all DataAreas which belong to the DataAreaCustomizing with current CU_name

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
List<DataArea> get_records(
    string custName
)
Function get_records ( _
    custName As String _
) As List(Of DataArea)
List<DataArea^>^ get_records(
    String^ custName
)
def get_records(
    custName : str
) : List[DataArea]

Parameters

custName
String
CU_name of the DataAreaCustomizing

Return Value

List of all DataAreas which belong to the DataAreaCustomizing with current CU_name

See Also

Root Interface
GUI.PythonApi.Data Namespace


GetDA Method

Iron Python

Root..::GetDA Method
Looks for DA with given uid

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
DataArea GetDA(
    string uid
)
Function GetDA ( _
    uid As String _
) As DataArea
DataArea^ GetDA(
    String^ uid
)
def GetDA(
    uid : str
) : DataArea

Parameters

uid
String
Uid of DA to look for

Return Value

DA with given UID or Null if not found

See Also

Root Interface
GUI.PythonApi.Data Namespace


Root Properties

Iron Python

Root Properties

The Root type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Customizing | Root Customizing
Uid | Uid
VirtualRootDA | Virtual root DA that groups all top level DAs.

See Also

Root Interface
GUI.PythonApi.Data Namespace


Customizing Property

Iron Python

Root..::Customizing Property
Root Customizing

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
RootCustomizing Customizing { get; }
ReadOnly Property Customizing As RootCustomizing
    Get
property RootCustomizing^ Customizing {
    RootCustomizing^ get ();
}
property Customizing : RootCustomizing
 get

See Also

Root Interface
GUI.PythonApi.Data Namespace


Uid Property

Iron Python

Root..::Uid Property
Uid

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
string Uid { get; }
ReadOnly Property Uid As String
    Get
property String^ Uid {
    String^ get ();
}
property Uid : str
 get

See Also

Root Interface
GUI.PythonApi.Data Namespace


VirtualRootDA Property

Iron Python

Root..::VirtualRootDA Property
Virtual root DA that groups all top level DAs.

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
DataArea VirtualRootDA { get; }
ReadOnly Property VirtualRootDA As DataArea
    Get
property DataArea^ VirtualRootDA {
    DataArea^ get ();
}
property VirtualRootDA : DataArea
 get

See Also

Root Interface
GUI.PythonApi.Data Namespace


Sheet Interface

Iron Python

| Members | See Also
PLANTA API to IronPython
Sheet Interface
Defines Python contract on Sheet

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
public interface Sheet : IEnumerable<DataArea>,
    IEnumerable
Public Interface Sheet _
    Inherits IEnumerable(Of DataArea), IEnumerable
public interface class Sheet : IEnumerable<DataArea^>,
    IEnumerable
public abstract class Sheet(IEnumerable[DataArea],
    IEnumerable)

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
GetEnumerator()()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable <(Of <(<' DataArea >)>)>.)
GetEnumerator()()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Uid | Uid

See Also

GUI.PythonApi.Data Namespace


Sheet Methods

Iron Python

Sheet Methods

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
GetEnumerator()()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable <(Of <(<' DataArea >)>)>.)
GetEnumerator()()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

Sheet Interface
GUI.PythonApi.Data Namespace


GetEnumerator Method

Iron Python

Sheet..::GetEnumerator Method

Overload List

Name | Description
GetEnumerator()()()() | Returns an enumerator that iterates through the collection.
GetEnumerator()()()() | Returns an enumerator that iterates through a collection.

See Also

Sheet Interface
GUI.PythonApi.Data Namespace


Sheet Properties

Iron Python

Sheet Properties

The Sheet type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Uid | Uid

See Also

Sheet Interface
GUI.PythonApi.Data Namespace


Uid Property

Iron Python

Sheet..::Uid Property
Uid

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
string Uid { get; }
ReadOnly Property Uid As String
    Get
property String^ Uid {
    String^ get ();
}
property Uid : str
 get

See Also

Sheet Interface
GUI.PythonApi.Data Namespace


SheetManager Interface

Iron Python

| Members | See Also
PLANTA API to IronPython
SheetManager Interface
Defines Python contract on SheetManager

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
public interface SheetManager
Public Interface SheetManager
public interface class SheetManager
public abstract class SheetManager

Members

All Members | Properties
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ActiveSheet | Currently active sheet of DataArea.

See Also

GUI.PythonApi.Data Namespace


SheetManager Properties

Iron Python

SheetManager Properties

The SheetManager type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ActiveSheet | Currently active sheet of DataArea.

See Also

SheetManager Interface
GUI.PythonApi.Data Namespace


ActiveSheet Property

Iron Python

SheetManager..::ActiveSheet Property
Currently active sheet of DataArea.

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
Sheet ActiveSheet { get; }
ReadOnly Property ActiveSheet As Sheet
    Get
property Sheet^ ActiveSheet {
    Sheet^ get ();
}
property ActiveSheet : Sheet
 get

See Also

SheetManager Interface
GUI.PythonApi.Data Namespace


GUI.PythonApi.Export Namespace

Iron Python

GUI.PythonApi.Export Namespace
Defines Python contracts on the documents export

Types

All Types | Interfaces
Name | Description
ExcelExportDocument | Defines Python contract on ExcelExportDocument. This document is used for exporting module content to Excel file.
PdfExportDocument | Defines Python contract on PdfExportDocument. This document is used for exporting module content to PDF file.
PrintExportDocument | Defines Python contract on PrintExportDocument. This document is used for printing module.


ExcelExportDocument Interface

Iron Python

ExcelExportDocument Interface
Defines Python contract on ExcelExportDocument. This document is used for exporting module content to Excel file.

Namespace: GUI.PythonApi.Export
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
public interface ExcelExportDocument
Public Interface ExcelExportDocument
public interface class ExcelExportDocument
public abstract class ExcelExportDocument

See Also

GUI.PythonApi.Export Namespace


PdfExportDocument Interface

Iron Python

PdfExportDocument Interface
Defines Python contract on PdfExportDocument. This document is used for exporting module content to PDF file.

Namespace: GUI.PythonApi.Export
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
public interface PdfExportDocument
Public Interface PdfExportDocument
public interface class PdfExportDocument
public abstract class PdfExportDocument

See Also

GUI.PythonApi.Export Namespace


PrintExportDocument Interface

Iron Python

PrintExportDocument Interface
Defines Python contract on PrintExportDocument. This document is used for printing module.

Namespace: GUI.PythonApi.Export
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
public interface PrintExportDocument
Public Interface PrintExportDocument
public interface class PrintExportDocument
public abstract class PrintExportDocument

See Also

GUI.PythonApi.Export Namespace


GUI.PythonApi.Layout Namespace

Iron Python

GUI.PythonApi.Layout Namespace
Contains interfaces exposed to Python by View layer

Types

All Types | Interfaces
Name | Description
ModuleLayout | Defines Python contract on ModuleLayout


ModuleLayout Interface

Iron Python

| Members | See Also
PLANTA API to IronPython
ModuleLayout Interface
Defines Python contract on ModuleLayout

Namespace: GUI.PythonApi.Layout
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
public interface ModuleLayout
Public Interface ModuleLayout
public interface class ModuleLayout
public abstract class ModuleLayout

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Activate(DataField) | Activates the DF
Module | Module for which the layout was build for

See Also

GUI.PythonApi.Layout Namespace


ModuleLayout Methods

Iron Python

ModuleLayout Methods

The ModuleLayout type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Activate(DataField) | Activates the DF

See Also

ModuleLayout Interface
GUI.PythonApi.Layout Namespace


Activate Method

Iron Python

ModuleLayout..::Activate Method
Activates the DF

Namespace: GUI.PythonApi.Layout
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
bool Activate(
    DataField df
)
Function Activate ( _
    df As DataField _
) As Boolean
bool Activate(
    DataField^ df
)
def Activate(
    df : DataField
) : bool

Parameters

df
DataField
DF to activate

Return Value

True if DF was activated, False if it cant be activated

Remarks

The following table shows fields that can be activated and corresponding user action to activate the field

DF behaviour | User action
c1-c4 | Button press
e1-e4 | LMouse click
f1-f4 | LMouse doubleclick
g1-g4 | Enter key press
h | LMouse click

See Also

ModuleLayout Interface
GUI.PythonApi.Layout Namespace


ModuleLayout Properties

Iron Python

ModuleLayout Properties

The ModuleLayout type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Module | Module for which the layout was build for

See Also

ModuleLayout Interface
GUI.PythonApi.Layout Namespace


Module Property

Iron Python

ModuleLayout..::Module Property
Module for which the layout was build for

Namespace: GUI.PythonApi.Layout
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++ | Iron Python
Module Module { get; }
ReadOnly Property Module As Module
    Get
property Module^ Module {
    Module^ get ();
}
property Module : Module
 get

See Also

ModuleLayout Interface
GUI.PythonApi.Layout Namespace


Variables of embedded controls

Iron Python

Variables of embedded controls

Description of scope variables which are available in DF scripts

Here you can find variables which can be used from python DF scripts directly.

Variables

df
DataField
Embedded control owner DataFiled

moduleLayout
Embedded control owner ModuleLayout

ctl
Control
Embedded control


General notes

Iron Python

General notes

There are general notes and hints

Default and keyword arguments

Python supports keyword and default values of arguments of the functions. It can be usefull when a function requires a lot of arguments but you need to specify only few of them. Please see detailed information about default argument values and default behaviour of the function in its documentation. An example of such function in the PLANTA API to IronPython:

CreatePdfExportDocument

See also:

Default argument values

Keyword argument values