GUI.PythonApi Namespace

| [image]
C#

Visual Basic

Visual C++

C2007 API to IronPython
GUI.PythonApi Namespace
Root namespace of Python API. Contains two subnamespaces: Data, Customizing and Layout Class Diagram of Python API to GUI elements

Types

All Types | Interfaces
Name | Description
PpmsPanel | Defines Python contract on PpmsPanel

PLANTA GmbH


PpmsPanel Interface

| Members | See Also
C2007 API to IronPython
PpmsPanel Interface
Defines Python contract on PpmsPanel

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
public interface PpmsPanel
Public Interface PpmsPanel
public interface class PpmsPanel

Members

All Members | Properties
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
MainModule | Return any Main module of the Panel.
Modules | All modules currently present on the Panel
Uid | Uid

See Also

GUI.PythonApi Namespace


PpmsPanel Properties

| See Also
C2007 API to IronPython
PpmsPanel Properties

The PpmsPanel type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
MainModule | Return any Main module of the Panel.
Modules | All modules currently present on the Panel
Uid | Uid

See Also

PpmsPanel Interface
GUI.PythonApi Namespace


MainModule Property

C2007 API to IronPython
PpmsPanel..::MainModule Property
Return any Main module of the Panel.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
Module MainModule { get; }
ReadOnly Property MainModule As Module
property Module^ MainModule {
    Module^ get ();
}

Field Value

Remarks

Ussually there should be a single Main module in a Panel

See Also

PpmsPanel Interface
GUI.PythonApi Namespace


Modules Property

C2007 API to IronPython
PpmsPanel..::Modules Property
All modules currently present on the Panel

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
IEnumerable<Module> Modules { get; }
ReadOnly Property Modules As IEnumerable(Of Module)
property IEnumerable<Module^>^ Modules {
    IEnumerable<Module^>^ get ();
}

See Also

PpmsPanel Interface
GUI.PythonApi Namespace


Uid Property

C2007 API to IronPython
PpmsPanel..::Uid Property
Uid

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
string Uid { get; }
ReadOnly Property Uid As String
property String^ Uid {
    String^ get ();
}

See Also

PpmsPanel Interface
GUI.PythonApi Namespace


GUI.PythonApi.Customizing Namespace

C2007 API to IronPython
GUI.PythonApi.Customizing Namespace
Contains interfaces exposed to Python by Customizing objects

Types

All Types | Interfaces | Enumerations
Name | Description
DataAreaCustomizing | Defines Python contract on DataAreaCustomizing
DataFieldCustomizing | Defines Python contract on DataFieldCustomizing
ModuleCustomizing | Defines Python contract on Customizing
RawDataType | Raw DataField Data Type
RawTextFormatInfo | Raw Text Format Info
RootCustomizing | Defines Python contract on Customizing


DataAreaCustomizing Interface

| Members | See Also
C2007 API to IronPython
DataAreaCustomizing Interface
Defines Python contract on DataAreaCustomizing

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
public interface DataAreaCustomizing
Public Interface DataAreaCustomizing
public interface class DataAreaCustomizing

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ChildrenDFC | List of DFCs the DAC has
get_customizing_name()()() | Get CU name
get_df_by_name(String) | Gets DFC by its Name
Name | DAC name
TryGetDFC(String, DataFieldCustomizing%) | Tries to locate a DFC by uid
Uid | Uid

See Also

GUI.PythonApi.Customizing Namespace


DataAreaCustomizing Methods

C2007 API to IronPython
DataAreaCustomizing Methods

The DataAreaCustomizing type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
get_customizing_name()()() | Get CU name
get_df_by_name(String) | Gets DFC by its Name
TryGetDFC(String, DataFieldCustomizing%) | Tries to locate a DFC by uid

See Also

DataAreaCustomizing Interface
GUI.PythonApi.Customizing Namespace


get_customizing_name Method

C2007 API to IronPython
DataAreaCustomizing..::get_customizing_name Method
Get CU name

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
string get_customizing_name()
Function get_customizing_name As String
String^ get_customizing_name()

Return Value

Customizing Name

See Also

DataAreaCustomizing Interface
GUI.PythonApi.Customizing Namespace


get_df_by_name Method

C2007 API to IronPython
DataAreaCustomizing..::get_df_by_name Method
Gets DFC by its Name

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
DataFieldCustomizing get_df_by_name(
    string name
)
Function get_df_by_name ( _
    name As String _
) As DataFieldCustomizing
DataFieldCustomizing^ get_df_by_name(
    String^ name
)

Parameters

name
String
Name of DFC to look for

Return Value

Found DFC or null name is not found

See Also

DataAreaCustomizing Interface
GUI.PythonApi.Customizing Namespace


TryGetDFC Method

C2007 API to IronPython
DataAreaCustomizing..::TryGetDFC Method
Tries to locate a DFC by uid

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
bool TryGetDFC(
    string uid,
    out DataFieldCustomizing dfc
)
Function TryGetDFC ( _
    uid As String, _
    <OutAttribute> ByRef dfc As DataFieldCustomizing _
) As Boolean
bool TryGetDFC(
    String^ uid,
    [OutAttribute] DataFieldCustomizing^% dfc
)

Parameters

uid
String
UID of DFC to get
dfc
DataFieldCustomizing %
Recievies found DFC or Null if not found

Return Value

True if found, False otherwise

Remarks

If DAC has a DFC with given uid true is retrurned and will point to it, othewise returns false and dfc will be set to Null

See Also

DataAreaCustomizing Interface
GUI.PythonApi.Customizing Namespace


DataAreaCustomizing Properties

C2007 API to IronPython
DataAreaCustomizing Properties

The DataAreaCustomizing type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ChildrenDFC | List of DFCs the DAC has
Name | DAC name
Uid | Uid

See Also

DataAreaCustomizing Interface
GUI.PythonApi.Customizing Namespace


ChildrenDFC Property

C2007 API to IronPython
DataAreaCustomizing..::ChildrenDFC Property
List of DFCs the DAC has

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
IEnumerable<DataFieldCustomizing> ChildrenDFC { get; }
ReadOnly Property ChildrenDFC As IEnumerable(Of DataFieldCustomizing)
property IEnumerable<DataFieldCustomizing^>^ ChildrenDFC {
    IEnumerable<DataFieldCustomizing^>^ get ();
}

See Also

DataAreaCustomizing Interface
GUI.PythonApi.Customizing Namespace


Name Property

C2007 API to IronPython
DataAreaCustomizing..::Name Property
DAC name

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
string Name { get; }
ReadOnly Property Name As String
property String^ Name {
    String^ get ();
}

See Also

DataAreaCustomizing Interface
GUI.PythonApi.Customizing Namespace


Uid Property

C2007 API to IronPython
DataAreaCustomizing..::Uid Property
Uid

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
string Uid { get; }
ReadOnly Property Uid As String
property String^ Uid {
    String^ get ();
}

See Also

DataAreaCustomizing Interface
GUI.PythonApi.Customizing Namespace


DataFieldCustomizing Interface

| Members | See Also
C2007 API to IronPython
DataFieldCustomizing Interface
Defines Python contract on DataFieldCustomizing

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
public interface DataFieldCustomizing
Public Interface DataFieldCustomizing
public interface class DataFieldCustomizing

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
get_customizing_name()()() | Get CU name
PythonScriptSettings | Python script settings. Customized script parameters.
RawTextFormat | Gets Raw Text format of DFC
Title | DFC title
Uid | Uid

Remarks

Class Diagram of DFC elements

See Also

GUI.PythonApi.Customizing Namespace


DataFieldCustomizing Methods

C2007 API to IronPython
DataFieldCustomizing Methods

The DataFieldCustomizing type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
get_customizing_name()()() | Get CU name

See Also

DataFieldCustomizing Interface
GUI.PythonApi.Customizing Namespace


get_customizing_name Method

C2007 API to IronPython
DataFieldCustomizing..::get_customizing_name Method
Get CU name

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
string get_customizing_name()
Function get_customizing_name As String
String^ get_customizing_name()

Return Value

Customizing Name

See Also

DataFieldCustomizing Interface
GUI.PythonApi.Customizing Namespace


DataFieldCustomizing Properties

C2007 API to IronPython
DataFieldCustomizing Properties

The DataFieldCustomizing type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
PythonScriptSettings | Python script settings. Customized script parameters.
RawTextFormat | Gets Raw Text format of DFC
Title | DFC title
Uid | Uid

See Also

DataFieldCustomizing Interface
GUI.PythonApi.Customizing Namespace


PythonScriptSettings Property

C2007 API to IronPython
DataFieldCustomizing..::PythonScriptSettings Property
Python script settings. Customized script parameters.

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
string PythonScriptSettings { get; }
ReadOnly Property PythonScriptSettings As String
property String^ PythonScriptSettings {
    String^ get ();
}

See Also

DataFieldCustomizing Interface
GUI.PythonApi.Customizing Namespace


RawTextFormat Property

C2007 API to IronPython
DataFieldCustomizing..::RawTextFormat Property
Gets Raw Text format of DFC

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
RawTextFormatInfo RawTextFormat { get; }
ReadOnly Property RawTextFormat As RawTextFormatInfo
property RawTextFormatInfo^ RawTextFormat {
    RawTextFormatInfo^ get ();
}

See Also

DataFieldCustomizing Interface
GUI.PythonApi.Customizing Namespace


Title Property

C2007 API to IronPython
DataFieldCustomizing..::Title Property
DFC title

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
string Title { get; }
ReadOnly Property Title As String
property String^ Title {
    String^ get ();
}

See Also

DataFieldCustomizing Interface
GUI.PythonApi.Customizing Namespace


Uid Property

C2007 API to IronPython
DataFieldCustomizing..::Uid Property
Uid

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
string Uid { get; }
ReadOnly Property Uid As String
property String^ Uid {
    String^ get ();
}

See Also

DataFieldCustomizing Interface
GUI.PythonApi.Customizing Namespace


ModuleCustomizing Interface

| Members | See Also
C2007 API to IronPython
ModuleCustomizing Interface
Defines Python contract on Customizing

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
public interface ModuleCustomizing
Public Interface ModuleCustomizing
public interface class ModuleCustomizing

Members

All Members | Properties
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Roots | All RootCustomizings of the Customizing
Uid | Uid

See Also

GUI.PythonApi.Customizing Namespace


ModuleCustomizing Properties

C2007 API to IronPython
ModuleCustomizing Properties

The ModuleCustomizing type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Roots | All RootCustomizings of the Customizing
Uid | Uid

See Also

ModuleCustomizing Interface
GUI.PythonApi.Customizing Namespace


Roots Property

C2007 API to IronPython
ModuleCustomizing..::Roots Property
All RootCustomizings of the Customizing

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
IEnumerable<RootCustomizing> Roots { get; }
ReadOnly Property Roots As IEnumerable(Of RootCustomizing)
property IEnumerable<RootCustomizing^>^ Roots {
    IEnumerable<RootCustomizing^>^ get ();
}

See Also

ModuleCustomizing Interface
GUI.PythonApi.Customizing Namespace


Uid Property

C2007 API to IronPython
ModuleCustomizing..::Uid Property
Uid

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
string Uid { get; }
ReadOnly Property Uid As String
property String^ Uid {
    String^ get ();
}

See Also

ModuleCustomizing Interface
GUI.PythonApi.Customizing Namespace


RawDataType Enumeration

C2007 API to IronPython
RawDataType Enumeration
Raw DataField Data Type

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
public enum RawDataType
Public Enumeration RawDataType
public enum class RawDataType

Members

Member | Description
String | String
Integral | Integral
Decimal | Decimal
Date | Date
Time | Time

See Also

GUI.PythonApi.Customizing Namespace


RawTextFormatInfo Interface

| Members | See Also
C2007 API to IronPython
RawTextFormatInfo Interface
Raw Text Format Info

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
public interface RawTextFormatInfo
Public Interface RawTextFormatInfo
public interface class RawTextFormatInfo

Members

All Members | Properties
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
PDataType | Data type
SuffixSymbol | Suffix symbol
ZeroPadWidth | Zero pad width

See Also

GUI.PythonApi.Customizing Namespace


RawTextFormatInfo Properties

C2007 API to IronPython
RawTextFormatInfo Properties

The RawTextFormatInfo type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
PDataType | Data type
SuffixSymbol | Suffix symbol
ZeroPadWidth | Zero pad width

See Also

RawTextFormatInfo Interface
GUI.PythonApi.Customizing Namespace


PDataType Property

C2007 API to IronPython
RawTextFormatInfo..::PDataType Property
Data type

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
RawDataType PDataType { get; }
ReadOnly Property PDataType As RawDataType
property RawDataType PDataType {
    RawDataType get ();
}

See Also

RawTextFormatInfo Interface
GUI.PythonApi.Customizing Namespace


SuffixSymbol Property

C2007 API to IronPython
RawTextFormatInfo..::SuffixSymbol Property
Suffix symbol

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
string SuffixSymbol { get; }
ReadOnly Property SuffixSymbol As String
property String^ SuffixSymbol {
    String^ get ();
}

See Also

RawTextFormatInfo Interface
GUI.PythonApi.Customizing Namespace


ZeroPadWidth Property

C2007 API to IronPython
RawTextFormatInfo..::ZeroPadWidth Property
Zero pad width

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
int ZeroPadWidth { get; }
ReadOnly Property ZeroPadWidth As Integer
property int ZeroPadWidth {
    int get ();
}

See Also

RawTextFormatInfo Interface
GUI.PythonApi.Customizing Namespace


RootCustomizing Interface

| Members | See Also
C2007 API to IronPython
RootCustomizing Interface
Defines Python contract on Customizing

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
public interface RootCustomizing
Public Interface RootCustomizing
public interface class RootCustomizing

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
GetDAC(String) | Looks for DAC with given uid
Uid | Uid
VirtualRootDAC | Virtual root DAC that groups all top level DACs.

See Also

GUI.PythonApi.Customizing Namespace


RootCustomizing Methods

C2007 API to IronPython
RootCustomizing Methods

The RootCustomizing type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
GetDAC(String) | Looks for DAC with given uid

See Also

RootCustomizing Interface
GUI.PythonApi.Customizing Namespace


GetDAC Method

C2007 API to IronPython
RootCustomizing..::GetDAC Method
Looks for DAC with given uid

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
DataAreaCustomizing GetDAC(
    string uid
)
Function GetDAC ( _
    uid As String _
) As DataAreaCustomizing
DataAreaCustomizing^ GetDAC(
    String^ uid
)

Parameters

uid
String
DAC uid to search for

Return Value

DAC with given UID or Null if not found

See Also

RootCustomizing Interface
GUI.PythonApi.Customizing Namespace


RootCustomizing Properties

C2007 API to IronPython
RootCustomizing Properties

The RootCustomizing type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Uid | Uid
VirtualRootDAC | Virtual root DAC that groups all top level DACs.

See Also

RootCustomizing Interface
GUI.PythonApi.Customizing Namespace


Uid Property

C2007 API to IronPython
RootCustomizing..::Uid Property
Uid

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
string Uid { get; }
ReadOnly Property Uid As String
property String^ Uid {
    String^ get ();
}

See Also

RootCustomizing Interface
GUI.PythonApi.Customizing Namespace


VirtualRootDAC Property

C2007 API to IronPython
RootCustomizing..::VirtualRootDAC Property
Virtual root DAC that groups all top level DACs.

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
DataAreaCustomizing VirtualRootDAC { get; }
ReadOnly Property VirtualRootDAC As DataAreaCustomizing
property DataAreaCustomizing^ VirtualRootDAC {
    DataAreaCustomizing^ get ();
}

See Also

RootCustomizing Interface
GUI.PythonApi.Customizing Namespace


GUI.PythonApi.Data Namespace

C2007 API to IronPython
GUI.PythonApi.Data Namespace
Contains interfaces exposed to Python by Data objects

Types

All Types | Interfaces
Name | Description
DataArea | Defines Python contract on DataArea
DataField | Defines Python contract on DataField
Module | Defines Python contract on Module
Root | Defines Python contract on Root
Sheet | Defines Python contract on Sheet
SheetManager | Defines Python contract on SheetManager


DataArea Interface

| Members | See Also
C2007 API to IronPython
DataArea Interface
Defines Python contract on DataArea

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
public interface DataArea
Public Interface DataArea
public interface class DataArea

Members

All Members | Properties
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ChildrenDF | DFs of DA
Customizing | DA customizing
DASheets | SheetManager of DA sheets
Uid | Uid

See Also

GUI.PythonApi.Data Namespace


DataArea Properties

C2007 API to IronPython
DataArea Properties

The DataArea type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ChildrenDF | DFs of DA
Customizing | DA customizing
DASheets | SheetManager of DA sheets
Uid | Uid

See Also

DataArea Interface
GUI.PythonApi.Data Namespace


ChildrenDF Property

C2007 API to IronPython
DataArea..::ChildrenDF Property
DFs of DA

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
IEnumerable<DataField> ChildrenDF { get; }
ReadOnly Property ChildrenDF As IEnumerable(Of DataField)
property IEnumerable<DataField^>^ ChildrenDF {
    IEnumerable<DataField^>^ get ();
}

See Also

DataArea Interface
GUI.PythonApi.Data Namespace


Customizing Property

C2007 API to IronPython
DataArea..::Customizing Property
DA customizing

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
DataAreaCustomizing Customizing { get; }
ReadOnly Property Customizing As DataAreaCustomizing
property DataAreaCustomizing^ Customizing {
    DataAreaCustomizing^ get ();
}

See Also

DataArea Interface
GUI.PythonApi.Data Namespace


DASheets Property

C2007 API to IronPython
DataArea..::DASheets Property
SheetManager of DA sheets

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
SheetManager DASheets { get; }
ReadOnly Property DASheets As SheetManager
property SheetManager^ DASheets {
    SheetManager^ get ();
}

See Also

DataArea Interface
GUI.PythonApi.Data Namespace


Uid Property

C2007 API to IronPython
DataArea..::Uid Property
Uid

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
string Uid { get; }
ReadOnly Property Uid As String
property String^ Uid {
    String^ get ();
}

See Also

DataArea Interface
GUI.PythonApi.Data Namespace


DataField Interface

| Members | See Also
C2007 API to IronPython
DataField Interface
Defines Python contract on DataField

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
public interface DataField
Public Interface DataField
public interface class DataField

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Customizing | DF CU
GetValue<(Of <(T>)>)()()() | Gets DF value.
SetServerValue(ModuleLayout, Object) | Sets DF value, like if the user have changed it

See Also

GUI.PythonApi.Data Namespace


DataField Methods

C2007 API to IronPython
DataField Methods

The DataField type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
GetValue<(Of <(T>)>)()()() | Gets DF value.
SetServerValue(ModuleLayout, Object) | Sets DF value, like if the user have changed it

See Also

DataField Interface
GUI.PythonApi.Data Namespace


GetValue Generic Method

C2007 API to IronPython
DataField..::GetValue<(Of <(T>)>) Method
Gets DF value.

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
T GetValue<T>()

Function GetValue(Of T) As T
generic<typename T>
T GetValue()

Type Parameters

T
The type of Value to retrieve from DF. Consider reading remarks

Return Value

DF value of type T

Remarks

The type of DF value is determined by its behaviour. To make code typesafe this function is generic. So calling code must pass valid T when requesting DF value Depending on DF behaviour a valid object type must be specified

DF behaviour | T type
i2 and o2 | Boolean
c1-c4 | DataFieldButtonValue
h | DataFieldHlinkValue
a | BinaryImage
all other | String

See Also

DataField Interface
GUI.PythonApi.Data Namespace


SetServerValue Method

C2007 API to IronPython
DataField..::SetServerValue Method
Sets DF value, like if the user have changed it

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
void SetServerValue(
    ModuleLayout ml,
    Object value
)
Sub SetServerValue ( _
    ml As ModuleLayout, _
    value As Object _
)
void SetServerValue(
    ModuleLayout^ ml,
    Object^ value
)

Parameters

ml
ModuleLayout
Module layout that caused the value to be set
value
Object
Depending on DF behaviour a valid object type must be specified. Read remarks to GetValue<(Of <(T>)>)()()()

See Also

DataField Interface
GUI.PythonApi.Data Namespace


DataField Properties

C2007 API to IronPython
DataField Properties

The DataField type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Customizing | DF CU

See Also

DataField Interface
GUI.PythonApi.Data Namespace


Customizing Property

C2007 API to IronPython
DataField..::Customizing Property
DF CU

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
DataFieldCustomizing Customizing { get; }
ReadOnly Property Customizing As DataFieldCustomizing
property DataFieldCustomizing^ Customizing {
    DataFieldCustomizing^ get ();
}

See Also

DataField Interface
GUI.PythonApi.Data Namespace


Module Interface

| Members | See Also
C2007 API to IronPython
Module Interface
Defines Python contract on Module

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
public interface Module
Public Interface Module
public interface class Module

Members

All Members | Properties
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Customizing | Module customizing
Roots | All roots of the module
Uid | Uid

See Also

GUI.PythonApi.Data Namespace


Module Properties

C2007 API to IronPython
Module Properties

The Module type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Customizing | Module customizing
Roots | All roots of the module
Uid | Uid

See Also

Module Interface
GUI.PythonApi.Data Namespace


Customizing Property

C2007 API to IronPython
Module..::Customizing Property
Module customizing

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
ModuleCustomizing Customizing { get; }
ReadOnly Property Customizing As ModuleCustomizing
property ModuleCustomizing^ Customizing {
    ModuleCustomizing^ get ();
}

See Also

Module Interface
GUI.PythonApi.Data Namespace


Roots Property

C2007 API to IronPython
Module..::Roots Property
All roots of the module

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
IEnumerable<Root> Roots { get; }
ReadOnly Property Roots As IEnumerable(Of Root)
property IEnumerable<Root^>^ Roots {
    IEnumerable<Root^>^ get ();
}

See Also

Module Interface
GUI.PythonApi.Data Namespace


Uid Property

C2007 API to IronPython
Module..::Uid Property
Uid

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
string Uid { get; }
ReadOnly Property Uid As String
property String^ Uid {
    String^ get ();
}

See Also

Module Interface
GUI.PythonApi.Data Namespace


Root Interface

| Members | See Also
C2007 API to IronPython
Root Interface
Defines Python contract on Root

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
public interface Root
Public Interface Root
public interface class Root

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Customizing | Root Customizing
GetDA(String) | Looks for DA with given uid
Uid | Uid
VirtualRootDA | Virtual root DA that groups all top level DAs.

See Also

GUI.PythonApi.Data Namespace


Root Methods

C2007 API to IronPython
Root Methods

The Root type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
GetDA(String) | Looks for DA with given uid

See Also

Root Interface
GUI.PythonApi.Data Namespace


GetDA Method

C2007 API to IronPython
Root..::GetDA Method
Looks for DA with given uid

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
DataArea GetDA(
    string uid
)
Function GetDA ( _
    uid As String _
) As DataArea
DataArea^ GetDA(
    String^ uid
)

Parameters

uid
String
Uid of DA to look for

Return Value

DA with given UID or Null if not found

See Also

Root Interface
GUI.PythonApi.Data Namespace


Root Properties

C2007 API to IronPython
Root Properties

The Root type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Customizing | Root Customizing
Uid | Uid
VirtualRootDA | Virtual root DA that groups all top level DAs.

See Also

Root Interface
GUI.PythonApi.Data Namespace


Customizing Property

C2007 API to IronPython
Root..::Customizing Property
Root Customizing

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
RootCustomizing Customizing { get; }
ReadOnly Property Customizing As RootCustomizing
property RootCustomizing^ Customizing {
    RootCustomizing^ get ();
}

See Also

Root Interface
GUI.PythonApi.Data Namespace


Uid Property

C2007 API to IronPython
Root..::Uid Property
Uid

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
string Uid { get; }
ReadOnly Property Uid As String
property String^ Uid {
    String^ get ();
}

See Also

Root Interface
GUI.PythonApi.Data Namespace


VirtualRootDA Property

C2007 API to IronPython
Root..::VirtualRootDA Property
Virtual root DA that groups all top level DAs.

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
DataArea VirtualRootDA { get; }
ReadOnly Property VirtualRootDA As DataArea
property DataArea^ VirtualRootDA {
    DataArea^ get ();
}

See Also

Root Interface
GUI.PythonApi.Data Namespace


Sheet Interface

| Members | See Also
C2007 API to IronPython
Sheet Interface
Defines Python contract on Sheet

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
public interface Sheet : IEnumerable<DataArea>,
    IEnumerable
Public Interface Sheet _
    Implements IEnumerable(Of DataArea), IEnumerable
public interface class Sheet : IEnumerable<DataArea^>,
    IEnumerable

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable <(Of <( DataArea >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Uid | Uid

See Also

GUI.PythonApi.Data Namespace


Sheet Methods

C2007 API to IronPython
Sheet Methods

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable <(Of <( DataArea >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

Sheet Interface
GUI.PythonApi.Data Namespace


GetEnumerator Method

C2007 API to IronPython
Sheet..::GetEnumerator Method

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection.
GetEnumerator()()() | Returns an enumerator that iterates through a collection.

See Also

Sheet Interface
GUI.PythonApi.Data Namespace


Sheet Properties

C2007 API to IronPython
Sheet Properties

The Sheet type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Uid | Uid

See Also

Sheet Interface
GUI.PythonApi.Data Namespace


Uid Property

C2007 API to IronPython
Sheet..::Uid Property
Uid

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
string Uid { get; }
ReadOnly Property Uid As String
property String^ Uid {
    String^ get ();
}

See Also

Sheet Interface
GUI.PythonApi.Data Namespace


SheetManager Interface

| Members | See Also
C2007 API to IronPython
SheetManager Interface
Defines Python contract on SheetManager

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
public interface SheetManager
Public Interface SheetManager
public interface class SheetManager

Members

All Members | Properties
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ActiveSheet | Currently active sheet of DataArea

See Also

GUI.PythonApi.Data Namespace


SheetManager Properties

C2007 API to IronPython
SheetManager Properties

The SheetManager type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ActiveSheet | Currently active sheet of DataArea

See Also

SheetManager Interface
GUI.PythonApi.Data Namespace


ActiveSheet Property

C2007 API to IronPython
SheetManager..::ActiveSheet Property
Currently active sheet of DataArea

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
Sheet ActiveSheet { get; }
ReadOnly Property ActiveSheet As Sheet
property Sheet^ ActiveSheet {
    Sheet^ get ();
}

See Also

SheetManager Interface
GUI.PythonApi.Data Namespace


GUI.PythonApi.Layout Namespace

C2007 API to IronPython
GUI.PythonApi.Layout Namespace
Contains interfaces exposed to Python by View layer

Types

All Types | Interfaces
Name | Description
ModuleLayout | Defines Python contract on ModuleLayout


ModuleLayout Interface

| Members | See Also
C2007 API to IronPython
ModuleLayout Interface
Defines Python contract on ModuleLayout

Namespace: GUI.PythonApi.Layout
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
public interface ModuleLayout
Public Interface ModuleLayout
public interface class ModuleLayout

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Activate(DataField) | Activates the DF
Module | Module for which the layout was build for

See Also

GUI.PythonApi.Layout Namespace


ModuleLayout Methods

C2007 API to IronPython
ModuleLayout Methods

The ModuleLayout type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Activate(DataField) | Activates the DF

See Also

ModuleLayout Interface
GUI.PythonApi.Layout Namespace


Activate Method

C2007 API to IronPython
ModuleLayout..::Activate Method
Activates the DF

Namespace: GUI.PythonApi.Layout
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
bool Activate(
    DataField df
)
Function Activate ( _
    df As DataField _
) As Boolean
bool Activate(
    DataField^ df
)

Parameters

df
DataField
DF to activate

Return Value

True if DF was activated, False if it cant be activated

Remarks

The following table shows fields that can be activated and corresponding user action to activate the field

DF behaviour | User action
c1-c4 | Button press
e1-e4 | LMouse click
f1-f4 | LMouse doubleclick
g1-g4 | Enter key press
h | LMouse click

See Also

ModuleLayout Interface
GUI.PythonApi.Layout Namespace


ModuleLayout Properties

C2007 API to IronPython
ModuleLayout Properties

The ModuleLayout type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Module | Module for which the layout was build for

See Also

ModuleLayout Interface
GUI.PythonApi.Layout Namespace


Module Property

C2007 API to IronPython
ModuleLayout..::Module Property
Module for which the layout was build for

Namespace: GUI.PythonApi.Layout
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C# | Visual Basic | Visual C++
Module Module { get; }
ReadOnly Property Module As Module
property Module^ Module {
    Module^ get ();
}

See Also

ModuleLayout Interface
GUI.PythonApi.Layout Namespace