GUI.PythonApi Namespace

Root namespace of Python API. Contains three subnamespaces: Data, Customizing and Layout

Class Diagram of Python API to GUI elements
Interfaces
 | Interface | Description
Public interface | Environment | Defines Python contract on Environment
Public interface | Logger | Defines Python contract on Logger
Public interface | PpmsPanel | Defines Python contract on PpmsPanel
Public interface | ShadingWindow | Defines Python contract on ShadingWindow
Enumerations
 | Enumeration | Description
Public enumeration | ClientProtocolVersionEnum | Client Protocol Version
Public enumeration | ServerProtocolVersionEnum | Server Protocol Version
Public enumeration | WindowState | Panel window state Data Type

PLANTA GmbH


ClientProtocolVersionEnum Enumeration

Client Protocol Version

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[C#]:enum""" ClientProtocolVersionEnum
Members
Member name | Value | Description
NO_OPTIONS_ENABLED | 0 | initial protocol
COMPRESSION_ENABLED | 1 | compression enabled
FIXED_DA_PRINTING | 2 | add new attribute "print_for_fixed_da" in DAC node
SHOW_DF_ON_SCREEN_ONLY | 3 | add new attribute "show_screen_only" in DFC node
RPC_MESSAGE | 4 | RPC message handling: sending/receiving RPC messages
See Also

Reference

GUI.PythonApi Namespace


Environment Interface

Defines Python contract on Environment

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[C#]:interface""" Environment

The Environment type exposes the following members.

Properties
 | Name | Description
Public property | ActivePanel | Current active client's panel.
Public property | ChangeSetID | ChangeSetID - the latest TFS changeset ID of the current build
Public property | ClientProtocolVersion | Client protocol version number. Used for notifying server about supported features on client. Use latest protocol version.
Public property | DpiX | Gets number of pixels per logical inch along the screen width
Public property | DpiY | Gets number of pixels per logical inch along the screen height
Public property | Logger | Class for output messages
Public property | PanelsList | List of all opened clients panels.
Public property | PdfExportDocumentsList | Get PdfExportDocument list needed for PDF file generation.
Public property | ServerProtocolVersion | Server protocol version number. Used for detecting supported features on server.
Public property | ServerProtocolVersionIsVenus | Server protocol version is Venus or later (ProgramVersion >= 39.5.0.0). Used to track new features in Venus like: ClientMenuTranslations node with global Insert and others.
Top
Methods
 | Name | Description
Public method | GenerateExcelFile | Generate excel document
Public method | GeneratePdfFile | Generate PDF file from pdf export documents list.
Public method | MinimizePanels | Minimize panels
Public method | RestorePanels | Restore panels
Public method | TotalBusyModeOff | Disables total busy mode
Public method | TotalBusyModeOn | Enables total busy mode
Top
See Also

Reference

GUI.PythonApi Namespace


Environment Properties

The Environment type exposes the following members.

Properties
 | Name | Description
Public property | ActivePanel | Current active client's panel.
Public property | ChangeSetID | ChangeSetID - the latest TFS changeset ID of the current build
Public property | ClientProtocolVersion | Client protocol version number. Used for notifying server about supported features on client. Use latest protocol version.
Public property | DpiX | Gets number of pixels per logical inch along the screen width
Public property | DpiY | Gets number of pixels per logical inch along the screen height
Public property | Logger | Class for output messages
Public property | PanelsList | List of all opened clients panels.
Public property | PdfExportDocumentsList | Get PdfExportDocument list needed for PDF file generation.
Public property | ServerProtocolVersion | Server protocol version number. Used for detecting supported features on server.
Public property | ServerProtocolVersionIsVenus | Server protocol version is Venus or later (ProgramVersion >= 39.5.0.0). Used to track new features in Venus like: ClientMenuTranslations node with global Insert and others.
Top
See Also

Reference

Environment Interface
GUI.PythonApi Namespace


Environment.ActivePanel Property

PLANTA API to IronPython

EnvironmentActivePanel Property

Current active client's panel.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[PpmsPanel]""" ActivePanel """[C#]:{ get; }"""

Property Value

Type: PpmsPanel
See Also

Reference

Environment Interface
GUI.PythonApi Namespace


Environment.ChangeSetID Property

EnvironmentChangeSetID Property

ChangeSetID - the latest TFS changeset ID of the current build

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[str]""" ChangeSetID """[C#]:{ get; }"""

Property Value

Type: String
See Also

Reference

Environment Interface
GUI.PythonApi Namespace


Environment.ClientProtocolVersion Property

EnvironmentClientProtocolVersion Property

Client protocol version number. Used for notifying server about supported features on client. Use latest protocol version.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[ClientProtocolVersionEnum]""" ClientProtocolVersion """[C#]:{ get; }"""

Property Value

Type: ClientProtocolVersionEnum
See Also

Reference

Environment Interface
GUI.PythonApi Namespace


Environment.DpiX Property

EnvironmentDpiX Property

Gets number of pixels per logical inch along the screen width

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[int]""" DpiX """[C#]:{ get; }"""

Property Value

Type: Int32
See Also

Reference

Environment Interface
GUI.PythonApi Namespace


Environment.DpiY Property

EnvironmentDpiY Property

Gets number of pixels per logical inch along the screen height

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[int]""" DpiY """[C#]:{ get; }"""

Property Value

Type: Int32
See Also

Reference

Environment Interface
GUI.PythonApi Namespace


Environment.Logger Property

EnvironmentLogger Property

Class for output messages

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[Logger]""" Logger """[C#]:{ get; }"""

Property Value

Type: Logger
See Also

Reference

Environment Interface
GUI.PythonApi Namespace


Environment.PanelsList Property

EnvironmentPanelsList Property

List of all opened clients panels.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[IEnumerable<PpmsPanel>]""" PanelsList """[C#]:{ get; }"""

Property Value

Type: IEnumerable PpmsPanel
See Also

Reference

Environment Interface
GUI.PythonApi Namespace


Environment.PdfExportDocumentsList Property

EnvironmentPdfExportDocumentsList Property

Get PdfExportDocument list needed for PDF file generation.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[List<PdfExportDocument>]""" PdfExportDocumentsList """[C#]:{ get; }"""

Property Value

Type: List PdfExportDocument
See Also

Reference

Environment Interface
GUI.PythonApi Namespace


Environment.ServerProtocolVersion Property

EnvironmentServerProtocolVersion Property

Server protocol version number. Used for detecting supported features on server.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[ServerProtocolVersionEnum]""" ServerProtocolVersion """[C#]:{ get; }"""

Property Value

Type: ServerProtocolVersionEnum
See Also

Reference

Environment Interface
GUI.PythonApi Namespace


Environment.ServerProtocolVersionIsVenus Property

EnvironmentServerProtocolVersionIsVenus Property

Server protocol version is Venus or later (ProgramVersion >= 39.5.0.0). Used to track new features in Venus like: ClientMenuTranslations node with global Insert and others.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[bool]""" ServerProtocolVersionIsVenus """[C#]:{ get; }"""

Property Value

Type: Boolean
See Also

Reference

Environment Interface
GUI.PythonApi Namespace


Environment Methods

The Environment type exposes the following members.

Methods
 | Name | Description
Public method | GenerateExcelFile | Generate excel document
Public method | GeneratePdfFile | Generate PDF file from pdf export documents list.
Public method | MinimizePanels | Minimize panels
Public method | RestorePanels | Restore panels
Public method | TotalBusyModeOff | Disables total busy mode
Public method | TotalBusyModeOn | Enables total busy mode
Top
See Also

Reference

Environment Interface
GUI.PythonApi Namespace


Environment.GenerateExcelFile Method

EnvironmentGenerateExcelFile Method

Generate excel document

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[None]""" def GenerateExcelFile(
    """[ExcelExportDocument]""" excelExportDocument,
    """[bool]""" waitForExcelExport
)

Parameters

excelExportDocument
Type: GUI.PythonApi.ExportExcelExportDocument
configured excel document
waitForExcelExport (Optional)
Type: SystemBoolean
wait until excel export terminates
See Also

Reference

Environment Interface
GUI.PythonApi Namespace


Environment.GeneratePdfFile Method

EnvironmentGeneratePdfFile Method

Generate PDF file from pdf export documents list.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[str]""" def GeneratePdfFile(
    """[List<PdfExportDocument>]""" documentsList,
    """[str]""" path,
    """[str]""" name
)

Parameters

documentsList
Type: System.Collections.GenericList PdfExportDocument
pdf export documents list
path
Type: SystemString
path to file
name
Type: SystemString
Name of the output file

Return Value

Type: String
PDF file full name if generation is successful, empty string otherwise
See Also

Reference

Environment Interface
GUI.PythonApi Namespace


Environment.MinimizePanels Method

EnvironmentMinimizePanels Method

Minimize panels

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[None]""" def MinimizePanels()
See Also

Reference

Environment Interface
GUI.PythonApi Namespace


Environment.RestorePanels Method

EnvironmentRestorePanels Method

Restore panels

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[None]""" def RestorePanels()
See Also

Reference

Environment Interface
GUI.PythonApi Namespace


Environment.TotalBusyModeOff Method

EnvironmentTotalBusyModeOff Method

Disables total busy mode

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[None]""" def TotalBusyModeOff()
See Also

Reference

Environment Interface
GUI.PythonApi Namespace


Environment.TotalBusyModeOn Method

EnvironmentTotalBusyModeOn Method

Enables total busy mode

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[None]""" def TotalBusyModeOn()
See Also

Reference

Environment Interface
GUI.PythonApi Namespace


Logger Interface

Defines Python contract on Logger

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[C#]:interface""" Logger

The Logger type exposes the following members.

Methods
 | Name | Description
Public method | Close | Close log file.
Public method | Debug | Write DEBUG msg into log file.
Public method | Error | Write ERROR msg into log file.
Public method | Fatal | Write FATAL msg into log file.
Public method | GetLogDirectory | Returns directory containing logs.
Public method | GetSupportLogFileName | Returns support log file name.
Public method | Info | Write INFO msg into log file.
Public method | Warning | Write WARNING msg into log file.
Top
See Also

Reference

GUI.PythonApi Namespace


Logger Methods

The Logger type exposes the following members.

Methods
 | Name | Description
Public method | Close | Close log file.
Public method | Debug | Write DEBUG msg into log file.
Public method | Error | Write ERROR msg into log file.
Public method | Fatal | Write FATAL msg into log file.
Public method | GetLogDirectory | Returns directory containing logs.
Public method | GetSupportLogFileName | Returns support log file name.
Public method | Info | Write INFO msg into log file.
Public method | Warning | Write WARNING msg into log file.
Top
See Also

Reference

Logger Interface
GUI.PythonApi Namespace


Logger.Close Method

LoggerClose Method

Close log file.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[None]""" def Close()
See Also

Reference

Logger Interface
GUI.PythonApi Namespace


Logger.Debug Method

LoggerDebug Method

Write DEBUG msg into log file.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[None]""" def Debug(
    """[str]""" msg
)

Parameters

msg
Type: SystemString
log string
See Also

Reference

Logger Interface
GUI.PythonApi Namespace


Logger.Error Method

LoggerError Method

Write ERROR msg into log file.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[None]""" def Error(
    """[str]""" msg
)

Parameters

msg
Type: SystemString
log string
See Also

Reference

Logger Interface
GUI.PythonApi Namespace


Logger.Fatal Method

LoggerFatal Method

Write FATAL msg into log file.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[None]""" def Fatal(
    """[str]""" msg
)

Parameters

msg
Type: SystemString
log string
See Also

Reference

Logger Interface
GUI.PythonApi Namespace


Logger.GetLogDirectory Method

LoggerGetLogDirectory Method

Returns directory containing logs.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[str]""" def GetLogDirectory()

Return Value

Type: String
Log directory name
See Also

Reference

Logger Interface
GUI.PythonApi Namespace


Logger.GetSupportLogFileName Method

LoggerGetSupportLogFileName Method

Returns support log file name.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[str]""" def GetSupportLogFileName()

Return Value

Type: String
Support log file name
See Also

Reference

Logger Interface
GUI.PythonApi Namespace


Logger.Info Method

LoggerInfo Method

Write INFO msg into log file.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[None]""" def Info(
    """[str]""" msg
)

Parameters

msg
Type: SystemString
log string
See Also

Reference

Logger Interface
GUI.PythonApi Namespace


Logger.Warning Method

LoggerWarning Method

Write WARNING msg into log file.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[None]""" def Warning(
    """[str]""" msg
)

Parameters

msg
Type: SystemString
log string
See Also

Reference

Logger Interface
GUI.PythonApi Namespace


PpmsPanel Interface

Defines Python contract on PpmsPanel

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[C#]:interface""" PpmsPanel

The PpmsPanel type exposes the following members.

Properties
 | Name | Description
Public property | MainModule | Return any Main module of the Panel.
Public property | Modules | All modules currently present on the Panel
Public property | Uid | Uid
Public property | WindowState | Return window state of PPMS Panel.
Top
Methods
 | Name | Description
Public method | GetShadingWindow | Get object of Shading window with specified parameters
Top
See Also

Reference

GUI.PythonApi Namespace


PpmsPanel Properties

The PpmsPanel type exposes the following members.

Properties
 | Name | Description
Public property | MainModule | Return any Main module of the Panel.
Public property | Modules | All modules currently present on the Panel
Public property | Uid | Uid
Public property | WindowState | Return window state of PPMS Panel.
Top
See Also

Reference

PpmsPanel Interface
GUI.PythonApi Namespace


PpmsPanel.MainModule Property

PpmsPanelMainModule Property

Return any Main module of the Panel.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[Module]""" MainModule """[C#]:{ get; }"""

Property Value

Type: Module
Remarks
Usually there should be a single Main module in a Panel
See Also

Reference

PpmsPanel Interface
GUI.PythonApi Namespace


PpmsPanel.Modules Property

PpmsPanelModules Property

All modules currently present on the Panel

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[IEnumerable<Module>]""" Modules """[C#]:{ get; }"""

Property Value

Type: IEnumerable Module
See Also

Reference

PpmsPanel Interface
GUI.PythonApi Namespace


PpmsPanel.Uid Property

PpmsPanelUid Property

Uid

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[str]""" Uid """[C#]:{ get; }"""

Property Value

Type: String
See Also

Reference

PpmsPanel Interface
GUI.PythonApi Namespace


PpmsPanel.WindowState Property

PpmsPanelWindowState Property

Return window state of PPMS Panel.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[WindowState]""" WindowState """[C#]:{ get; }"""

Property Value

Type: WindowState
See Also

Reference

PpmsPanel Interface
GUI.PythonApi Namespace


PpmsPanel Methods

The PpmsPanel type exposes the following members.

Methods
 | Name | Description
Public method | GetShadingWindow | Get object of Shading window with specified parameters
Top
See Also

Reference

PpmsPanel Interface
GUI.PythonApi Namespace


PpmsPanel.GetShadingWindow Method

PpmsPanelGetShadingWindow Method

Get object of Shading window with specified parameters

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[ShadingWindow]""" def GetShadingWindow(
    """[str]""" text,
    """[int]""" r,
    """[int]""" g,
    """[int]""" b,
    """[int]""" opacity,
    """[bool]""" spinnerIsVisible
)

Parameters

text
Type: SystemString
Text which will be displayed on Shading window
r
Type: SystemByte
The red component of window background color. Valid values are 0 through 255.
g
Type: SystemByte
The green component of window background color. Valid values are 0 through 255.
b
Type: SystemByte
The blue component of window background color. Valid values are 0 through 255.
opacity
Type: SystemByte
The level of opacity for the Shading window.
spinnerIsVisible
Type: SystemBoolean
Parameter which specifies visibility of spinner. If True - spinner is visible.

Return Value

Type: ShadingWindow
ShadingWindow object
See Also

Reference

PpmsPanel Interface
GUI.PythonApi Namespace


ServerProtocolVersionEnum Enumeration

Server Protocol Version

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[C#]:enum""" ServerProtocolVersionEnum
Members
Member name | Value | Description
EARTH_SERVER | -1 | earth server
VENUS_OLD | 0 | venus old server
COMPRESSION_ENABLED | 1 | venus new server with compression enabled
FIXED_DA_PRINTING | 2 | add new attribute "print_for_fixed_da" in DAC node
SHOW_DF_ON_SCREEN_ONLY | 3 | add new attribute "show_screen_only" in DFC node
RPC_MESSAGE | 4 | RPC message handling: sending/receiving RPC messages
See Also

Reference

GUI.PythonApi Namespace


ShadingWindow Interface

Defines Python contract on ShadingWindow

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[C#]:interface""" ShadingWindow

The ShadingWindow type exposes the following members.

Properties
 | Name | Description
Public property | text | Get or set text which will be displayed on Shading window.
Top
Methods
 | Name | Description
Public method | activate | Show shading window
Public method | disable | Hide shading window
Top
See Also

Reference

GUI.PythonApi Namespace


ShadingWindow Properties

The ShadingWindow type exposes the following members.

Properties
 | Name | Description
Public property | text | Get or set text which will be displayed on Shading window.
Top
See Also

Reference

ShadingWindow Interface
GUI.PythonApi Namespace


ShadingWindow.text Property

ShadingWindowtext Property

Get or set text which will be displayed on Shading window.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[str]""" text """[C#]:{ get; set; }"""

Property Value

Type: String
See Also

Reference

ShadingWindow Interface
GUI.PythonApi Namespace


ShadingWindow Methods

The ShadingWindow type exposes the following members.

Methods
 | Name | Description
Public method | activate | Show shading window
Public method | disable | Hide shading window
Top
See Also

Reference

ShadingWindow Interface
GUI.PythonApi Namespace


ShadingWindow.activate Method

ShadingWindowactivate Method

Show shading window

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[None]""" def activate()
See Also

Reference

ShadingWindow Interface
GUI.PythonApi Namespace


ShadingWindow.disable Method

ShadingWindowdisable Method

Hide shading window

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[None]""" def disable()
See Also

Reference

ShadingWindow Interface
GUI.PythonApi Namespace


WindowState Enumeration

Panel window state Data Type

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[C#]:enum""" WindowState
Members
Member name | Value | Description
Normal | 0 | Normal
Maximized | 1 | Maximized
Minimized | 2 | Minimized
Unknown | 3 | Unknown
See Also

Reference

GUI.PythonApi Namespace


GUI.PythonApi.Customizing Namespace

Contains interfaces exposed to Python by Customizing objects
Interfaces
 | Interface | Description
Public interface | DataAreaCustomizing | Defines Python contract on DataAreaCustomizing
Public interface | DataFieldCustomizing | Defines Python contract on DataFieldCustomizing
Public interface | ModuleCustomizing | Defines Python contract on Customizing
Public interface | RawTextFormatInfo | Raw Text Format Info
Public interface | RootCustomizing | Defines Python contract on Customizing
Enumerations
 | Enumeration | Description
Public enumeration | RawDataType | Raw DataField Data Type


DataAreaCustomizing Interface

Defines Python contract on DataAreaCustomizing

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[C#]:interface""" DataAreaCustomizing

The DataAreaCustomizing type exposes the following members.

Properties
 | Name | Description
Public property | ChildrenDFC | List of DFCs the DAC has
Public property | Name | DAC name
Public property | Uid | Uid
Top
Methods
 | Name | Description
Public method | get_customizing_name | Get DataAreaCustomizing name
Public method | get_df_by_name | Get DataFieldCustomizing by its name(NOT USED ANYMORE. USE get_dfc_by_name(string name))
Public method | get_dfc_by_name | Get DataFieldCustomizing by its name
Public method | TryGetDFC | Tries to locate a DFC by uid
Top
See Also

Reference

GUI.PythonApi.Customizing Namespace


DataAreaCustomizing Properties

The DataAreaCustomizing type exposes the following members.

Properties
 | Name | Description
Public property | ChildrenDFC | List of DFCs the DAC has
Public property | Name | DAC name
Public property | Uid | Uid
Top
See Also

Reference

DataAreaCustomizing Interface
GUI.PythonApi.Customizing Namespace


DataAreaCustomizing.ChildrenDFC Property

DataAreaCustomizingChildrenDFC Property

List of DFCs the DAC has

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[IEnumerable<DataFieldCustomizing>]""" ChildrenDFC """[C#]:{ get; }"""

Property Value

Type: IEnumerable DataFieldCustomizing
See Also

Reference

DataAreaCustomizing Interface
GUI.PythonApi.Customizing Namespace


DataAreaCustomizing.Name Property

DataAreaCustomizingName Property

DAC name

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[str]""" Name """[C#]:{ get; }"""

Property Value

Type: String
See Also

Reference

DataAreaCustomizing Interface
GUI.PythonApi.Customizing Namespace


DataAreaCustomizing.Uid Property

DataAreaCustomizingUid Property

Uid

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[str]""" Uid """[C#]:{ get; }"""

Property Value

Type: String
See Also

Reference

DataAreaCustomizing Interface
GUI.PythonApi.Customizing Namespace


DataAreaCustomizing Methods

The DataAreaCustomizing type exposes the following members.

Methods
 | Name | Description
Public method | get_customizing_name | Get DataAreaCustomizing name
Public method | get_df_by_name | Get DataFieldCustomizing by its name(NOT USED ANYMORE. USE get_dfc_by_name(string name))
Public method | get_dfc_by_name | Get DataFieldCustomizing by its name
Public method | TryGetDFC | Tries to locate a DFC by uid
Top
See Also

Reference

DataAreaCustomizing Interface
GUI.PythonApi.Customizing Namespace


DataAreaCustomizing.get_customizing_name Method

DataAreaCustomizingget_customizing_name Method

Get DataAreaCustomizing name

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[str]""" def get_customizing_name()

Return Value

Type: String
DataAreaCustomizing Name
See Also

Reference

DataAreaCustomizing Interface
GUI.PythonApi.Customizing Namespace


DataAreaCustomizing.get_df_by_name Method

DataAreaCustomizingget_df_by_name Method

Get DataFieldCustomizing by its name(NOT USED ANYMORE. USE get_dfc_by_name(string name))

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[DataFieldCustomizing]""" def get_df_by_name(
    """[str]""" name
)

Parameters

name
Type: SystemString
Name of DataFieldCustomizing to look for

Return Value

Type: DataFieldCustomizing
Found DataFieldCustomizing or None if name is not found
See Also

Reference

DataAreaCustomizing Interface
GUI.PythonApi.Customizing Namespace


DataAreaCustomizing.get_dfc_by_name Method

DataAreaCustomizingget_dfc_by_name Method

Get DataFieldCustomizing by its name

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[DataFieldCustomizing]""" def get_dfc_by_name(
    """[str]""" name
)

Parameters

name
Type: SystemString
Name of DataFieldCustomizing to look for

Return Value

Type: DataFieldCustomizing
Found DataFieldCustomizing or None if name is not found
See Also

Reference

DataAreaCustomizing Interface
GUI.PythonApi.Customizing Namespace


DataAreaCustomizing.TryGetDFC Method

DataAreaCustomizingTryGetDFC Method

Tries to locate a DFC by uid

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[bool]""" def TryGetDFC(
    """[str]""" uid,
    """[C#]:[out]""" """[DataFieldCustomizing]""" dfc
)

Parameters

uid
Type: SystemString
UID of DFC to get
dfc
Type: GUI.PythonApi.CustomizingDataFieldCustomizing
Receives found DFC or None if not found

Return Value

Type: Boolean
True if found, False otherwise
Remarks
If DAC has a DFC with given uid True is returned and will point to it, otherwise returns False and dfc will be set to None
See Also

Reference

DataAreaCustomizing Interface
GUI.PythonApi.Customizing Namespace


DataFieldCustomizing Interface

Defines Python contract on DataFieldCustomizing

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[C#]:interface""" DataFieldCustomizing

The DataFieldCustomizing type exposes the following members.

Properties
 | Name | Description
Public property | PythonScriptSettings | Python script settings. Customized script parameters.
Public property | RawTextFormat | Gets Raw Text format of DFC
Public property | Title | DFC title
Public property | Uid | Uid
Top
Methods
 | Name | Description
Public method | get_customizing_name | Get DataFieldCustomizing name
Top
Remarks
Class Diagram of DFC elements
See Also

Reference

GUI.PythonApi.Customizing Namespace


DataFieldCustomizing Properties

The DataFieldCustomizing type exposes the following members.

Properties
 | Name | Description
Public property | PythonScriptSettings | Python script settings. Customized script parameters.
Public property | RawTextFormat | Gets Raw Text format of DFC
Public property | Title | DFC title
Public property | Uid | Uid
Top
See Also

Reference

DataFieldCustomizing Interface
GUI.PythonApi.Customizing Namespace


DataFieldCustomizing.PythonScriptSettings Property

DataFieldCustomizingPythonScriptSettings Property

Python script settings. Customized script parameters.

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[str]""" PythonScriptSettings """[C#]:{ get; }"""

Property Value

Type: String
See Also

Reference

DataFieldCustomizing Interface
GUI.PythonApi.Customizing Namespace


DataFieldCustomizing.RawTextFormat Property

DataFieldCustomizingRawTextFormat Property

Gets Raw Text format of DFC

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[RawTextFormatInfo]""" RawTextFormat """[C#]:{ get; }"""

Property Value

Type: RawTextFormatInfo
See Also

Reference

DataFieldCustomizing Interface
GUI.PythonApi.Customizing Namespace


DataFieldCustomizing.Title Property

DataFieldCustomizingTitle Property

DFC title

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[str]""" Title """[C#]:{ get; }"""

Property Value

Type: String
See Also

Reference

DataFieldCustomizing Interface
GUI.PythonApi.Customizing Namespace


DataFieldCustomizing.Uid Property

DataFieldCustomizingUid Property

Uid

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[str]""" Uid """[C#]:{ get; }"""

Property Value

Type: String
See Also

Reference

DataFieldCustomizing Interface
GUI.PythonApi.Customizing Namespace


DataFieldCustomizing Methods

The DataFieldCustomizing type exposes the following members.

Methods
 | Name | Description
Public method | get_customizing_name | Get DataFieldCustomizing name
Top
See Also

Reference

DataFieldCustomizing Interface
GUI.PythonApi.Customizing Namespace


DataFieldCustomizing.get_customizing_name Method

DataFieldCustomizingget_customizing_name Method

Get DataFieldCustomizing name

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[str]""" def get_customizing_name()

Return Value

Type: String
DataFieldCustomizing name
See Also

Reference

DataFieldCustomizing Interface
GUI.PythonApi.Customizing Namespace


ModuleCustomizing Interface

Defines Python contract on Customizing

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[C#]:interface""" ModuleCustomizing

The ModuleCustomizing type exposes the following members.

Properties
 | Name | Description
Public property | Roots | All RootCustomizings of the Customizing
Public property | Uid | Uid
Top
See Also

Reference

GUI.PythonApi.Customizing Namespace


ModuleCustomizing Properties

The ModuleCustomizing type exposes the following members.

Properties
 | Name | Description
Public property | Roots | All RootCustomizings of the Customizing
Public property | Uid | Uid
Top
See Also

Reference

ModuleCustomizing Interface
GUI.PythonApi.Customizing Namespace


ModuleCustomizing.Roots Property

ModuleCustomizingRoots Property

All RootCustomizings of the Customizing

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[IEnumerable<RootCustomizing>]""" Roots """[C#]:{ get; }"""

Property Value

Type: IEnumerable RootCustomizing
See Also

Reference

ModuleCustomizing Interface
GUI.PythonApi.Customizing Namespace


ModuleCustomizing.Uid Property

ModuleCustomizingUid Property

Uid

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[str]""" Uid """[C#]:{ get; }"""

Property Value

Type: String
See Also

Reference

ModuleCustomizing Interface
GUI.PythonApi.Customizing Namespace


RawDataType Enumeration

Raw DataField Data Type

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[C#]:enum""" RawDataType
Members
Member name | Value | Description
String | 0 | String
Integral | 1 | Integral
Decimal | 2 | Decimal
Date | 3 | Date
Time | 4 | Time
Currency | 5 | Currency
See Also

Reference

GUI.PythonApi.Customizing Namespace


RawTextFormatInfo Interface

Raw Text Format Info

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[C#]:interface""" RawTextFormatInfo

The RawTextFormatInfo type exposes the following members.

Properties
 | Name | Description
Public property | PDataType | Data type
Public property | SuffixSymbol | Suffix symbol
Public property | ZeroPadWidth | Zero pad width
Top
See Also

Reference

GUI.PythonApi.Customizing Namespace


RawTextFormatInfo Properties

The RawTextFormatInfo type exposes the following members.

Properties
 | Name | Description
Public property | PDataType | Data type
Public property | SuffixSymbol | Suffix symbol
Public property | ZeroPadWidth | Zero pad width
Top
See Also

Reference

RawTextFormatInfo Interface
GUI.PythonApi.Customizing Namespace


RawTextFormatInfo.PDataType Property

RawTextFormatInfoPDataType Property

Data type

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[RawDataType]""" PDataType """[C#]:{ get; }"""

Property Value

Type: RawDataType
See Also

Reference

RawTextFormatInfo Interface
GUI.PythonApi.Customizing Namespace


RawTextFormatInfo.SuffixSymbol Property

RawTextFormatInfoSuffixSymbol Property

Suffix symbol

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[str]""" SuffixSymbol """[C#]:{ get; }"""

Property Value

Type: String
See Also

Reference

RawTextFormatInfo Interface
GUI.PythonApi.Customizing Namespace


RawTextFormatInfo.ZeroPadWidth Property

RawTextFormatInfoZeroPadWidth Property

Zero pad width

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[int]""" ZeroPadWidth """[C#]:{ get; }"""

Property Value

Type: Int32
See Also

Reference

RawTextFormatInfo Interface
GUI.PythonApi.Customizing Namespace


RootCustomizing Interface

Defines Python contract on Customizing

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[C#]:interface""" RootCustomizing

The RootCustomizing type exposes the following members.

Properties
 | Name | Description
Public property | Uid | Uid
Public property | VirtualRootDAC | Virtual root DAC that groups all top level DACs.
Top
Methods
 | Name | Description
Public method | GetDAC | Looks for DataAreaCustomizing with given uid
Top
See Also

Reference

GUI.PythonApi.Customizing Namespace


RootCustomizing Properties

The RootCustomizing type exposes the following members.

Properties
 | Name | Description
Public property | Uid | Uid
Public property | VirtualRootDAC | Virtual root DAC that groups all top level DACs.
Top
See Also

Reference

RootCustomizing Interface
GUI.PythonApi.Customizing Namespace


RootCustomizing.Uid Property

RootCustomizingUid Property

Uid

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[str]""" Uid """[C#]:{ get; }"""

Property Value

Type: String
See Also

Reference

RootCustomizing Interface
GUI.PythonApi.Customizing Namespace


RootCustomizing.VirtualRootDAC Property

RootCustomizingVirtualRootDAC Property

Virtual root DAC that groups all top level DACs.

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[DataAreaCustomizing]""" VirtualRootDAC """[C#]:{ get; }"""

Property Value

Type: DataAreaCustomizing
See Also

Reference

RootCustomizing Interface
GUI.PythonApi.Customizing Namespace


RootCustomizing Methods

The RootCustomizing type exposes the following members.

Methods
 | Name | Description
Public method | GetDAC | Looks for DataAreaCustomizing with given uid
Top
See Also

Reference

RootCustomizing Interface
GUI.PythonApi.Customizing Namespace


RootCustomizing.GetDAC Method

RootCustomizingGetDAC Method

Looks for DataAreaCustomizing with given uid

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[DataAreaCustomizing]""" def GetDAC(
    """[str]""" uid
)

Parameters

uid
Type: SystemString
DataAreaCustomizing uid to search for

Return Value

Type: DataAreaCustomizing
DataAreaCustomizing with given UID or None if not found
See Also

Reference

RootCustomizing Interface
GUI.PythonApi.Customizing Namespace


GUI.PythonApi.Data Namespace

Contains interfaces exposed to Python by Data objects
Interfaces
 | Interface | Description
Public interface | DataArea | Defines Python contract on DataArea
Public interface | DataField | Defines Python contract on DataField
Public interface | Module | Defines Python contract on Module
Public interface | Root | Defines Python contract on Root
Public interface | Sheet | Defines Python contract on Sheet
Public interface | SheetManager | Defines Python contract on SheetManager


DataArea Interface

Defines Python contract on DataArea

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[C#]:interface""" DataArea

The DataArea type exposes the following members.

Properties
 | Name | Description
Public property | ChildrenDF | DFs of DA
Public property | Customizing | DA customizing
Public property | DASheets | SheetManager of DA sheets
Public property | Uid | Uid
Top
Methods
 | Name | Description
Public method | get_children | Get list of child DataAreas which belong to the DataAreaCustomizing with current custName
Public method | get_customizing_name | Get name of DataAreaCustomizing
Public method | get_dfc | Get DataFieldCustomizing with specified customizing name
Public method | get_id | Get ID of data area customizing
Public method | get_records | Get list of all DataAreas which belong to the customizing of current dataarea
Top
See Also

Reference

GUI.PythonApi.Data Namespace


DataArea Properties

The DataArea type exposes the following members.

Properties
 | Name | Description
Public property | ChildrenDF | DFs of DA
Public property | Customizing | DA customizing
Public property | DASheets | SheetManager of DA sheets
Public property | Uid | Uid
Top
See Also

Reference

DataArea Interface
GUI.PythonApi.Data Namespace


DataArea.ChildrenDF Property

DataAreaChildrenDF Property

DFs of DA

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[IEnumerable<DataField>]""" ChildrenDF """[C#]:{ get; }"""

Property Value

Type: IEnumerable DataField
See Also

Reference

DataArea Interface
GUI.PythonApi.Data Namespace


DataArea.Customizing Property

DataAreaCustomizing Property

DA customizing

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[DataAreaCustomizing]""" Customizing """[C#]:{ get; }"""

Property Value

Type: DataAreaCustomizing
See Also

Reference

DataArea Interface
GUI.PythonApi.Data Namespace


DataArea.DASheets Property

DataAreaDASheets Property

SheetManager of DA sheets

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[SheetManager]""" DASheets """[C#]:{ get; }"""

Property Value

Type: SheetManager
See Also

Reference

DataArea Interface
GUI.PythonApi.Data Namespace


DataArea.Uid Property

DataAreaUid Property

Uid

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[str]""" Uid """[C#]:{ get; }"""

Property Value

Type: String
See Also

Reference

DataArea Interface
GUI.PythonApi.Data Namespace


DataArea Methods

The DataArea type exposes the following members.

Methods
 | Name | Description
Public method | get_children | Get list of child DataAreas which belong to the DataAreaCustomizing with current custName
Public method | get_customizing_name | Get name of DataAreaCustomizing
Public method | get_dfc | Get DataFieldCustomizing with specified customizing name
Public method | get_id | Get ID of data area customizing
Public method | get_records | Get list of all DataAreas which belong to the customizing of current dataarea
Top
See Also

Reference

DataArea Interface
GUI.PythonApi.Data Namespace


DataArea.get_children Method

DataAreaget_children Method

Get list of child DataAreas which belong to the DataAreaCustomizing with current custName

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[List<DataArea>]""" def get_children(
    """[str]""" custName
)

Parameters

custName
Type: SystemString
name of DataAreaCustomizing

Return Value

Type: List DataArea
List of child DataAreas which belong to the DataAreaCustomizing with current custName
See Also

Reference

DataArea Interface
GUI.PythonApi.Data Namespace


DataArea.get_customizing_name Method

DataAreaget_customizing_name Method

Get name of DataAreaCustomizing

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[str]""" def get_customizing_name()

Return Value

Type: String
Name of DataAreaCustomizing
See Also

Reference

DataArea Interface
GUI.PythonApi.Data Namespace


DataArea.get_dfc Method

DataAreaget_dfc Method

Get DataFieldCustomizing with specified customizing name

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[DataFieldCustomizing]""" def get_dfc(
    """[str]""" custName
)

Parameters

custName
Type: SystemString
name of DataFieldCustomizing

Return Value

Type: DataFieldCustomizing
DataFieldCustomizing instance with specified customizing name
See Also

Reference

DataArea Interface
GUI.PythonApi.Data Namespace


DataArea.get_id Method

DataAreaget_id Method

Get ID of data area customizing

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[str]""" def get_id()

Return Value

Type: String
Data area customizing ID
See Also

Reference

DataArea Interface
GUI.PythonApi.Data Namespace


DataArea.get_records Method

DataAreaget_records Method

Get list of all DataAreas which belong to the customizing of current dataarea

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[List<DataArea>]""" def get_records()

Return Value

Type: List DataArea
List of all DataAreas which belong to the customizing of current dataarea
See Also

Reference

DataArea Interface
GUI.PythonApi.Data Namespace


DataField Interface

Defines Python contract on DataField

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[C#]:interface""" DataField

The DataField type exposes the following members.

Properties
 | Name | Description
Public property | Customizing | DF CU
Public property | HasRawText | Gets a value indicating whether the DataField has a raw value assigned.
Public property | RawText | Gets or sets a raw text (an unformatted value). This method should only be used when the parameter "Raw Format" is activated on DT406 for the data source DA.
Top
Methods
 | Name | Description
Public method | get_customizing_name | Get customizing name of data field
Public method | GetControlImage | Get bitmap image of embedded control in data field
Public method | GetValueT | Gets DF value.
Public method | LoadControl | Loading embedded control in data field
Public method | SetServerValue | Sets DF value, like if the user have changed it
Top
See Also

Reference

GUI.PythonApi.Data Namespace


DataField Properties

The DataField type exposes the following members.

Properties
 | Name | Description
Public property | Customizing | DF CU
Public property | HasRawText | Gets a value indicating whether the DataField has a raw value assigned.
Public property | RawText | Gets or sets a raw text (an unformatted value). This method should only be used when the parameter "Raw Format" is activated on DT406 for the data source DA.
Top
See Also

Reference

DataField Interface
GUI.PythonApi.Data Namespace


DataField.Customizing Property

DataFieldCustomizing Property

DF CU

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[DataFieldCustomizing]""" Customizing """[C#]:{ get; }"""

Property Value

Type: DataFieldCustomizing
See Also

Reference

DataField Interface
GUI.PythonApi.Data Namespace


DataField.HasRawText Property

DataFieldHasRawText Property

Gets a value indicating whether the DataField has a raw value assigned.

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[bool]""" HasRawText """[C#]:{ get; set; }"""

Property Value

Type: Boolean
See Also

Reference

DataField Interface
GUI.PythonApi.Data Namespace


DataField.RawText Property

DataFieldRawText Property

Gets or sets a raw text (an unformatted value). This method should only be used when the parameter "Raw Format" is activated on DT406 for the data source DA.

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[Object]""" RawText """[C#]:{ get; set; }"""

Property Value

Type: Object
See Also

Reference

DataField Interface
GUI.PythonApi.Data Namespace


DataField Methods

The DataField type exposes the following members.

Methods
 | Name | Description
Public method | get_customizing_name | Get customizing name of data field
Public method | GetControlImage | Get bitmap image of embedded control in data field
Public method | GetValueT | Gets DF value.
Public method | LoadControl | Loading embedded control in data field
Public method | SetServerValue | Sets DF value, like if the user have changed it
Top
See Also

Reference

DataField Interface
GUI.PythonApi.Data Namespace


DataField.get_customizing_name Method

DataFieldget_customizing_name Method

Get customizing name of data field

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[str]""" def get_customizing_name()

Return Value

Type: String
Customizing name of data field
See Also

Reference

DataField Interface
GUI.PythonApi.Data Namespace


DataField.GetControlImage Method

DataFieldGetControlImage Method

Get bitmap image of embedded control in data field

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[Object]""" def GetControlImage(
    """[ModuleLayout]""" layout
)

Parameters

layout
Type: GUI.PythonApi.LayoutModuleLayout
Module layout which contains current data field

Return Value

Type: Object
Bitmap image of embedded control. If data field doesn't have any control - return null
See Also

Reference

DataField Interface
GUI.PythonApi.Data Namespace


DataField.GetValue(T) Method

DataFieldGetValueT Method

Gets DF value.

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[T]""" def GetValue()

Type Parameters

T
The type of Value to retrieve from DF. Consider reading remarks

Return Value

Type: T
DF value of type T
Remarks
The type of DF value is determined by its behavior. To make code typesafe this function is generic. So calling code must pass valid T when requesting DF value Depending on DF behavior a valid object type must be specified

DF behavior | T type
i2 and o2 | Boolean
c1-c4 | DataFieldButtonValue
h | DataFieldHlinkValue
a | BinaryImage
all other | String
See Also

Reference

DataField Interface
GUI.PythonApi.Data Namespace


DataField.LoadControl Method

DataFieldLoadControl Method

Loading embedded control in data field

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[bool]""" def LoadControl(
    """[ModuleLayout]""" layout
)

Parameters

layout
Type: GUI.PythonApi.LayoutModuleLayout
Module layout which contains current data field

Return Value

Type: Boolean
true - if data fied contains embedded control and it is loaded correctly. false - if data field doesn't not containt embedded control or error happened while control loading
See Also

Reference

DataField Interface
GUI.PythonApi.Data Namespace


DataField.SetServerValue Method

DataFieldSetServerValue Method

Sets DF value, like if the user have changed it

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[None]""" def SetServerValue(
    """[ModuleLayout]""" ml,
    """[Object]""" value
)

Parameters

ml
Type: GUI.PythonApi.LayoutModuleLayout
Module layout that caused the value to be set
value
Type: SystemObject
Depending on DF behavior a valid object type must be specified. Read remarks to GetValueT
See Also

Reference

DataField Interface
GUI.PythonApi.Data Namespace


Module Interface

Defines Python contract on Module

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[C#]:interface""" Module

The Module type exposes the following members.

Properties
 | Name | Description
Public property | Customizing | Module customizing
Public property | Roots | All roots of the module
Public property | Uid | Uid
Top
Methods
 | Name | Description
Public method | CreateExcelExportDocument | Create Excel export document which is used for exporting module content to Excel file. Module excel export configuration is shared between python excel export and normal excel export. This method overrides previous module excel export configuration. You can use this method to control default excel export configuration in normal module excel export. Usage example: 1) >>> import os >>> env = get_Env() >>> mod = env.ActivePanel.ModuleManager.__getitem__('10') >>> doc = mod.CreateExcelExportDocument(DACsCU_NamesToExport = {'Vorgang', 'Ressource'}, fullExportPath = os.path.normpath('C:/PlantaClient/Debug/Test'), exportLayout = True, adjustColors = True ) >>> env.GenerateExcelFile(doc) 2) >>> env = get_Env() >>> mod = env.ActivePanel.ModuleManager.__getitem__('10') >>> doc = mod.CreateExcelExportDocument(DACsCU_NamesToExport = {'Ressource'}, useBulkExport = True) >>> env.GenerateExcelFile(doc)
Public method | CreatePdfExportDocument | Create PDF export document, which is used for exporting module content to PDF file.
Public method | CreatePrintExportDocument | Create print export document, which is used for printing module.
Public method | ExportToExcelSetCurrencyFormatting | Apply any formatting to currency data-format. Use excel-custom-formatting style, fore details see excel formatting guide. For example: value == 100 formatting == # ##0$;-# ##0$ User sees: 100$
Public method | ExportToExcelWithDialog | Show excel export dialog
Public method | ExportToPdfWithDialog | Exports module to pdf file using dialog window.
Public method | get_dac | Get DataAreaCustomizing with specified customizing name
Public method | get_id | Get ID of module customizing
Top
Events
 | Name | Description
Public event | DAChanged | Event
Top
See Also

Reference

GUI.PythonApi.Data Namespace


Module Properties

The Module type exposes the following members.

Properties
 | Name | Description
Public property | Customizing | Module customizing
Public property | Roots | All roots of the module
Public property | Uid | Uid
Top
See Also

Reference

Module Interface
GUI.PythonApi.Data Namespace


Module.Customizing Property

ModuleCustomizing Property

Module customizing

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[ModuleCustomizing]""" Customizing """[C#]:{ get; }"""

Property Value

Type: ModuleCustomizing
See Also

Reference

Module Interface
GUI.PythonApi.Data Namespace


Module.Roots Property

ModuleRoots Property

All roots of the module

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[IEnumerable<Root>]""" Roots """[C#]:{ get; }"""

Property Value

Type: IEnumerable Root
See Also

Reference

Module Interface
GUI.PythonApi.Data Namespace


Module.Uid Property

ModuleUid Property

Uid

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[str]""" Uid """[C#]:{ get; }"""

Property Value

Type: String
See Also

Reference

Module Interface
GUI.PythonApi.Data Namespace


Module Methods

The Module type exposes the following members.

Methods
 | Name | Description
Public method | CreateExcelExportDocument | Create Excel export document which is used for exporting module content to Excel file. Module excel export configuration is shared between python excel export and normal excel export. This method overrides previous module excel export configuration. You can use this method to control default excel export configuration in normal module excel export. Usage example: 1) >>> import os >>> env = get_Env() >>> mod = env.ActivePanel.ModuleManager.__getitem__('10') >>> doc = mod.CreateExcelExportDocument(DACsCU_NamesToExport = {'Vorgang', 'Ressource'}, fullExportPath = os.path.normpath('C:/PlantaClient/Debug/Test'), exportLayout = True, adjustColors = True ) >>> env.GenerateExcelFile(doc) 2) >>> env = get_Env() >>> mod = env.ActivePanel.ModuleManager.__getitem__('10') >>> doc = mod.CreateExcelExportDocument(DACsCU_NamesToExport = {'Ressource'}, useBulkExport = True) >>> env.GenerateExcelFile(doc)
Public method | CreatePdfExportDocument | Create PDF export document, which is used for exporting module content to PDF file.
Public method | CreatePrintExportDocument | Create print export document, which is used for printing module.
Public method | ExportToExcelSetCurrencyFormatting | Apply any formatting to currency data-format. Use excel-custom-formatting style, fore details see excel formatting guide. For example: value == 100 formatting == # ##0$;-# ##0$ User sees: 100$
Public method | ExportToExcelWithDialog | Show excel export dialog
Public method | ExportToPdfWithDialog | Exports module to pdf file using dialog window.
Public method | get_dac | Get DataAreaCustomizing with specified customizing name
Public method | get_id | Get ID of module customizing
Top
See Also

Reference

Module Interface
GUI.PythonApi.Data Namespace


Module.CreateExcelExportDocument Method

ModuleCreateExcelExportDocument Method

Create Excel export document which is used for exporting module content to Excel file.

Module excel export configuration is shared between python excel export and normal excel export. This method overrides previous module excel export configuration. You can use this method to control default excel export configuration in normal module excel export.

Usage example:

1)

>>> import os

>>> env = get_Env()

>>> mod = env.ActivePanel.ModuleManager.__getitem__('10')

>>> doc = mod.CreateExcelExportDocument(DACsCU_NamesToExport = {'Vorgang', 'Ressource'}, fullExportPath = os.path.normpath('C:/PlantaClient/Debug/Test'), exportLayout = True, adjustColors = True )

>>> env.GenerateExcelFile(doc)

2)

>>> env = get_Env()

>>> mod = env.ActivePanel.ModuleManager.__getitem__('10')

>>> doc = mod.CreateExcelExportDocument(DACsCU_NamesToExport = {'Ressource'}, useBulkExport = True)

>>> env.GenerateExcelFile(doc)

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[ExcelExportDocument]""" def CreateExcelExportDocument(
    """[IEnumerable<str>]""" DACsCU_NamesToExport,
    """[str]""" fullExportPath,
    """[str]""" excelCurrencyFormat,
    """[bool]""" useBulkExport,
    """[bool]""" exportLayout,
    """[bool]""" adjustColors,
    """[bool]""" freezeFirstWindow,
    """[bool]""" rewriteExistedFile,
    """[bool]""" closeModule
)

Parameters

DACsCU_NamesToExport (Optional)
Type: System.Collections.GenericIEnumerable String
List of data area customizings CU_name, that will be exported, default value == None (export all data). If bulk export is used, first element will be taken as default for bulk export, but recommended to use single element collection (DACsCU_NamesToExport = {'Ressource'})
fullExportPath (Optional)
Type: SystemString
Full path, where exported document will be saved, default value == None (just display exported document). Usage example: CreateExcelExportDocument(fullExportPath = os.path.normpath('C:/SomeDir/OtherDir/FileName.xls')). Do not forget to use 'import os'. File extinction is not necessary.
excelCurrencyFormat (Optional)
Type: SystemString
Apply any formatting to currency data-format. Use excel-custom-formatting style, fore details see excel formatting guide. For example: value == 100 formatting == # ##0$;-# ##0$ User sees: 100$ default value == None
useBulkExport (Optional)
Type: SystemBoolean
Use bulkExport, default value == False
exportLayout (Optional)
Type: SystemBoolean
Layout options: Export layout, default value == False
adjustColors (Optional)
Type: SystemBoolean
Layout options: Adjust colors to the default palette, depends on exportLayout, if exportLayout == False, this param will be ignored, default value == False
freezeFirstWindow (Optional)
Type: SystemBoolean
Use Excel freeze function for windows 1, default value == True
rewriteExistedFile (Optional)
Type: SystemBoolean
try to rewrite file if it exist, default value == True
closeModule (Optional)
Type: SystemBoolean
Close module panel after data usage terminated. This action do not breaks excel export, as usual closing panel action.

Return Value

Type: ExcelExportDocument
ExcelExportDocument instance if all configuration data is ok, None otherwise
See Also

Reference

Module Interface
GUI.PythonApi.Data Namespace


Module.CreatePdfExportDocument Method

ModuleCreatePdfExportDocument Method

Create PDF export document, which is used for exporting module content to PDF file.

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[PdfExportDocument]""" def CreatePdfExportDocument(
    """[str]""" name,
    """[str]""" pageSize,
    """[Nullable<bool>]""" landscape,
    """[Nullable<bool>]""" fitToPage,
    """[Nullable<float>]""" zoom,
    """[Nullable<int>]""" marginLeft,
    """[Nullable<int>]""" marginRight,
    """[Nullable<int>]""" marginTop,
    """[Nullable<int>]""" marginBottom
)

Parameters

name (Optional)
Type: SystemString
Document name, if it is not set or empty, it is taken from module name
pageSize (Optional)
Type: SystemString
Page size: A4, A3, A2, if it is not set or empty, it is taken from module printing settings
landscape (Optional)
Type: SystemNullable Boolean
Landscape orientation, if it is not set, it is taken from module printing settings
fitToPage (Optional)
Type: SystemNullable Boolean
Fit content to page, if it is not set, it is taken from module printing settings. If it equals True, causes ignoring of the zoom
zoom (Optional)
Type: SystemNullable Single
Content zoom factor in percents, if it is not set, it is taken from module printing settings. It is not accounted if the fitToPage = True
marginLeft (Optional)
Type: SystemNullable Int32
Margin left in dmm, if it is not set, it is taken from module printing settings
marginRight (Optional)
Type: SystemNullable Int32
Margin right in dmm, if it is not set, it is taken from module printing settings
marginTop (Optional)
Type: SystemNullable Int32
Margin top in dmm, if it is not set, it is taken from module printing settings
marginBottom (Optional)
Type: SystemNullable Int32
Margin bottom in dmm, if it is not set, it is taken from module printing settings

Return Value

Type: PdfExportDocument
PdfExportDocument
See Also

Reference

Module Interface
GUI.PythonApi.Data Namespace


Module.CreatePrintExportDocument Method

ModuleCreatePrintExportDocument Method

Create print export document, which is used for printing module.

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[PrintExportDocument]""" def CreatePrintExportDocument(
    """[str]""" name,
    """[str]""" pageSize,
    """[Nullable<bool>]""" landscape,
    """[Nullable<bool>]""" fitToPage,
    """[Nullable<float>]""" zoom,
    """[Nullable<int>]""" marginLeft,
    """[Nullable<int>]""" marginRight,
    """[Nullable<int>]""" marginTop,
    """[Nullable<int>]""" marginBottom
)

Parameters

name (Optional)
Type: SystemString
Document name, if it is not set or empty, it is taken from module name
pageSize (Optional)
Type: SystemString
Page size: A4, A3, A2, if it is not set or empty, it is taken from module printing settings
landscape (Optional)
Type: SystemNullable Boolean
Landscape orientation, if it is not set, it is taken from module printing settings
fitToPage (Optional)
Type: SystemNullable Boolean
Fit content to page, if it is not set, it is taken from module printing settings. If it equals True, causes ignoring of the zoom
zoom (Optional)
Type: SystemNullable Single
Content zoom factor in percents, if it is not set, it is taken from module printing settings. It is not accounted if the fitToPage = True
marginLeft (Optional)
Type: SystemNullable Int32
Margin left in dmm, if it is not set, it is taken from module printing settings
marginRight (Optional)
Type: SystemNullable Int32
Margin right in dmm, if it is not set, it is taken from module printing settings
marginTop (Optional)
Type: SystemNullable Int32
Margin top in dmm, if it is not set, it is taken from module printing settings
marginBottom (Optional)
Type: SystemNullable Int32
Margin bottom in dmm, if it is not set, it is taken from module printing settings

Return Value

Type: PrintExportDocument
PrintExportDocument
See Also

Reference

Module Interface
GUI.PythonApi.Data Namespace


Module.ExportToExcelSetCurrencyFormatting Method

ModuleExportToExcelSetCurrencyFormatting Method

Apply any formatting to currency data-format. Use excel-custom-formatting style, fore details see excel formatting guide. For example: value == 100 formatting == # ##0$;-# ##0$ User sees: 100$

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[bool]""" def ExportToExcelSetCurrencyFormatting(
    """[str]""" formatting
)

Parameters

formatting
Type: SystemString
needed formatting

Return Value

Type: Boolean
True if formatting is valid, False otherwise
See Also

Reference

Module Interface
GUI.PythonApi.Data Namespace


Module.ExportToExcelWithDialog Method

ModuleExportToExcelWithDialog Method

Show excel export dialog

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[bool]""" def ExportToExcelWithDialog()

Return Value

Type: Boolean
True if action is successfully, False otherwise
See Also

Reference

Module Interface
GUI.PythonApi.Data Namespace


Module.ExportToPdfWithDialog Method

ModuleExportToPdfWithDialog Method

Exports module to pdf file using dialog window.

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[bool]""" def ExportToPdfWithDialog(
    """[str]""" directory,
    """[str]""" name
)

Parameters

directory (Optional)
Type: SystemString
Output directory. If value is None, the execution path of the client will be used. Default value is None.
name (Optional)
Type: SystemString
Module name. If value is None, the Name property of the customizing will be used. Default value is None.

Return Value

Type: Boolean
True if export is successful, False otherwise
See Also

Reference

Module Interface
GUI.PythonApi.Data Namespace


Module.get_dac Method

Moduleget_dac Method

Get DataAreaCustomizing with specified customizing name

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[DataAreaCustomizing]""" def get_dac(
    """[str]""" custName
)

Parameters

custName
Type: SystemString
CU_name of the DataAreaCustomizing

Return Value

Type: DataAreaCustomizing
DataAreaCustomizing with specified customizing name or None if not found
See Also

Reference

Module Interface
GUI.PythonApi.Data Namespace


Module.get_id Method

Moduleget_id Method

Get ID of module customizing

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[str]""" def get_id()

Return Value

Type: String
ID of module customizing
See Also

Reference

Module Interface
GUI.PythonApi.Data Namespace


Module Events

The Module type exposes the following members.

Events
 | Name | Description
Public event | DAChanged | Event
Top
See Also

Reference

Module Interface
GUI.PythonApi.Data Namespace


Module.DAChanged Event

ModuleDAChanged Event

Event

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
#[C#]:
"""event EventHandler DAChanged"""

Value

Type: SystemEventHandler
See Also

Reference

Module Interface
GUI.PythonApi.Data Namespace


Root Interface

Defines Python contract on Root

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[C#]:interface""" Root

The Root type exposes the following members.

Properties
 | Name | Description
Public property | Customizing | Root Customizing
Public property | Uid | Uid
Public property | VirtualRootDA | Virtual root DA that groups all top level DAs.
Top
Methods
 | Name | Description
Public method | get_dac | Get DataAreaCustomizing with specified customizing name
Public method | get_records | Get list of all DataAreas which belong to the DataAreaCustomizing with current CU_name
Public method | GetDA | Looks for DA with given uid
Top
See Also

Reference

GUI.PythonApi.Data Namespace


Root Properties

The Root type exposes the following members.

Properties
 | Name | Description
Public property | Customizing | Root Customizing
Public property | Uid | Uid
Public property | VirtualRootDA | Virtual root DA that groups all top level DAs.
Top
See Also

Reference

Root Interface
GUI.PythonApi.Data Namespace


Root.Customizing Property

RootCustomizing Property

Root Customizing

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[RootCustomizing]""" Customizing """[C#]:{ get; }"""

Property Value

Type: RootCustomizing
See Also

Reference

Root Interface
GUI.PythonApi.Data Namespace


Root.Uid Property

RootUid Property

Uid

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[str]""" Uid """[C#]:{ get; }"""

Property Value

Type: String
See Also

Reference

Root Interface
GUI.PythonApi.Data Namespace


Root.VirtualRootDA Property

RootVirtualRootDA Property

Virtual root DA that groups all top level DAs.

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[DataArea]""" VirtualRootDA """[C#]:{ get; }"""

Property Value

Type: DataArea
See Also

Reference

Root Interface
GUI.PythonApi.Data Namespace


Root Methods

The Root type exposes the following members.

Methods
 | Name | Description
Public method | get_dac | Get DataAreaCustomizing with specified customizing name
Public method | get_records | Get list of all DataAreas which belong to the DataAreaCustomizing with current CU_name
Public method | GetDA | Looks for DA with given uid
Top
See Also

Reference

Root Interface
GUI.PythonApi.Data Namespace


Root.get_dac Method

Rootget_dac Method

Get DataAreaCustomizing with specified customizing name

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[DataAreaCustomizing]""" def get_dac(
    """[str]""" custName
)

Parameters

custName
Type: SystemString
CU_name of the DataAreaCustomizing

Return Value

Type: DataAreaCustomizing
DataAreaCustomizing with specified customizing name
See Also

Reference

Root Interface
GUI.PythonApi.Data Namespace


Root.get_records Method

Rootget_records Method

Get list of all DataAreas which belong to the DataAreaCustomizing with current CU_name

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[List<DataArea>]""" def get_records(
    """[str]""" custName
)

Parameters

custName
Type: SystemString
CU_name of the DataAreaCustomizing

Return Value

Type: List DataArea
List of all DataAreas which belong to the DataAreaCustomizing with current CU_name
See Also

Reference

Root Interface
GUI.PythonApi.Data Namespace


Root.GetDA Method

RootGetDA Method

Looks for DA with given uid

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[DataArea]""" def GetDA(
    """[str]""" uid
)

Parameters

uid
Type: SystemString
Uid of DA to look for

Return Value

Type: DataArea
DA with given UID or None if not found
See Also

Reference

Root Interface
GUI.PythonApi.Data Namespace


Sheet Interface

Defines Python contract on Sheet

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[C#]:interface""" Sheet

The Sheet type exposes the following members.

Properties
 | Name | Description
Public property | Uid | Uid
Top
Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable DataArea .)
Top
See Also

Reference

GUI.PythonApi.Data Namespace


Sheet Properties

The Sheet type exposes the following members.

Properties
 | Name | Description
Public property | Uid | Uid
Top
See Also

Reference

Sheet Interface
GUI.PythonApi.Data Namespace


Sheet.Uid Property

SheetUid Property

Uid

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[str]""" Uid """[C#]:{ get; }"""

Property Value

Type: String
See Also

Reference

Sheet Interface
GUI.PythonApi.Data Namespace


Sheet Methods

The Sheet type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable DataArea .)
Top
See Also

Reference

Sheet Interface
GUI.PythonApi.Data Namespace


SheetManager Interface

Defines Python contract on SheetManager

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[C#]:interface""" SheetManager

The SheetManager type exposes the following members.

Properties
 | Name | Description
Public property | ActiveSheet | Currently active sheet of DataArea.
Top
See Also

Reference

GUI.PythonApi.Data Namespace


SheetManager Properties

The SheetManager type exposes the following members.

Properties
 | Name | Description
Public property | ActiveSheet | Currently active sheet of DataArea.
Top
See Also

Reference

SheetManager Interface
GUI.PythonApi.Data Namespace


SheetManager.ActiveSheet Property

SheetManagerActiveSheet Property

Currently active sheet of DataArea.

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[Sheet]""" ActiveSheet """[C#]:{ get; }"""

Property Value

Type: Sheet
See Also

Reference

SheetManager Interface
GUI.PythonApi.Data Namespace


GUI.PythonApi.Export Namespace

Defines Python contracts on the documents export
Interfaces
 | Interface | Description
Public interface | ExcelExportDocument | Defines Python contract on ExcelExportDocument. This document is used for exporting module content to Excel file.
Public interface | PdfExportDocument | Defines Python contract on PdfExportDocument. This document is used for exporting module content to PDF file.
Public interface | PrintExportDocument | Defines Python contract on PrintExportDocument. This document is used for printing module.


ExcelExportDocument Interface

Defines Python contract on ExcelExportDocument. This document is used for exporting module content to Excel file.

Namespace: GUI.PythonApi.Export
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[C#]:interface""" ExcelExportDocument
See Also

Reference

GUI.PythonApi.Export Namespace


PdfExportDocument Interface

Defines Python contract on PdfExportDocument. This document is used for exporting module content to PDF file.

Namespace: GUI.PythonApi.Export
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[C#]:interface""" PdfExportDocument
See Also

Reference

GUI.PythonApi.Export Namespace


PrintExportDocument Interface

Defines Python contract on PrintExportDocument. This document is used for printing module.

Namespace: GUI.PythonApi.Export
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[C#]:interface""" PrintExportDocument
See Also

Reference

GUI.PythonApi.Export Namespace


GUI.PythonApi.Layout Namespace

Contains interfaces exposed to Python by View layer
Interfaces
 | Interface | Description
Public interface | ModuleLayout | Defines Python contract on ModuleLayout


ModuleLayout Interface

Defines Python contract on ModuleLayout

Namespace: GUI.PythonApi.Layout
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[C#]:interface""" ModuleLayout

The ModuleLayout type exposes the following members.

Properties
 | Name | Description
Public property | Module | Module for which the layout was build for
Public property | OnwerPanel | Panel in which current module is shown
Top
Methods
 | Name | Description
Public method | Activate | Activates the DF
Public method | LoadAllControls | Load all embedded controls which are not loaded in module. Including controls which are in collapsed and hidden data areas.
Top
See Also

Reference

GUI.PythonApi.Layout Namespace


ModuleLayout Properties

The ModuleLayout type exposes the following members.

Properties
 | Name | Description
Public property | Module | Module for which the layout was build for
Public property | OnwerPanel | Panel in which current module is shown
Top
See Also

Reference

ModuleLayout Interface
GUI.PythonApi.Layout Namespace


ModuleLayout.Module Property

ModuleLayoutModule Property

Module for which the layout was build for

Namespace: GUI.PythonApi.Layout
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[Module]""" Module """[C#]:{ get; }"""

Property Value

Type: Module
See Also

Reference

ModuleLayout Interface
GUI.PythonApi.Layout Namespace


ModuleLayout.OnwerPanel Property

ModuleLayoutOnwerPanel Property

Panel in which current module is shown

Namespace: GUI.PythonApi.Layout
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[PpmsPanel]""" OnwerPanel """[C#]:{ get; }"""

Property Value

Type: PpmsPanel
See Also

Reference

ModuleLayout Interface
GUI.PythonApi.Layout Namespace


ModuleLayout Methods

The ModuleLayout type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the DF
Public method | LoadAllControls | Load all embedded controls which are not loaded in module. Including controls which are in collapsed and hidden data areas.
Top
See Also

Reference

ModuleLayout Interface
GUI.PythonApi.Layout Namespace


ModuleLayout.Activate Method

ModuleLayoutActivate Method

Activates the DF

Namespace: GUI.PythonApi.Layout
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[bool]""" def Activate(
    """[DataField]""" df
)

Parameters

df
Type: GUI.PythonApi.DataDataField
DF to activate

Return Value

Type: Boolean
True if DF was activated, False if it cant be activated
Remarks
The following table shows fields that can be activated and corresponding user action to activate the field

DF behavior | User action
c1-c4 | Button press
e1-e4 | LMouse click
f1-f4 | LMouse doubleclick
g1-g4 | Enter key press
h | LMouse click
See Also

Reference

ModuleLayout Interface
GUI.PythonApi.Layout Namespace


ModuleLayout.LoadAllControls Method

ModuleLayoutLoadAllControls Method

Load all embedded controls which are not loaded in module. Including controls which are in collapsed and hidden data areas.

Namespace: GUI.PythonApi.Layout
Assembly: PythonApi (in PythonApi.dll) Version: 5.21.0.60719 (5.21.0.60719)
Syntax
Python
Copy
"""[None]""" def LoadAllControls()
Remarks
Call of this method from within data field python script will lead to an exception. This method must be called from a Client service.
See Also

Reference

ModuleLayout Interface
GUI.PythonApi.Layout Namespace


Variables of embedded controls

Description of scope variables which are available in DF scripts

Here you can find variables which can be used from python DF scripts directly.

Variables

df
DataField
Embedded control owner DataFiled

moduleLayout
Embedded control owner ModuleLayout

ctl
Control
Embedded control