GUI.PythonApi Namespace

PLANTA API to IronPython
GUI.PythonApi Namespace
Send Feedback
Root namespace of Python API. Contains three subnamespaces: Data, Customizing and Layout Class Diagram of Python API to GUI elements

Interfaces

 | Interface | Description
Public interface | Environment | Defines Python contract on Environment
Public interface | Logger | Defines Python contract on Logger
Public interface | PpmsPanel | Defines Python contract on PpmsPanel
Public interface | ShadingWindow | Defines Python contract on ShadingWindow

Enumerations

 | Enumeration | Description
Public enumeration | WindowState | Panel window state Data Type

PLANTA GmbH


Environment Interface

Environment Interface
Members See Also Send Feedback
Defines Python contract on Environment

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[C#]:interface""" Environment

See Also

Environment Members
GUI.PythonApi Namespace


Environment Members

[image]

PLANTA API to IronPython
Environment Members
Environment Interface Methods Properties See Also Send Feedback

The Environment type exposes the following members.

Methods

 | Name | Description
Public method | GenerateExcelFile | Generate excel document
Public method | GeneratePdfFile | Generate PDF file from pdf export documents list.
Public method | MinimizePanels | Minimize panels
Public method | RestorePanels | Restore panels
Public method | TotalBusyModeOff | Disables total busy mode
Public method | TotalBusyModeOn | Enables total busy mode

Properties

 | Name | Description
Public property | ChangeSetID | ChangeSetID - the latest TFS changeset ID of the current build
Public property | DpiX | Gets number of pixels per logical inch along the screen width
Public property | DpiY | Gets number of pixels per logical inch along the screen height
Public property | Logger | Class for output messages
Public property | PdfExportDocumentsList | Get PdfExportDocument list needed for PDF file generation.

See Also

Environment Interface
GUI.PythonApi Namespace


Environment Methods

[image]

PLANTA API to IronPython
Environment Methods
Environment Interface See Also Send Feedback

The Environment type exposes the following members.

Methods

 | Name | Description
Public method | GenerateExcelFile | Generate excel document
Public method | GeneratePdfFile | Generate PDF file from pdf export documents list.
Public method | MinimizePanels | Minimize panels
Public method | RestorePanels | Restore panels
Public method | TotalBusyModeOff | Disables total busy mode
Public method | TotalBusyModeOn | Enables total busy mode

See Also

Environment Interface
GUI.PythonApi Namespace


Environment.GenerateExcelFile Method

Environment..::..GenerateExcelFile Method
Environment Interface See Also Send Feedback
Generate excel document

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[None]""" def GenerateExcelFile(
    """[ExcelExportDocument]""" excelExportDocument
)

Parameters

excelExportDocument
Type: GUI.PythonApi.Export..::..ExcelExportDocument
configured excel document

See Also

Environment Interface
Environment Members
GUI.PythonApi Namespace


Environment.GeneratePdfFile Method

Environment..::..GeneratePdfFile Method
Environment Interface See Also Send Feedback
Generate PDF file from pdf export documents list.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[str]""" def GeneratePdfFile(
    """[List<PdfExportDocument>]""" documentsList,
    """[str]""" path,
    """[str]""" name
)

Parameters

documentsList
Type: System.Collections.Generic..::..List <(Of <(<' PdfExportDocument >)>)>
pdf export documents list
path
Type: System..::..String
path to file
name
Type: System..::..String
Name of the output file

Return Value

Type: String
PDF file full name if generation is successful, empty string otherwise

See Also

Environment Interface
Environment Members
GUI.PythonApi Namespace


Environment.MinimizePanels Method

Environment..::..MinimizePanels Method
Environment Interface See Also Send Feedback
Minimize panels

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[None]""" def MinimizePanels()

See Also

Environment Interface
Environment Members
GUI.PythonApi Namespace


Environment.RestorePanels Method

Environment..::..RestorePanels Method
Environment Interface See Also Send Feedback
Restore panels

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[None]""" def RestorePanels()

See Also

Environment Interface
Environment Members
GUI.PythonApi Namespace


Environment.TotalBusyModeOff Method

Environment..::..TotalBusyModeOff Method
Environment Interface See Also Send Feedback
Disables total busy mode

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[None]""" def TotalBusyModeOff()

See Also

Environment Interface
Environment Members
GUI.PythonApi Namespace


Environment.TotalBusyModeOn Method

Environment..::..TotalBusyModeOn Method
Environment Interface See Also Send Feedback
Enables total busy mode

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[None]""" def TotalBusyModeOn()

See Also

Environment Interface
Environment Members
GUI.PythonApi Namespace


Environment Properties

[image]

PLANTA API to IronPython
Environment Properties
Environment Interface See Also Send Feedback

The Environment type exposes the following members.

Properties

 | Name | Description
Public property | ChangeSetID | ChangeSetID - the latest TFS changeset ID of the current build
Public property | DpiX | Gets number of pixels per logical inch along the screen width
Public property | DpiY | Gets number of pixels per logical inch along the screen height
Public property | Logger | Class for output messages
Public property | PdfExportDocumentsList | Get PdfExportDocument list needed for PDF file generation.

See Also

Environment Interface
GUI.PythonApi Namespace


Environment.ChangeSetID Property

Environment..::..ChangeSetID Property
Environment Interface See Also Send Feedback
ChangeSetID - the latest TFS changeset ID of the current build

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[str]""" ChangeSetID """[C#]:{ get; }"""

Property Value

Type: String

See Also

Environment Interface
Environment Members
GUI.PythonApi Namespace


Environment.DpiX Property

Environment..::..DpiX Property
Environment Interface See Also Send Feedback
Gets number of pixels per logical inch along the screen width

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[int]""" DpiX """[C#]:{ get; }"""

Property Value

Type: Int32

See Also

Environment Interface
Environment Members
GUI.PythonApi Namespace


Environment.DpiY Property

Environment..::..DpiY Property
Environment Interface See Also Send Feedback
Gets number of pixels per logical inch along the screen height

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[int]""" DpiY """[C#]:{ get; }"""

Property Value

Type: Int32

See Also

Environment Interface
Environment Members
GUI.PythonApi Namespace


Environment.Logger Property

Environment..::..Logger Property
Environment Interface See Also Send Feedback
Class for output messages

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[Logger]""" Logger """[C#]:{ get; }"""

Property Value

Type: Logger

See Also

Environment Interface
Environment Members
GUI.PythonApi Namespace


Environment.PdfExportDocumentsList Property

Environment..::..PdfExportDocumentsList Property
Environment Interface See Also Send Feedback
Get PdfExportDocument list needed for PDF file generation.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[List<PdfExportDocument>]""" PdfExportDocumentsList """[C#]:{ get; }"""

Property Value

Type: List <(Of <(<' PdfExportDocument >)>)>

See Also

Environment Interface
Environment Members
GUI.PythonApi Namespace


Logger Interface

Logger Interface
Members See Also Send Feedback
Defines Python contract on Logger

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[C#]:interface""" Logger

See Also

Logger Members
GUI.PythonApi Namespace


Logger Members

[image]

PLANTA API to IronPython
Logger Members
Logger Interface Methods See Also Send Feedback

The Logger type exposes the following members.

Methods

 | Name | Description
Public method | Close | Close log file.
Public method | Debug | Write DEBUG msg into log file.
Public method | Error | Write ERROR msg into log file.
Public method | Fatal | Write FATAL msg into log file.
Public method | GetLogDirectory | Returns directory containing logs.
Public method | GetSupportLogFileName | Returns support log file name.
Public method | Info | Write INFO msg into log file.
Public method | Warning | Write WARNING msg into log file.

See Also

Logger Interface
GUI.PythonApi Namespace


Logger Methods

[image]

PLANTA API to IronPython
Logger Methods
Logger Interface See Also Send Feedback

The Logger type exposes the following members.

Methods

 | Name | Description
Public method | Close | Close log file.
Public method | Debug | Write DEBUG msg into log file.
Public method | Error | Write ERROR msg into log file.
Public method | Fatal | Write FATAL msg into log file.
Public method | GetLogDirectory | Returns directory containing logs.
Public method | GetSupportLogFileName | Returns support log file name.
Public method | Info | Write INFO msg into log file.
Public method | Warning | Write WARNING msg into log file.

See Also

Logger Interface
GUI.PythonApi Namespace


Logger.Close Method

Logger..::..Close Method
Logger Interface See Also Send Feedback
Close log file.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[None]""" def Close()

See Also

Logger Interface
Logger Members
GUI.PythonApi Namespace


Logger.Debug Method

Logger..::..Debug Method
Logger Interface See Also Send Feedback
Write DEBUG msg into log file.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[None]""" def Debug(
    """[str]""" msg
)

Parameters

msg
Type: System..::..String
log string

See Also

Logger Interface
Logger Members
GUI.PythonApi Namespace


Logger.Error Method

Logger..::..Error Method
Logger Interface See Also Send Feedback
Write ERROR msg into log file.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[None]""" def Error(
    """[str]""" msg
)

Parameters

msg
Type: System..::..String
log string

See Also

Logger Interface
Logger Members
GUI.PythonApi Namespace


Logger.Fatal Method

Logger..::..Fatal Method
Logger Interface See Also Send Feedback
Write FATAL msg into log file.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[None]""" def Fatal(
    """[str]""" msg
)

Parameters

msg
Type: System..::..String
log string

See Also

Logger Interface
Logger Members
GUI.PythonApi Namespace


Logger.GetLogDirectory Method

Logger..::..GetLogDirectory Method
Logger Interface See Also Send Feedback
Returns directory containing logs.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[str]""" def GetLogDirectory()

Return Value

Type: String
Log directory name

See Also

Logger Interface
Logger Members
GUI.PythonApi Namespace


Logger.GetSupportLogFileName Method

Logger..::..GetSupportLogFileName Method
Logger Interface See Also Send Feedback
Returns support log file name.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[str]""" def GetSupportLogFileName()

Return Value

Type: String
Support log file name

See Also

Logger Interface
Logger Members
GUI.PythonApi Namespace


Logger.Info Method

Logger..::..Info Method
Logger Interface See Also Send Feedback
Write INFO msg into log file.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[None]""" def Info(
    """[str]""" msg
)

Parameters

msg
Type: System..::..String
log string

See Also

Logger Interface
Logger Members
GUI.PythonApi Namespace


Logger.Warning Method

Logger..::..Warning Method
Logger Interface See Also Send Feedback
Write WARNING msg into log file.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[None]""" def Warning(
    """[str]""" msg
)

Parameters

msg
Type: System..::..String
log string

See Also

Logger Interface
Logger Members
GUI.PythonApi Namespace


PpmsPanel Interface

PpmsPanel Interface
Members See Also Send Feedback
Defines Python contract on PpmsPanel

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[C#]:interface""" PpmsPanel

See Also

PpmsPanel Members
GUI.PythonApi Namespace


PpmsPanel Members

[image]

PLANTA API to IronPython
PpmsPanel Members
PpmsPanel Interface Methods Properties See Also Send Feedback

The PpmsPanel type exposes the following members.

Methods

 | Name | Description
Public method | GetShadingWindow | Get object of Shading window with specified parameters

Properties

 | Name | Description
Public property | MainModule | Return any Main module of the Panel.
Public property | Modules | All modules currently present on the Panel
Public property | Uid | Uid
Public property | WindowState | Return window state of PPMS Panel.

See Also

PpmsPanel Interface
GUI.PythonApi Namespace


PpmsPanel Methods

[image]

PLANTA API to IronPython
PpmsPanel Methods
PpmsPanel Interface See Also Send Feedback

The PpmsPanel type exposes the following members.

Methods

 | Name | Description
Public method | GetShadingWindow | Get object of Shading window with specified parameters

See Also

PpmsPanel Interface
GUI.PythonApi Namespace


PpmsPanel.GetShadingWindow Method

PpmsPanel..::..GetShadingWindow Method
PpmsPanel Interface See Also Send Feedback
Get object of Shading window with specified parameters

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[ShadingWindow]""" def GetShadingWindow(
    """[str]""" text,
    """[int]""" r,
    """[int]""" g,
    """[int]""" b,
    """[int]""" opacity,
    """[bool]""" spinnerIsVisible
)

Parameters

text
Type: System..::..String
Text which will be displayed on Shading window
r
Type: System..::..Byte
The red component of window background color. Valid values are 0 through 255.
g
Type: System..::..Byte
The green component of window background color. Valid values are 0 through 255.
b
Type: System..::..Byte
The blue component of window background color. Valid values are 0 through 255.
opacity
Type: System..::..Byte
The level of opacity for the Shading window.
spinnerIsVisible
Type: System..::..Boolean
Parameter which specifies visibility of spinner. If True - spinner is visible.

Return Value

Type: ShadingWindow
ShadingWindow object

See Also

PpmsPanel Interface
PpmsPanel Members
GUI.PythonApi Namespace


PpmsPanel Properties

[image]

PLANTA API to IronPython
PpmsPanel Properties
PpmsPanel Interface See Also Send Feedback

The PpmsPanel type exposes the following members.

Properties

 | Name | Description
Public property | MainModule | Return any Main module of the Panel.
Public property | Modules | All modules currently present on the Panel
Public property | Uid | Uid
Public property | WindowState | Return window state of PPMS Panel.

See Also

PpmsPanel Interface
GUI.PythonApi Namespace


PpmsPanel.MainModule Property

PpmsPanel..::..MainModule Property
PpmsPanel Interface See Also Send Feedback
Return any Main module of the Panel.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[Module]""" MainModule """[C#]:{ get; }"""

Property Value

Type: Module

Remarks

Usually there should be a single Main module in a Panel

See Also

PpmsPanel Interface
PpmsPanel Members
GUI.PythonApi Namespace


PpmsPanel.Modules Property

PpmsPanel..::..Modules Property
PpmsPanel Interface See Also Send Feedback
All modules currently present on the Panel

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[IEnumerable<Module>]""" Modules """[C#]:{ get; }"""

Property Value

Type: IEnumerable <(Of <(<' Module >)>)>

See Also

PpmsPanel Interface
PpmsPanel Members
GUI.PythonApi Namespace


PpmsPanel.Uid Property

PpmsPanel..::..Uid Property
PpmsPanel Interface See Also Send Feedback
Uid

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[str]""" Uid """[C#]:{ get; }"""

Property Value

Type: String

See Also

PpmsPanel Interface
PpmsPanel Members
GUI.PythonApi Namespace


PpmsPanel.WindowState Property

PpmsPanel..::..WindowState Property
PpmsPanel Interface See Also Send Feedback
Return window state of PPMS Panel.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[WindowState]""" WindowState """[C#]:{ get; }"""

Property Value

Type: WindowState

See Also

PpmsPanel Interface
PpmsPanel Members
GUI.PythonApi Namespace


ShadingWindow Interface

ShadingWindow Interface
Members See Also Send Feedback
Defines Python contract on ShadingWindow

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[C#]:interface""" ShadingWindow

See Also

ShadingWindow Members
GUI.PythonApi Namespace


ShadingWindow Members

[image]

PLANTA API to IronPython
ShadingWindow Members
ShadingWindow Interface Methods Properties See Also Send Feedback

The ShadingWindow type exposes the following members.

Methods

 | Name | Description
Public method | activate | Show shading window
Public method | disable | Hide shading window

Properties

 | Name | Description
Public property | text | Get or set text which will be displayed on Shading window.

See Also

ShadingWindow Interface
GUI.PythonApi Namespace


ShadingWindow Methods

[image]

PLANTA API to IronPython
ShadingWindow Methods
ShadingWindow Interface See Also Send Feedback

The ShadingWindow type exposes the following members.

Methods

 | Name | Description
Public method | activate | Show shading window
Public method | disable | Hide shading window

See Also

ShadingWindow Interface
GUI.PythonApi Namespace


ShadingWindow.activate Method

ShadingWindow..::..activate Method
ShadingWindow Interface See Also Send Feedback
Show shading window

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[None]""" def activate()

See Also

ShadingWindow Interface
ShadingWindow Members
GUI.PythonApi Namespace


ShadingWindow.disable Method

ShadingWindow..::..disable Method
ShadingWindow Interface See Also Send Feedback
Hide shading window

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[None]""" def disable()

See Also

ShadingWindow Interface
ShadingWindow Members
GUI.PythonApi Namespace


ShadingWindow Properties

[image]

PLANTA API to IronPython
ShadingWindow Properties
ShadingWindow Interface See Also Send Feedback

The ShadingWindow type exposes the following members.

Properties

 | Name | Description
Public property | text | Get or set text which will be displayed on Shading window.

See Also

ShadingWindow Interface
GUI.PythonApi Namespace


ShadingWindow.text Property

ShadingWindow..::..text Property
ShadingWindow Interface See Also Send Feedback
Get or set text which will be displayed on Shading window.

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[str]""" text """[C#]:{ get; set; }"""

Property Value

Type: String

See Also

ShadingWindow Interface
ShadingWindow Members
GUI.PythonApi Namespace


WindowState Enumeration

WindowState Enumeration
See Also Send Feedback
Panel window state Data Type

Namespace: GUI.PythonApi
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[C#]:enum""" WindowState

Members

Member name | Value | Description
Normal | 0 | Normal
Maximized | 1 | Maximized
Minimized | 2 | Minimized
Unknown | 3 | Unknown

See Also

GUI.PythonApi Namespace


GUI.PythonApi.Customizing Namespace

GUI.PythonApi.Customizing Namespace
Send Feedback
Contains interfaces exposed to Python by Customizing objects

Interfaces

 | Interface | Description
Public interface | DataAreaCustomizing | Defines Python contract on DataAreaCustomizing
Public interface | DataFieldCustomizing | Defines Python contract on DataFieldCustomizing
Public interface | ModuleCustomizing | Defines Python contract on Customizing
Public interface | RawTextFormatInfo | Raw Text Format Info
Public interface | RootCustomizing | Defines Python contract on Customizing

Enumerations

 | Enumeration | Description
Public enumeration | RawDataType | Raw DataField Data Type


DataAreaCustomizing Interface

DataAreaCustomizing Interface
Members See Also Send Feedback
Defines Python contract on DataAreaCustomizing

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[C#]:interface""" DataAreaCustomizing

See Also

DataAreaCustomizing Members
GUI.PythonApi.Customizing Namespace


DataAreaCustomizing Members

[image]

PLANTA API to IronPython
DataAreaCustomizing Members
DataAreaCustomizing Interface Methods Properties See Also Send Feedback

The DataAreaCustomizing type exposes the following members.

Methods

 | Name | Description
Public method | get_customizing_name | Get DataAreaCustomizing name
Public method | get_df_by_name | Get DataFieldCustomizing by its name(NOT USED ANYMORE. USE get_dfc_by_name(string name))
Public method | get_dfc_by_name | Get DataFieldCustomizing by its name
Public method | TryGetDFC | Tries to locate a DFC by uid

Properties

 | Name | Description
Public property | ChildrenDFC | List of DFCs the DAC has
Public property | Name | DAC name
Public property | Uid | Uid

See Also

DataAreaCustomizing Interface
GUI.PythonApi.Customizing Namespace


DataAreaCustomizing Methods

[image]

PLANTA API to IronPython
DataAreaCustomizing Methods
DataAreaCustomizing Interface See Also Send Feedback

The DataAreaCustomizing type exposes the following members.

Methods

 | Name | Description
Public method | get_customizing_name | Get DataAreaCustomizing name
Public method | get_df_by_name | Get DataFieldCustomizing by its name(NOT USED ANYMORE. USE get_dfc_by_name(string name))
Public method | get_dfc_by_name | Get DataFieldCustomizing by its name
Public method | TryGetDFC | Tries to locate a DFC by uid

See Also

DataAreaCustomizing Interface
GUI.PythonApi.Customizing Namespace


DataAreaCustomizing.get_customizing_name Method

DataAreaCustomizing..::..get_customizing_name Method
DataAreaCustomizing Interface See Also Send Feedback
Get DataAreaCustomizing name

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[str]""" def get_customizing_name()

Return Value

Type: String
DataAreaCustomizing Name

See Also

DataAreaCustomizing Interface
DataAreaCustomizing Members
GUI.PythonApi.Customizing Namespace


DataAreaCustomizing.get_df_by_name Method

DataAreaCustomizing..::..get_df_by_name Method
DataAreaCustomizing Interface See Also Send Feedback
Get DataFieldCustomizing by its name(NOT USED ANYMORE. USE get_dfc_by_name(string name))

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[DataFieldCustomizing]""" def get_df_by_name(
    """[str]""" name
)

Parameters

name
Type: System..::..String
Name of DataFieldCustomizing to look for

Return Value

Type: DataFieldCustomizing
Found DataFieldCustomizing or None if name is not found

See Also

DataAreaCustomizing Interface
DataAreaCustomizing Members
GUI.PythonApi.Customizing Namespace


DataAreaCustomizing.get_dfc_by_name Method

DataAreaCustomizing..::..get_dfc_by_name Method
DataAreaCustomizing Interface See Also Send Feedback
Get DataFieldCustomizing by its name

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[DataFieldCustomizing]""" def get_dfc_by_name(
    """[str]""" name
)

Parameters

name
Type: System..::..String
Name of DataFieldCustomizing to look for

Return Value

Type: DataFieldCustomizing
Found DataFieldCustomizing or None if name is not found

See Also

DataAreaCustomizing Interface
DataAreaCustomizing Members
GUI.PythonApi.Customizing Namespace


DataAreaCustomizing.TryGetDFC Method

DataAreaCustomizing..::..TryGetDFC Method
DataAreaCustomizing Interface See Also Send Feedback
Tries to locate a DFC by uid

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[bool]""" def TryGetDFC(
    """[str]""" uid,
    """[C#]:[out]""" """[DataFieldCustomizing]""" dfc
)

Parameters

uid
Type: System..::..String
UID of DFC to get
dfc
Type: GUI.PythonApi.Customizing..::..DataFieldCustomizing %
Receives found DFC or None if not found

Return Value

Type: Boolean
True if found, False otherwise

Remarks

If DAC has a DFC with given uid True is returned and will point to it, otherwise returns False and dfc will be set to None

See Also

DataAreaCustomizing Interface
DataAreaCustomizing Members
GUI.PythonApi.Customizing Namespace


DataAreaCustomizing Properties

[image]

PLANTA API to IronPython
DataAreaCustomizing Properties
DataAreaCustomizing Interface See Also Send Feedback

The DataAreaCustomizing type exposes the following members.

Properties

 | Name | Description
Public property | ChildrenDFC | List of DFCs the DAC has
Public property | Name | DAC name
Public property | Uid | Uid

See Also

DataAreaCustomizing Interface
GUI.PythonApi.Customizing Namespace


DataAreaCustomizing.ChildrenDFC Property

DataAreaCustomizing..::..ChildrenDFC Property
DataAreaCustomizing Interface See Also Send Feedback
List of DFCs the DAC has

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[IEnumerable<DataFieldCustomizing>]""" ChildrenDFC """[C#]:{ get; }"""

Property Value

Type: IEnumerable <(Of <(<' DataFieldCustomizing >)>)>

See Also

DataAreaCustomizing Interface
DataAreaCustomizing Members
GUI.PythonApi.Customizing Namespace


DataAreaCustomizing.Name Property

DataAreaCustomizing..::..Name Property
DataAreaCustomizing Interface See Also Send Feedback
DAC name

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[str]""" Name """[C#]:{ get; }"""

Property Value

Type: String

See Also

DataAreaCustomizing Interface
DataAreaCustomizing Members
GUI.PythonApi.Customizing Namespace


DataAreaCustomizing.Uid Property

DataAreaCustomizing..::..Uid Property
DataAreaCustomizing Interface See Also Send Feedback
Uid

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[str]""" Uid """[C#]:{ get; }"""

Property Value

Type: String

See Also

DataAreaCustomizing Interface
DataAreaCustomizing Members
GUI.PythonApi.Customizing Namespace


DataFieldCustomizing Interface

DataFieldCustomizing Interface
Members See Also Send Feedback
Defines Python contract on DataFieldCustomizing

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[C#]:interface""" DataFieldCustomizing

Remarks

Class Diagram of DFC elements

See Also

DataFieldCustomizing Members
GUI.PythonApi.Customizing Namespace


DataFieldCustomizing Members

[image]

PLANTA API to IronPython
DataFieldCustomizing Members
DataFieldCustomizing Interface Methods Properties See Also Send Feedback

The DataFieldCustomizing type exposes the following members.

Methods

 | Name | Description
Public method | get_customizing_name | Get DataFieldCustomizing name

Properties

 | Name | Description
Public property | PythonScriptSettings | Python script settings. Customized script parameters.
Public property | RawTextFormat | Gets Raw Text format of DFC
Public property | Title | DFC title
Public property | Uid | Uid

See Also

DataFieldCustomizing Interface
GUI.PythonApi.Customizing Namespace


DataFieldCustomizing Methods

[image]

PLANTA API to IronPython
DataFieldCustomizing Methods
DataFieldCustomizing Interface See Also Send Feedback

The DataFieldCustomizing type exposes the following members.

Methods

 | Name | Description
Public method | get_customizing_name | Get DataFieldCustomizing name

See Also

DataFieldCustomizing Interface
GUI.PythonApi.Customizing Namespace


DataFieldCustomizing.get_customizing_name Method

DataFieldCustomizing..::..get_customizing_name Method
DataFieldCustomizing Interface See Also Send Feedback
Get DataFieldCustomizing name

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[str]""" def get_customizing_name()

Return Value

Type: String
DataFieldCustomizing name

See Also

DataFieldCustomizing Interface
DataFieldCustomizing Members
GUI.PythonApi.Customizing Namespace


DataFieldCustomizing Properties

[image]

PLANTA API to IronPython
DataFieldCustomizing Properties
DataFieldCustomizing Interface See Also Send Feedback

The DataFieldCustomizing type exposes the following members.

Properties

 | Name | Description
Public property | PythonScriptSettings | Python script settings. Customized script parameters.
Public property | RawTextFormat | Gets Raw Text format of DFC
Public property | Title | DFC title
Public property | Uid | Uid

See Also

DataFieldCustomizing Interface
GUI.PythonApi.Customizing Namespace


DataFieldCustomizing.PythonScriptSettings Property

DataFieldCustomizing..::..PythonScriptSettings Property
DataFieldCustomizing Interface See Also Send Feedback
Python script settings. Customized script parameters.

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[str]""" PythonScriptSettings """[C#]:{ get; }"""

Property Value

Type: String

See Also

DataFieldCustomizing Interface
DataFieldCustomizing Members
GUI.PythonApi.Customizing Namespace


DataFieldCustomizing.RawTextFormat Property

DataFieldCustomizing..::..RawTextFormat Property
DataFieldCustomizing Interface See Also Send Feedback
Gets Raw Text format of DFC

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[RawTextFormatInfo]""" RawTextFormat """[C#]:{ get; }"""

Property Value

Type: RawTextFormatInfo

See Also

DataFieldCustomizing Interface
DataFieldCustomizing Members
GUI.PythonApi.Customizing Namespace


DataFieldCustomizing.Title Property

DataFieldCustomizing..::..Title Property
DataFieldCustomizing Interface See Also Send Feedback
DFC title

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[str]""" Title """[C#]:{ get; }"""

Property Value

Type: String

See Also

DataFieldCustomizing Interface
DataFieldCustomizing Members
GUI.PythonApi.Customizing Namespace


DataFieldCustomizing.Uid Property

DataFieldCustomizing..::..Uid Property
DataFieldCustomizing Interface See Also Send Feedback
Uid

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[str]""" Uid """[C#]:{ get; }"""

Property Value

Type: String

See Also

DataFieldCustomizing Interface
DataFieldCustomizing Members
GUI.PythonApi.Customizing Namespace


ModuleCustomizing Interface

ModuleCustomizing Interface
Members See Also Send Feedback
Defines Python contract on Customizing

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[C#]:interface""" ModuleCustomizing

See Also

ModuleCustomizing Members
GUI.PythonApi.Customizing Namespace


ModuleCustomizing Members

[image]

PLANTA API to IronPython
ModuleCustomizing Members
ModuleCustomizing Interface Properties See Also Send Feedback

The ModuleCustomizing type exposes the following members.

Properties

 | Name | Description
Public property | Roots | All RootCustomizings of the Customizing
Public property | Uid | Uid

See Also

ModuleCustomizing Interface
GUI.PythonApi.Customizing Namespace


ModuleCustomizing Properties

[image]

PLANTA API to IronPython
ModuleCustomizing Properties
ModuleCustomizing Interface See Also Send Feedback

The ModuleCustomizing type exposes the following members.

Properties

 | Name | Description
Public property | Roots | All RootCustomizings of the Customizing
Public property | Uid | Uid

See Also

ModuleCustomizing Interface
GUI.PythonApi.Customizing Namespace


ModuleCustomizing.Roots Property

ModuleCustomizing..::..Roots Property
ModuleCustomizing Interface See Also Send Feedback
All RootCustomizings of the Customizing

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[IEnumerable<RootCustomizing>]""" Roots """[C#]:{ get; }"""

Property Value

Type: IEnumerable <(Of <(<' RootCustomizing >)>)>

See Also

ModuleCustomizing Interface
ModuleCustomizing Members
GUI.PythonApi.Customizing Namespace


ModuleCustomizing.Uid Property

ModuleCustomizing..::..Uid Property
ModuleCustomizing Interface See Also Send Feedback
Uid

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[str]""" Uid """[C#]:{ get; }"""

Property Value

Type: String

See Also

ModuleCustomizing Interface
ModuleCustomizing Members
GUI.PythonApi.Customizing Namespace


RawDataType Enumeration

RawDataType Enumeration
See Also Send Feedback
Raw DataField Data Type

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[C#]:enum""" RawDataType

Members

Member name | Value | Description
String | 0 | String
Integral | 1 | Integral
Decimal | 2 | Decimal
Date | 3 | Date
Time | 4 | Time
Currency | 5 | Currency

See Also

GUI.PythonApi.Customizing Namespace


RawTextFormatInfo Interface

RawTextFormatInfo Interface
Members See Also Send Feedback
Raw Text Format Info

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[C#]:interface""" RawTextFormatInfo

See Also

RawTextFormatInfo Members
GUI.PythonApi.Customizing Namespace


RawTextFormatInfo Members

[image]

PLANTA API to IronPython
RawTextFormatInfo Members
RawTextFormatInfo Interface Properties See Also Send Feedback

The RawTextFormatInfo type exposes the following members.

Properties

 | Name | Description
Public property | PDataType | Data type
Public property | SuffixSymbol | Suffix symbol
Public property | ZeroPadWidth | Zero pad width

See Also

RawTextFormatInfo Interface
GUI.PythonApi.Customizing Namespace


RawTextFormatInfo Properties

[image]

PLANTA API to IronPython
RawTextFormatInfo Properties
RawTextFormatInfo Interface See Also Send Feedback

The RawTextFormatInfo type exposes the following members.

Properties

 | Name | Description
Public property | PDataType | Data type
Public property | SuffixSymbol | Suffix symbol
Public property | ZeroPadWidth | Zero pad width

See Also

RawTextFormatInfo Interface
GUI.PythonApi.Customizing Namespace


RawTextFormatInfo.PDataType Property

RawTextFormatInfo..::..PDataType Property
RawTextFormatInfo Interface See Also Send Feedback
Data type

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[RawDataType]""" PDataType """[C#]:{ get; }"""

Property Value

Type: RawDataType

See Also

RawTextFormatInfo Interface
RawTextFormatInfo Members
GUI.PythonApi.Customizing Namespace


RawTextFormatInfo.SuffixSymbol Property

RawTextFormatInfo..::..SuffixSymbol Property
RawTextFormatInfo Interface See Also Send Feedback
Suffix symbol

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[str]""" SuffixSymbol """[C#]:{ get; }"""

Property Value

Type: String

See Also

RawTextFormatInfo Interface
RawTextFormatInfo Members
GUI.PythonApi.Customizing Namespace


RawTextFormatInfo.ZeroPadWidth Property

RawTextFormatInfo..::..ZeroPadWidth Property
RawTextFormatInfo Interface See Also Send Feedback
Zero pad width

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[int]""" ZeroPadWidth """[C#]:{ get; }"""

Property Value

Type: Int32

See Also

RawTextFormatInfo Interface
RawTextFormatInfo Members
GUI.PythonApi.Customizing Namespace


RootCustomizing Interface

RootCustomizing Interface
Members See Also Send Feedback
Defines Python contract on Customizing

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[C#]:interface""" RootCustomizing

See Also

RootCustomizing Members
GUI.PythonApi.Customizing Namespace


RootCustomizing Members

[image]

PLANTA API to IronPython
RootCustomizing Members
RootCustomizing Interface Methods Properties See Also Send Feedback

The RootCustomizing type exposes the following members.

Methods

 | Name | Description
Public method | GetDAC | Looks for DataAreaCustomizing with given uid

Properties

 | Name | Description
Public property | Uid | Uid
Public property | VirtualRootDAC | Virtual root DAC that groups all top level DACs.

See Also

RootCustomizing Interface
GUI.PythonApi.Customizing Namespace


RootCustomizing Methods

[image]

PLANTA API to IronPython
RootCustomizing Methods
RootCustomizing Interface See Also Send Feedback

The RootCustomizing type exposes the following members.

Methods

 | Name | Description
Public method | GetDAC | Looks for DataAreaCustomizing with given uid

See Also

RootCustomizing Interface
GUI.PythonApi.Customizing Namespace


RootCustomizing.GetDAC Method

RootCustomizing..::..GetDAC Method
RootCustomizing Interface See Also Send Feedback
Looks for DataAreaCustomizing with given uid

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[DataAreaCustomizing]""" def GetDAC(
    """[str]""" uid
)

Parameters

uid
Type: System..::..String
DataAreaCustomizing uid to search for

Return Value

Type: DataAreaCustomizing
DataAreaCustomizing with given UID or None if not found

See Also

RootCustomizing Interface
RootCustomizing Members
GUI.PythonApi.Customizing Namespace


RootCustomizing Properties

[image]

PLANTA API to IronPython
RootCustomizing Properties
RootCustomizing Interface See Also Send Feedback

The RootCustomizing type exposes the following members.

Properties

 | Name | Description
Public property | Uid | Uid
Public property | VirtualRootDAC | Virtual root DAC that groups all top level DACs.

See Also

RootCustomizing Interface
GUI.PythonApi.Customizing Namespace


RootCustomizing.Uid Property

RootCustomizing..::..Uid Property
RootCustomizing Interface See Also Send Feedback
Uid

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[str]""" Uid """[C#]:{ get; }"""

Property Value

Type: String

See Also

RootCustomizing Interface
RootCustomizing Members
GUI.PythonApi.Customizing Namespace


RootCustomizing.VirtualRootDAC Property

RootCustomizing..::..VirtualRootDAC Property
RootCustomizing Interface See Also Send Feedback
Virtual root DAC that groups all top level DACs.

Namespace: GUI.PythonApi.Customizing
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[DataAreaCustomizing]""" VirtualRootDAC """[C#]:{ get; }"""

Property Value

Type: DataAreaCustomizing

See Also

RootCustomizing Interface
RootCustomizing Members
GUI.PythonApi.Customizing Namespace


GUI.PythonApi.Data Namespace

GUI.PythonApi.Data Namespace
Send Feedback
Contains interfaces exposed to Python by Data objects

Interfaces

 | Interface | Description
Public interface | DataArea | Defines Python contract on DataArea
Public interface | DataField | Defines Python contract on DataField
Public interface | Module | Defines Python contract on Module
Public interface | Root | Defines Python contract on Root
Public interface | Sheet | Defines Python contract on Sheet
Public interface | SheetManager | Defines Python contract on SheetManager


DataArea Interface

DataArea Interface
Members See Also Send Feedback
Defines Python contract on DataArea

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[C#]:interface""" DataArea

See Also

DataArea Members
GUI.PythonApi.Data Namespace


DataArea Members

[image]

PLANTA API to IronPython
DataArea Members
DataArea Interface Methods Properties See Also Send Feedback

The DataArea type exposes the following members.

Methods

 | Name | Description
Public method | get_children | Get list of child DataAreas which belong to the DataAreaCustomizing with current custName
Public method | get_customizing_name | Get name of DataAreaCustomizing
Public method | get_dfc | Get DataFieldCustomizing with specified customizing name
Public method | get_id | Get ID of data area customizing
Public method | get_records | Get list of all DataAreas which belong to the customizing of current dataarea

Properties

 | Name | Description
Public property | ChildrenDF | DFs of DA
Public property | Customizing | DA customizing
Public property | DASheets | SheetManager of DA sheets
Public property | Uid | Uid

See Also

DataArea Interface
GUI.PythonApi.Data Namespace


DataArea Methods

[image]

PLANTA API to IronPython
DataArea Methods
DataArea Interface See Also Send Feedback

The DataArea type exposes the following members.

Methods

 | Name | Description
Public method | get_children | Get list of child DataAreas which belong to the DataAreaCustomizing with current custName
Public method | get_customizing_name | Get name of DataAreaCustomizing
Public method | get_dfc | Get DataFieldCustomizing with specified customizing name
Public method | get_id | Get ID of data area customizing
Public method | get_records | Get list of all DataAreas which belong to the customizing of current dataarea

See Also

DataArea Interface
GUI.PythonApi.Data Namespace


DataArea.get_children Method

DataArea..::..get_children Method
DataArea Interface See Also Send Feedback
Get list of child DataAreas which belong to the DataAreaCustomizing with current custName

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[List<DataArea>]""" def get_children(
    """[str]""" custName
)

Parameters

custName
Type: System..::..String
name of DataAreaCustomizing

Return Value

Type: List <(Of <(<' DataArea >)>)>
List of child DataAreas which belong to the DataAreaCustomizing with current custName

See Also

DataArea Interface
DataArea Members
GUI.PythonApi.Data Namespace


DataArea.get_customizing_name Method

DataArea..::..get_customizing_name Method
DataArea Interface See Also Send Feedback
Get name of DataAreaCustomizing

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[str]""" def get_customizing_name()

Return Value

Type: String
Name of DataAreaCustomizing

See Also

DataArea Interface
DataArea Members
GUI.PythonApi.Data Namespace


DataArea.get_dfc Method

DataArea..::..get_dfc Method
DataArea Interface See Also Send Feedback
Get DataFieldCustomizing with specified customizing name

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[DataFieldCustomizing]""" def get_dfc(
    """[str]""" custName
)

Parameters

custName
Type: System..::..String
name of DataFieldCustomizing

Return Value

Type: DataFieldCustomizing
DataFieldCustomizing instance with specified customizing name

See Also

DataArea Interface
DataArea Members
GUI.PythonApi.Data Namespace


DataArea.get_id Method

DataArea..::..get_id Method
DataArea Interface See Also Send Feedback
Get ID of data area customizing

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[str]""" def get_id()

Return Value

Type: String
Data area customizing ID

See Also

DataArea Interface
DataArea Members
GUI.PythonApi.Data Namespace


DataArea.get_records Method

DataArea..::..get_records Method
DataArea Interface See Also Send Feedback
Get list of all DataAreas which belong to the customizing of current dataarea

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[List<DataArea>]""" def get_records()

Return Value

Type: List <(Of <(<' DataArea >)>)>
List of all DataAreas which belong to the customizing of current dataarea

See Also

DataArea Interface
DataArea Members
GUI.PythonApi.Data Namespace


DataArea Properties

[image]

PLANTA API to IronPython
DataArea Properties
DataArea Interface See Also Send Feedback

The DataArea type exposes the following members.

Properties

 | Name | Description
Public property | ChildrenDF | DFs of DA
Public property | Customizing | DA customizing
Public property | DASheets | SheetManager of DA sheets
Public property | Uid | Uid

See Also

DataArea Interface
GUI.PythonApi.Data Namespace


DataArea.ChildrenDF Property

DataArea..::..ChildrenDF Property
DataArea Interface See Also Send Feedback
DFs of DA

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[IEnumerable<DataField>]""" ChildrenDF """[C#]:{ get; }"""

Property Value

Type: IEnumerable <(Of <(<' DataField >)>)>

See Also

DataArea Interface
DataArea Members
GUI.PythonApi.Data Namespace


DataArea.Customizing Property

DataArea..::..Customizing Property
DataArea Interface See Also Send Feedback
DA customizing

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[DataAreaCustomizing]""" Customizing """[C#]:{ get; }"""

Property Value

Type: DataAreaCustomizing

See Also

DataArea Interface
DataArea Members
GUI.PythonApi.Data Namespace


DataArea.DASheets Property

DataArea..::..DASheets Property
DataArea Interface See Also Send Feedback
SheetManager of DA sheets

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[SheetManager]""" DASheets """[C#]:{ get; }"""

Property Value

Type: SheetManager

See Also

DataArea Interface
DataArea Members
GUI.PythonApi.Data Namespace


DataArea.Uid Property

DataArea..::..Uid Property
DataArea Interface See Also Send Feedback
Uid

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[str]""" Uid """[C#]:{ get; }"""

Property Value

Type: String

See Also

DataArea Interface
DataArea Members
GUI.PythonApi.Data Namespace


DataField Interface

DataField Interface
Members See Also Send Feedback
Defines Python contract on DataField

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[C#]:interface""" DataField

See Also

DataField Members
GUI.PythonApi.Data Namespace


DataField Members

[image]

PLANTA API to IronPython
DataField Members
DataField Interface Methods Properties See Also Send Feedback

The DataField type exposes the following members.

Methods

 | Name | Description
Public method | get_customizing_name | Get customizing name of data field
Public method | GetValue<(Of <<'(T>)>>) | Gets DF value.
Public method | SetServerValue | Sets DF value, like if the user have changed it

Properties

 | Name | Description
Public property | Customizing | DF CU
Public property | HasRawText | Gets a value indicating whether the DataField has a raw value assigned.
Public property | RawText | Gets or sets a raw text (an unformatted value). This method should only be used when the parameter "Raw Format" is activated on DT406 for the data source DA.

See Also

DataField Interface
GUI.PythonApi.Data Namespace


DataField Methods

[image]

PLANTA API to IronPython
DataField Methods
DataField Interface See Also Send Feedback

The DataField type exposes the following members.

Methods

 | Name | Description
Public method | get_customizing_name | Get customizing name of data field
Public method | GetValue<(Of <<'(T>)>>) | Gets DF value.
Public method | SetServerValue | Sets DF value, like if the user have changed it

See Also

DataField Interface
GUI.PythonApi.Data Namespace


DataField.get_customizing_name Method

DataField..::..get_customizing_name Method
DataField Interface See Also Send Feedback
Get customizing name of data field

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[str]""" def get_customizing_name()

Return Value

Type: String
Customizing name of data field

See Also

DataField Interface
DataField Members
GUI.PythonApi.Data Namespace


DataField.GetValue(T) Method

DataField..::..GetValue<(Of <(<'T>)>)> Method
DataField Interface See Also Send Feedback
Gets DF value.

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[T]""" def GetValue()

Type Parameters

T
The type of Value to retrieve from DF. Consider reading remarks

Return Value

Type: T
DF value of type T

Remarks

The type of DF value is determined by its behavior. To make code typesafe this function is generic. So calling code must pass valid T when requesting DF value Depending on DF behavior a valid object type must be specified

DF behavior | T type
i2 and o2 | Boolean
c1-c4 | DataFieldButtonValue
h | DataFieldHlinkValue
a | BinaryImage
all other | String

See Also

DataField Interface
DataField Members
GUI.PythonApi.Data Namespace


DataField.SetServerValue Method

DataField..::..SetServerValue Method
DataField Interface See Also Send Feedback
Sets DF value, like if the user have changed it

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[None]""" def SetServerValue(
    """[ModuleLayout]""" ml,
    """[Object]""" value
)

Parameters

ml
Type: GUI.PythonApi.Layout..::..ModuleLayout
Module layout that caused the value to be set
value
Type: System..::..Object
Depending on DF behavior a valid object type must be specified. Read remarks to GetValue<(Of <<'(T>)>>)()()()()

See Also

DataField Interface
DataField Members
GUI.PythonApi.Data Namespace


DataField Properties

[image]

PLANTA API to IronPython
DataField Properties
DataField Interface See Also Send Feedback

The DataField type exposes the following members.

Properties

 | Name | Description
Public property | Customizing | DF CU
Public property | HasRawText | Gets a value indicating whether the DataField has a raw value assigned.
Public property | RawText | Gets or sets a raw text (an unformatted value). This method should only be used when the parameter "Raw Format" is activated on DT406 for the data source DA.

See Also

DataField Interface
GUI.PythonApi.Data Namespace


DataField.Customizing Property

DataField..::..Customizing Property
DataField Interface See Also Send Feedback
DF CU

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[DataFieldCustomizing]""" Customizing """[C#]:{ get; }"""

Property Value

Type: DataFieldCustomizing

See Also

DataField Interface
DataField Members
GUI.PythonApi.Data Namespace


DataField.HasRawText Property

DataField..::..HasRawText Property
DataField Interface See Also Send Feedback
Gets a value indicating whether the DataField has a raw value assigned.

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[bool]""" HasRawText """[C#]:{ get; set; }"""

Property Value

Type: Boolean

See Also

DataField Interface
DataField Members
GUI.PythonApi.Data Namespace


DataField.RawText Property

DataField..::..RawText Property
DataField Interface See Also Send Feedback
Gets or sets a raw text (an unformatted value). This method should only be used when the parameter "Raw Format" is activated on DT406 for the data source DA.

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[Object]""" RawText """[C#]:{ get; set; }"""

Property Value

Type: Object

See Also

DataField Interface
DataField Members
GUI.PythonApi.Data Namespace


Module Interface

Module Interface
Members See Also Send Feedback
Defines Python contract on Module

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[C#]:interface""" Module

See Also

Module Members
GUI.PythonApi.Data Namespace


Module Members

[image]

PLANTA API to IronPython
Module Members
Module Interface Methods Properties Events See Also Send Feedback

The Module type exposes the following members.

Methods

 | Name | Description
Public method | CreateExcelExportDocument | Create Excel export document which is used for exporting module content to Excel file. Usage example: 1) >>> import os >>> env = get_Env() >>> mod = env.ActivePanel.ModuleManager.__getitem__('10') >>> doc = mod.CreateExcelExportDocument(DACsCU_NamesToExport = {'Vorgang', 'Ressource'}, fullExportPath = os.path.normpath('C:/PlantaClient/Debug/Test'), exportLayout = True, adjustColors = True ) >>> env.GenerateExcelFile(doc) 2) >>> env = get_Env() >>> mod = env.ActivePanel.ModuleManager.__getitem__('10') >>> doc = mod.CreateExcelExportDocument(DACsCU_NamesToExport = {'Ressource'}, useBulkExport = True) >>> env.GenerateExcelFile(doc)
Public method | CreatePdfExportDocument | Create PDF export document, which is used for exporting module content to PDF file.
Public method | CreatePrintExportDocument | Create print export document, which is used for printing module.
Public method | ExportToExcelSetCurrencyFormatting | Apply any formatting to currency data-format. Use excel-custom-formatting style, fore details see excel formatting guide. For example: value == 100 formatting == # ##0$;-# ##0$ User sees: 100$
Public method | ExportToExcelWithDialog | Show excel export dialog
Public method | ExportToPdfWithDialog | Exports module to pdf file using dialog window.
Public method | get_dac | Get DataAreaCustomizing with specified customizing name
Public method | get_id | Get ID of module customizing

Properties

 | Name | Description
Public property | Customizing | Module customizing
Public property | Roots | All roots of the module
Public property | Uid | Uid

Events

 | Name | Description
Public event | DAChanged | Event

See Also

Module Interface
GUI.PythonApi.Data Namespace


Module Methods

[image]

PLANTA API to IronPython
Module Methods
Module Interface See Also Send Feedback

The Module type exposes the following members.

Methods

 | Name | Description
Public method | CreateExcelExportDocument | Create Excel export document which is used for exporting module content to Excel file. Usage example: 1) >>> import os >>> env = get_Env() >>> mod = env.ActivePanel.ModuleManager.__getitem__('10') >>> doc = mod.CreateExcelExportDocument(DACsCU_NamesToExport = {'Vorgang', 'Ressource'}, fullExportPath = os.path.normpath('C:/PlantaClient/Debug/Test'), exportLayout = True, adjustColors = True ) >>> env.GenerateExcelFile(doc) 2) >>> env = get_Env() >>> mod = env.ActivePanel.ModuleManager.__getitem__('10') >>> doc = mod.CreateExcelExportDocument(DACsCU_NamesToExport = {'Ressource'}, useBulkExport = True) >>> env.GenerateExcelFile(doc)
Public method | CreatePdfExportDocument | Create PDF export document, which is used for exporting module content to PDF file.
Public method | CreatePrintExportDocument | Create print export document, which is used for printing module.
Public method | ExportToExcelSetCurrencyFormatting | Apply any formatting to currency data-format. Use excel-custom-formatting style, fore details see excel formatting guide. For example: value == 100 formatting == # ##0$;-# ##0$ User sees: 100$
Public method | ExportToExcelWithDialog | Show excel export dialog
Public method | ExportToPdfWithDialog | Exports module to pdf file using dialog window.
Public method | get_dac | Get DataAreaCustomizing with specified customizing name
Public method | get_id | Get ID of module customizing

See Also

Module Interface
GUI.PythonApi.Data Namespace


Module.CreateExcelExportDocument Method

Module..::..CreateExcelExportDocument Method
Module Interface See Also Send Feedback
Create Excel export document which is used for exporting module content to Excel file.

Usage example:

1)

>>> import os

>>> env = get_Env()

>>> mod = env.ActivePanel.ModuleManager.__getitem__('10')

>>> doc = mod.CreateExcelExportDocument(DACsCU_NamesToExport = {'Vorgang', 'Ressource'}, fullExportPath = os.path.normpath('C:/PlantaClient/Debug/Test'), exportLayout = True, adjustColors = True )

>>> env.GenerateExcelFile(doc)

2)

>>> env = get_Env()

>>> mod = env.ActivePanel.ModuleManager.__getitem__('10')

>>> doc = mod.CreateExcelExportDocument(DACsCU_NamesToExport = {'Ressource'}, useBulkExport = True)

>>> env.GenerateExcelFile(doc)

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[ExcelExportDocument]""" def CreateExcelExportDocument(
    """[IEnumerable<str>]""" DACsCU_NamesToExport,
    """[str]""" fullExportPath,
    """[str]""" excelCurrencyFormat,
    """[bool]""" useBulkExport,
    """[bool]""" exportLayout,
    """[bool]""" adjustColors,
    """[bool]""" freezeFirstWindow,
    """[bool]""" rewriteExistedFile
)

Parameters

DACsCU_NamesToExport (Optional)
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' String >)>)>
List of data area customizings CU_name, that will be exported, default value == None (export all data). If bulk export is used, first element will be taken as default for bulk export, but recommended to use single element collection (DACsCU_NamesToExport = {'Ressource'})
fullExportPath (Optional)
Type: System..::..String
Full path, where exported document will be saved, default value == None (just display exported document). Usage example: CreateExcelExportDocument(fullExportPath = os.path.normpath('C:/SomeDir/OtherDir/FileName.xls')). Do not forget to use 'import os'. File extinction is not necessary.
excelCurrencyFormat (Optional)
Type: System..::..String
Apply any formatting to currency data-format. Use excel-custom-formatting style, fore details see excel formatting guide. For example: value == 100 formatting == # ##0$;-# ##0$ User sees: 100$ default value == None
useBulkExport (Optional)
Type: System..::..Boolean
Use bulkExport, default value == False
exportLayout (Optional)
Type: System..::..Boolean
Layout options: Export layout, default value == False
adjustColors (Optional)
Type: System..::..Boolean
Layout options: Adjust colors to the default palette, depends on exportLayout, if exportLayout == False, this param will be ignored, default value == False
freezeFirstWindow (Optional)
Type: System..::..Boolean
Use Excel freeze function for windows 1, default value == True
rewriteExistedFile (Optional)
Type: System..::..Boolean
try to rewrite file if it exist, default value == True

Return Value

Type: ExcelExportDocument
ExcelExportDocument instance if all configuration data is ok, None otherwise

See Also

Module Interface
Module Members
GUI.PythonApi.Data Namespace


Module.CreatePdfExportDocument Method

Module..::..CreatePdfExportDocument Method
Module Interface See Also Send Feedback
Create PDF export document, which is used for exporting module content to PDF file.

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[PdfExportDocument]""" def CreatePdfExportDocument(
    """[str]""" name,
    """[str]""" pageSize,
    """[Nullable<bool>]""" landscape,
    """[Nullable<bool>]""" fitToPage,
    """[Nullable<float>]""" zoom,
    """[Nullable<int>]""" marginLeft,
    """[Nullable<int>]""" marginRight,
    """[Nullable<int>]""" marginTop,
    """[Nullable<int>]""" marginBottom
)

Parameters

name (Optional)
Type: System..::..String
Document name, if it is not set or empty, it is taken from module name
pageSize (Optional)
Type: System..::..String
Page size: A4, A3, A2, if it is not set or empty, it is taken from module printing settings
landscape (Optional)
Type: System..::..Nullable <(Of <(<' Boolean >)>)>
Landscape orientation, if it is not set, it is taken from module printing settings
fitToPage (Optional)
Type: System..::..Nullable <(Of <(<' Boolean >)>)>
Fit content to page, if it is not set, it is taken from module printing settings. If it equals True, causes ignoring of the zoom
zoom (Optional)
Type: System..::..Nullable <(Of <(<' Single >)>)>
Content zoom factor in percents, if it is not set, it is taken from module printing settings. It is not accounted if the fitToPage = True
marginLeft (Optional)
Type: System..::..Nullable <(Of <(<' Int32 >)>)>
Margin left in dmm, if it is not set, it is taken from module printing settings
marginRight (Optional)
Type: System..::..Nullable <(Of <(<' Int32 >)>)>
Margin right in dmm, if it is not set, it is taken from module printing settings
marginTop (Optional)
Type: System..::..Nullable <(Of <(<' Int32 >)>)>
Margin top in dmm, if it is not set, it is taken from module printing settings
marginBottom (Optional)
Type: System..::..Nullable <(Of <(<' Int32 >)>)>
Margin bottom in dmm, if it is not set, it is taken from module printing settings

Return Value

Type: PdfExportDocument
PdfExportDocument

See Also

Module Interface
Module Members
GUI.PythonApi.Data Namespace


Module.CreatePrintExportDocument Method

Module..::..CreatePrintExportDocument Method
Module Interface See Also Send Feedback
Create print export document, which is used for printing module.

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[PrintExportDocument]""" def CreatePrintExportDocument(
    """[str]""" name,
    """[str]""" pageSize,
    """[Nullable<bool>]""" landscape,
    """[Nullable<bool>]""" fitToPage,
    """[Nullable<float>]""" zoom,
    """[Nullable<int>]""" marginLeft,
    """[Nullable<int>]""" marginRight,
    """[Nullable<int>]""" marginTop,
    """[Nullable<int>]""" marginBottom
)

Parameters

name (Optional)
Type: System..::..String
Document name, if it is not set or empty, it is taken from module name
pageSize (Optional)
Type: System..::..String
Page size: A4, A3, A2, if it is not set or empty, it is taken from module printing settings
landscape (Optional)
Type: System..::..Nullable <(Of <(<' Boolean >)>)>
Landscape orientation, if it is not set, it is taken from module printing settings
fitToPage (Optional)
Type: System..::..Nullable <(Of <(<' Boolean >)>)>
Fit content to page, if it is not set, it is taken from module printing settings. If it equals True, causes ignoring of the zoom
zoom (Optional)
Type: System..::..Nullable <(Of <(<' Single >)>)>
Content zoom factor in percents, if it is not set, it is taken from module printing settings. It is not accounted if the fitToPage = True
marginLeft (Optional)
Type: System..::..Nullable <(Of <(<' Int32 >)>)>
Margin left in dmm, if it is not set, it is taken from module printing settings
marginRight (Optional)
Type: System..::..Nullable <(Of <(<' Int32 >)>)>
Margin right in dmm, if it is not set, it is taken from module printing settings
marginTop (Optional)
Type: System..::..Nullable <(Of <(<' Int32 >)>)>
Margin top in dmm, if it is not set, it is taken from module printing settings
marginBottom (Optional)
Type: System..::..Nullable <(Of <(<' Int32 >)>)>
Margin bottom in dmm, if it is not set, it is taken from module printing settings

Return Value

Type: PrintExportDocument
PrintExportDocument

See Also

Module Interface
Module Members
GUI.PythonApi.Data Namespace


Module.ExportToExcelSetCurrencyFormatting Method

Module..::..ExportToExcelSetCurrencyFormatting Method
Module Interface See Also Send Feedback
Apply any formatting to currency data-format. Use excel-custom-formatting style, fore details see excel formatting guide. For example: value == 100 formatting == # ##0$;-# ##0$ User sees: 100$

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[bool]""" def ExportToExcelSetCurrencyFormatting(
    """[str]""" formatting
)

Parameters

formatting
Type: System..::..String
needed formatting

Return Value

Type: Boolean
True if formatting is valid, False otherwise

See Also

Module Interface
Module Members
GUI.PythonApi.Data Namespace


Module.ExportToExcelWithDialog Method

Module..::..ExportToExcelWithDialog Method
Module Interface See Also Send Feedback
Show excel export dialog

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[bool]""" def ExportToExcelWithDialog()

Return Value

Type: Boolean
True if action is successfully, False otherwise

See Also

Module Interface
Module Members
GUI.PythonApi.Data Namespace


Module.ExportToPdfWithDialog Method

Module..::..ExportToPdfWithDialog Method
Module Interface See Also Send Feedback
Exports module to pdf file using dialog window.

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[bool]""" def ExportToPdfWithDialog(
    """[str]""" directory,
    """[str]""" name
)

Parameters

directory (Optional)
Type: System..::..String
Output directory. If value is None, the execution path of the client will be used. Default value is None.
name (Optional)
Type: System..::..String
Module name. If value is None, the Name property of the customizing will be used. Default value is None.

Return Value

Type: Boolean
True if export is successful, False otherwise

See Also

Module Interface
Module Members
GUI.PythonApi.Data Namespace


Module.get_dac Method

Module..::..get_dac Method
Module Interface See Also Send Feedback
Get DataAreaCustomizing with specified customizing name

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[DataAreaCustomizing]""" def get_dac(
    """[str]""" custName
)

Parameters

custName
Type: System..::..String
CU_name of the DataAreaCustomizing

Return Value

Type: DataAreaCustomizing
DataAreaCustomizing with specified customizing name or None if not found

See Also

Module Interface
Module Members
GUI.PythonApi.Data Namespace


Module.get_id Method

Module..::..get_id Method
Module Interface See Also Send Feedback
Get ID of module customizing

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[str]""" def get_id()

Return Value

Type: String
ID of module customizing

See Also

Module Interface
Module Members
GUI.PythonApi.Data Namespace


Module Properties

[image]

PLANTA API to IronPython
Module Properties
Module Interface See Also Send Feedback

The Module type exposes the following members.

Properties

 | Name | Description
Public property | Customizing | Module customizing
Public property | Roots | All roots of the module
Public property | Uid | Uid

See Also

Module Interface
GUI.PythonApi.Data Namespace


Module.Customizing Property

Module..::..Customizing Property
Module Interface See Also Send Feedback
Module customizing

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[ModuleCustomizing]""" Customizing """[C#]:{ get; }"""

Property Value

Type: ModuleCustomizing

See Also

Module Interface
Module Members
GUI.PythonApi.Data Namespace


Module.Roots Property

Module..::..Roots Property
Module Interface See Also Send Feedback
All roots of the module

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[IEnumerable<Root>]""" Roots """[C#]:{ get; }"""

Property Value

Type: IEnumerable <(Of <(<' Root >)>)>

See Also

Module Interface
Module Members
GUI.PythonApi.Data Namespace


Module.Uid Property

Module..::..Uid Property
Module Interface See Also Send Feedback
Uid

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[str]""" Uid """[C#]:{ get; }"""

Property Value

Type: String

See Also

Module Interface
Module Members
GUI.PythonApi.Data Namespace


Module Events

[image]

PLANTA API to IronPython
Module Events
Module Interface See Also Send Feedback

The Module type exposes the following members.

Events

 | Name | Description
Public event | DAChanged | Event

See Also

Module Interface
GUI.PythonApi.Data Namespace


Module.DAChanged Event

Module..::..DAChanged Event
Module Interface See Also Send Feedback
Event

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
#[C#]:
"""event EventHandler DAChanged"""

Value

Type: System..::..EventHandler

See Also

Module Interface
Module Members
GUI.PythonApi.Data Namespace


Root Interface

Root Interface
Members See Also Send Feedback
Defines Python contract on Root

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[C#]:interface""" Root

See Also

Root Members
GUI.PythonApi.Data Namespace


Root Members

[image]

PLANTA API to IronPython
Root Members
Root Interface Methods Properties See Also Send Feedback

The Root type exposes the following members.

Methods

 | Name | Description
Public method | get_dac | Get DataAreaCustomizing with specified customizing name
Public method | get_records | Get list of all DataAreas which belong to the DataAreaCustomizing with current CU_name
Public method | GetDA | Looks for DA with given uid

Properties

 | Name | Description
Public property | Customizing | Root Customizing
Public property | Uid | Uid
Public property | VirtualRootDA | Virtual root DA that groups all top level DAs.

See Also

Root Interface
GUI.PythonApi.Data Namespace


Root Methods

[image]

PLANTA API to IronPython
Root Methods
Root Interface See Also Send Feedback

The Root type exposes the following members.

Methods

 | Name | Description
Public method | get_dac | Get DataAreaCustomizing with specified customizing name
Public method | get_records | Get list of all DataAreas which belong to the DataAreaCustomizing with current CU_name
Public method | GetDA | Looks for DA with given uid

See Also

Root Interface
GUI.PythonApi.Data Namespace


Root.get_dac Method

Root..::..get_dac Method
Root Interface See Also Send Feedback
Get DataAreaCustomizing with specified customizing name

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[DataAreaCustomizing]""" def get_dac(
    """[str]""" custName
)

Parameters

custName
Type: System..::..String
CU_name of the DataAreaCustomizing

Return Value

Type: DataAreaCustomizing
DataAreaCustomizing with specified customizing name

See Also

Root Interface
Root Members
GUI.PythonApi.Data Namespace


Root.get_records Method

Root..::..get_records Method
Root Interface See Also Send Feedback
Get list of all DataAreas which belong to the DataAreaCustomizing with current CU_name

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[List<DataArea>]""" def get_records(
    """[str]""" custName
)

Parameters

custName
Type: System..::..String
CU_name of the DataAreaCustomizing

Return Value

Type: List <(Of <(<' DataArea >)>)>
List of all DataAreas which belong to the DataAreaCustomizing with current CU_name

See Also

Root Interface
Root Members
GUI.PythonApi.Data Namespace


Root.GetDA Method

Root..::..GetDA Method
Root Interface See Also Send Feedback
Looks for DA with given uid

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[DataArea]""" def GetDA(
    """[str]""" uid
)

Parameters

uid
Type: System..::..String
Uid of DA to look for

Return Value

Type: DataArea
DA with given UID or None if not found

See Also

Root Interface
Root Members
GUI.PythonApi.Data Namespace


Root Properties

[image]

PLANTA API to IronPython
Root Properties
Root Interface See Also Send Feedback

The Root type exposes the following members.

Properties

 | Name | Description
Public property | Customizing | Root Customizing
Public property | Uid | Uid
Public property | VirtualRootDA | Virtual root DA that groups all top level DAs.

See Also

Root Interface
GUI.PythonApi.Data Namespace


Root.Customizing Property

Root..::..Customizing Property
Root Interface See Also Send Feedback
Root Customizing

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[RootCustomizing]""" Customizing """[C#]:{ get; }"""

Property Value

Type: RootCustomizing

See Also

Root Interface
Root Members
GUI.PythonApi.Data Namespace


Root.Uid Property

Root..::..Uid Property
Root Interface See Also Send Feedback
Uid

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[str]""" Uid """[C#]:{ get; }"""

Property Value

Type: String

See Also

Root Interface
Root Members
GUI.PythonApi.Data Namespace


Root.VirtualRootDA Property

Root..::..VirtualRootDA Property
Root Interface See Also Send Feedback
Virtual root DA that groups all top level DAs.

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[DataArea]""" VirtualRootDA """[C#]:{ get; }"""

Property Value

Type: DataArea

See Also

Root Interface
Root Members
GUI.PythonApi.Data Namespace


Sheet Interface

Sheet Interface
Members See Also Send Feedback
Defines Python contract on Sheet

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[C#]:interface""" Sheet

See Also

Sheet Members
GUI.PythonApi.Data Namespace


Sheet Members

[image]

PLANTA API to IronPython
Sheet Members
Sheet Interface Properties See Also Send Feedback

The Sheet type exposes the following members.

Methods

 | Name | Description
Public method | GetEnumerator()()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable <(Of <(<' DataArea >)>)>.)
Public method | GetEnumerator()()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

Properties

 | Name | Description
Public property | Uid | Uid

See Also

Sheet Interface
GUI.PythonApi.Data Namespace


Sheet Methods

[image]

PLANTA API to IronPython
Sheet Methods
Sheet Interface See Also Send Feedback

Methods

 | Name | Description
Public method | GetEnumerator()()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable <(Of <(<' DataArea >)>)>.)
Public method | GetEnumerator()()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

Sheet Interface
GUI.PythonApi.Data Namespace


Sheet Properties

[image]

PLANTA API to IronPython
Sheet Properties
Sheet Interface See Also Send Feedback

The Sheet type exposes the following members.

Properties

 | Name | Description
Public property | Uid | Uid

See Also

Sheet Interface
GUI.PythonApi.Data Namespace


Sheet.Uid Property

Sheet..::..Uid Property
Sheet Interface See Also Send Feedback
Uid

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[str]""" Uid """[C#]:{ get; }"""

Property Value

Type: String

See Also

Sheet Interface
Sheet Members
GUI.PythonApi.Data Namespace


SheetManager Interface

SheetManager Interface
Members See Also Send Feedback
Defines Python contract on SheetManager

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[C#]:interface""" SheetManager

See Also

SheetManager Members
GUI.PythonApi.Data Namespace


SheetManager Members

[image]

PLANTA API to IronPython
SheetManager Members
SheetManager Interface Properties See Also Send Feedback

The SheetManager type exposes the following members.

Properties

 | Name | Description
Public property | ActiveSheet | Currently active sheet of DataArea.

See Also

SheetManager Interface
GUI.PythonApi.Data Namespace


SheetManager Properties

[image]

PLANTA API to IronPython
SheetManager Properties
SheetManager Interface See Also Send Feedback

The SheetManager type exposes the following members.

Properties

 | Name | Description
Public property | ActiveSheet | Currently active sheet of DataArea.

See Also

SheetManager Interface
GUI.PythonApi.Data Namespace


SheetManager.ActiveSheet Property

SheetManager..::..ActiveSheet Property
SheetManager Interface See Also Send Feedback
Currently active sheet of DataArea.

Namespace: GUI.PythonApi.Data
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[Sheet]""" ActiveSheet """[C#]:{ get; }"""

Property Value

Type: Sheet

See Also

SheetManager Interface
SheetManager Members
GUI.PythonApi.Data Namespace


GUI.PythonApi.Export Namespace

GUI.PythonApi.Export Namespace
Send Feedback
Defines Python contracts on the documents export

Interfaces

 | Interface | Description
Public interface | ExcelExportDocument | Defines Python contract on ExcelExportDocument. This document is used for exporting module content to Excel file.
Public interface | PdfExportDocument | Defines Python contract on PdfExportDocument. This document is used for exporting module content to PDF file.
Public interface | PrintExportDocument | Defines Python contract on PrintExportDocument. This document is used for printing module.


ExcelExportDocument Interface

ExcelExportDocument Interface
See Also Send Feedback
Defines Python contract on ExcelExportDocument. This document is used for exporting module content to Excel file.

Namespace: GUI.PythonApi.Export
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[C#]:interface""" ExcelExportDocument

See Also

GUI.PythonApi.Export Namespace


PdfExportDocument Interface

PdfExportDocument Interface
See Also Send Feedback
Defines Python contract on PdfExportDocument. This document is used for exporting module content to PDF file.

Namespace: GUI.PythonApi.Export
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[C#]:interface""" PdfExportDocument

See Also

GUI.PythonApi.Export Namespace


PrintExportDocument Interface

PrintExportDocument Interface
See Also Send Feedback
Defines Python contract on PrintExportDocument. This document is used for printing module.

Namespace: GUI.PythonApi.Export
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[C#]:interface""" PrintExportDocument

See Also

GUI.PythonApi.Export Namespace


GUI.PythonApi.Layout Namespace

GUI.PythonApi.Layout Namespace
Send Feedback
Contains interfaces exposed to Python by View layer

Interfaces

 | Interface | Description
Public interface | ModuleLayout | Defines Python contract on ModuleLayout


ModuleLayout Interface

ModuleLayout Interface
Members See Also Send Feedback
Defines Python contract on ModuleLayout

Namespace: GUI.PythonApi.Layout
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[C#]:interface""" ModuleLayout

See Also

ModuleLayout Members
GUI.PythonApi.Layout Namespace


ModuleLayout Members

[image]

PLANTA API to IronPython
ModuleLayout Members
ModuleLayout Interface Methods Properties See Also Send Feedback

The ModuleLayout type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Activates the DF

Properties

 | Name | Description
Public property | Module | Module for which the layout was build for

See Also

ModuleLayout Interface
GUI.PythonApi.Layout Namespace


ModuleLayout Methods

[image]

PLANTA API to IronPython
ModuleLayout Methods
ModuleLayout Interface See Also Send Feedback

The ModuleLayout type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Activates the DF

See Also

ModuleLayout Interface
GUI.PythonApi.Layout Namespace


ModuleLayout.Activate Method

ModuleLayout..::..Activate Method
ModuleLayout Interface See Also Send Feedback
Activates the DF

Namespace: GUI.PythonApi.Layout
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[bool]""" def Activate(
    """[DataField]""" df
)

Parameters

df
Type: GUI.PythonApi.Data..::..DataField
DF to activate

Return Value

Type: Boolean
True if DF was activated, False if it cant be activated

Remarks

The following table shows fields that can be activated and corresponding user action to activate the field

DF behavior | User action
c1-c4 | Button press
e1-e4 | LMouse click
f1-f4 | LMouse doubleclick
g1-g4 | Enter key press
h | LMouse click

See Also

ModuleLayout Interface
ModuleLayout Members
GUI.PythonApi.Layout Namespace


ModuleLayout Properties

[image]

PLANTA API to IronPython
ModuleLayout Properties
ModuleLayout Interface See Also Send Feedback

The ModuleLayout type exposes the following members.

Properties

 | Name | Description
Public property | Module | Module for which the layout was build for

See Also

ModuleLayout Interface
GUI.PythonApi.Layout Namespace


ModuleLayout.Module Property

ModuleLayout..::..Module Property
ModuleLayout Interface See Also Send Feedback
Module for which the layout was build for

Namespace: GUI.PythonApi.Layout
Assembly: PythonApi (in PythonApi.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

Python
"""[Module]""" Module """[C#]:{ get; }"""

Property Value

Type: Module

See Also

ModuleLayout Interface
ModuleLayout Members
GUI.PythonApi.Layout Namespace


Variables of embedded controls

Variables of embedded controls
Send Feedback

Description of scope variables which are available in DF scripts

Here you can find variables which can be used from python DF scripts directly.

Variables

df
DataField
Embedded control owner DataFiled

moduleLayout
Embedded control owner ModuleLayout

ctl
Control
Embedded control